macrog
Contributor
Contributor

Insufficient permissions to access the file

Jump to solution

I have just begun using VMWare, but am an experienced mac tech. Here's the issue:

I upgraded the hard drive on my Macbook and did a clean install of 10.4.11 with all updates. the user was "mac", and i used that account to run all the program installs and updates, including the latest version of Fusion. Then I took my old hard drive, connected it via firewire to my macbook and imported the data and settings thru Migration Asst.

I rebooted, logged into the new account, rog, and deleted the "mac" account, on which i had installed Fusion - note that I created the Virtual Machines folder in the Users\Shared folder, so the Win XP Pro install is still there, it was not deleted when i deleted the user "mac account".

now the problem is that when i open vmware fusion and point it to the Windows XP Pro in the Virtual Machines folder - i get the error "Insufficient permissions to access the file". i have tried to repair permissions, change permissions in the Get Info window on the Share folder, but i still get the same error.

does any one know how to fix this so that 1. i don't have to reinstall xp, and 2. so that the Virtual Machine can be shared by all users of the macbook?

thank you for your help,

roger

0 Kudos
1 Solution

Accepted Solutions
WoodyZ
Immortal
Immortal

Okay you said "but am an experienced mac tech" so are you saying then you have used the "chown" and or "chmod" commands in a Terminal to set proper ownership, group and permissions and still can't access the files in question?

View solution in original post

0 Kudos
14 Replies
admin
Immortal
Immortal

VMware Fusion virtual machines are really bundles, not single files - you also have to fix the permissions of all the contents. See for how to get inside a bundle. It also covers how to share a virtual machine between users.

0 Kudos
macrog
Contributor
Contributor

etung, thank you for your reply. however, i did not find any answers in that page or in browsing around that say how to resolve the issue specified. i saw that others had the same issue, but could not find a clear cut anwser on how to solve the problem. if i have to research for too long, it would be faster to just reinstall fusion and xp. i was hoping to find a quicker solution.

0 Kudos
macrog
Contributor
Contributor

another note - since the error "Insufficient permissions to access the file" is directly from the programming code in VMWare Fusion, you would think it would show results on the support site

that would direct users on how to solve the issue. when i searched support for the Fusion product, i did not get any help to resolve the issue.

0 Kudos
WoodyZ
Immortal
Immortal

Okay you said "but am an experienced mac tech" so are you saying then you have used the "chown" and or "chmod" commands in a Terminal to set proper ownership, group and permissions and still can't access the files in question?

0 Kudos
macrog
Contributor
Contributor

i wish i was but i'm not an expert or advanced unix/linux user. i can get around a little with terminal, and am familiar with chown and chmod, but no, i don't how to get around well enough yet to do that.

i did find the items in the show package contents but when i get info on all 5 items, they don't show what program to open with. should i set them all to VMare, and change the permissions? what group do i choose?

thanks

0 Kudos
macrog
Contributor
Contributor

etung, i reset the application and permissions using the show package contents, and that solved the prolblem. the only thing left is what group to select for the correct group permissions. thanks again.

0 Kudos
macrog
Contributor
Contributor

the other part of the issue was to be able to share the vm for all users, so can you please tell me what would be the correct settings on the permissions for user, group, and others? thank you.

0 Kudos
WoodyZ
Immortal
Immortal

What is the fully qualified pathname of the target Virtual Machine Bundle Package?

Note: Click the Reply link to this Post and the drag & drop the target Virtual Machine Bundle Package into the Reply and this will give the FQP.

Example: /Users/Shared/VMware Fusion/Virtual Machines/Windows XP.vmwarevm

Copy and Paste the following in a Terminal then press Enter and paste the output in the reply with the FPQ of the target Virtual Machine.

echo $

0 Kudos
macrog
Contributor
Contributor

/Users/Shared/Virtual Machines/Windows XP Professional.vmwarevm

rog is the user

0 Kudos
WoodyZ
Immortal
Immortal

Copy & Paste the following command line in a Terminal (/Applications/Utilities/Terminal) then press Enter.

ls -alR "/Users/Shared/Virtual Machines/Windows XP Professional.vmwarevm" > ~/Desktop/dirlist.txt

This will create a file named dirlist.txt on your Desktop then attach the dirlist.txt file to a reply post.

0 Kudos
macrog
Contributor
Contributor

see attached, thanks

0 Kudos
WoodyZ
Immortal
Immortal

With the Virtual Machine shutdown and not suspended...

Copy & Paste the following command lines one at a time in a Terminal pressing Enter after each and entering your password.

sudo chown -R rog "/Users/Shared/VMware Fusion/Virtual Machines/Windows XP Professional.vmwarevm"

sudo chown -R :wheel "/Users/Shared/VMware Fusion/Virtual Machines/Windows XP Professional.vmwarevm"

0 Kudos
zanzig
Contributor
Contributor

hi,

can i also get the same help from the experts here please?

i tried doing the commands on the terminal to no avail.

i think im not doing it right.

im attaching my dirlist file here.

thanks again.

0 Kudos
WoodyZ
Immortal
Immortal

can i also get the same help from the experts here please?

Copy and paste the following command line, as is without modifying it, in a Terminal (/Applications/Utilities/Terminal) then press Enter and type in your password and press Enter. Note: Be sure to copy the entire command line below starting with "sudo" and ending with the quote " at the end of the line.

sudo chown -R $:staff "/Users/$/Documents/Virtual Machines/Windows XP Professional.vmwarevm"

0 Kudos