VMware Communities
InamBhatti
Contributor
Contributor

Installing EVE-NG on MAC - M2 Chip

I have just recently upgraded to MAC M2 Chip,  VMware running perfectly fine, whereas installing EVE-NG is failing. to install as the package is based on X86,  is there a way to install Eve-NG  or is there a ARM version. 

 

Screenshot 2024-02-26 at 9.52.11 PM.png

Reply
0 Kudos
3 Replies
ColoradoMarmot
Champion
Champion

You can’t run an intel OS on an ARM machine - that’s like trying to run a gasoline car on diesel fuel.

You’ll either need to find an ARM version, or switch back to an intel machine.

There are CPU emulators like UTM, but the performance is very poor (basically unusable).

Reply
0 Kudos
Technogeezer
Immortal
Immortal

From the EVE-NG system requirements at https://www.eve-ng.net/index.php/documentation/installation/system-requirement/

emphasis mine:

EVE-NG CE and PE Supported platforms and systems:

  • Intel CPU VT-x/EPT
  • One of the following:
    • Ubuntu Focal Fossa 20.04.X LTS 64bit Server as OS for EVE.  
    • VMware ESXi 6.7 or later
    • VMware Workstation 15.0 or later
    • VMware Fusion 8 or later
    • VMware Player 15.0 or later
    • Google Cloud platform VM
    • AMD Ryzen 3900, the newer AMD EPYC  should work as well. Please consult to EVE support for CPU tune before use.  Older series AMD can have issues

NOT supported or have serious issues:

Using platforms or systems listed below, is user responsibiliy and not officially supported.

  • Upgrade your Linux OS to the newer Ubuntu 22.04 or later, will bring you to non-working EVE, roll-back after such upgrade is impossible. Please use only the exact version which is supported
  • MAC OSX Big Sur, Monterey and Ventura currently is not supported
  • MAC M1, M2 and M3 CPUs are not supported due issues with VMWare Fusion and nested CPU.
  • Oracle VM Virtual Box does not support HW acceleration !!! Avoid to using it !!!! 
  • VM Ware NAS or DAS storages as EVE HDD, please choose local HDD only
  • MS Hyper-V, issues with nested virtualization
  • Proxmox, it has serious issues with nested virtualization, any glitches or issues are not supported by EVE-NG Team.
  • XEN Citrix, it has serious issues with nested virtualization, any glitches or issues are not supported by EVE-NG Team.
  • Azure cloud is not officially supported, because Azure overwrite kernel for EVE VM, and do not accept custom Kernels for VM Machines.
  • AWS cloud is not officially supported due issues with sub-virtualization. It has issues to run Qemu nodes
  • Nutanix, issues with nested virtualization
  • NAS, SAN or DAS is not supported for EVE HDD system
  • USB as external HDD is not supported
  • Other virtual or nested cloud platforms are not officially supported.

There is no ARM version of the VM.  You will need to run EVE-NG on an Intel PC or Mac.

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides
Reply
0 Kudos
dempson
Hot Shot
Hot Shot


@Technogeezer wrote:

There is no ARM version of the VM.  You will need to run EVE-NG on an Intel PC or Mac.


Further points, based on the information in the exclusion list and reading between the lines:

The fact that Big Sur and later are not supported means that EVE-NG is not compatible with VMware Fusion running on Big Sur or later, which implies it is not compatible with Apple's hypervisor, probably also due to lack of support for nested virtualisation in the Apple hypervisor.

That means to run EVE-NG on an Intel Mac in VMware Fusion, the Mac must be running macOS Catalina or earlier, and you need VMware Fusion 12.1.2 or earlier, so that VMware's own hypervisor is used rather than Apple's one.

Not mentioned in the list, but the repeated warnings about nested virtualisation implies that you would also need to be running on a Mac which has a CPU that supports nested virtualisation in VMware Fusion 12.1.2 or earlier. This is a somewhat scattered and not obvious set of models.

For example, the Late 2019 16-inch MacBook Pro and mid 2019 15-inch MacBook Pro had three processor variants available, and of the three only the middle one supported nested virtualisation (not the cheapest and most expensive ones).

One way to check is to find the exact Intel processor used in a particular Mac (which Apple doesn't specify but can be found in third party resources such as everymac.com or the MacTracker utility), then look up that processor on ark.intel.com and see if it supports the "vPro" feature. The ones that mention vPro can do nested virtualisation in VMware Fusion 12.1.2 and earlier.

I don't have enough experience with VMware Workstation to know whether the same rule applies on the PC side of the fence.

Reply
0 Kudos