Faim-Media
Contributor
Contributor

IP-address and DHCP reservation with Fusion on macOS Big Sur

Hi,

I've had this problem on three machines already that I've upgraded from Catalina to Big Sur in combination with Fusion 12.

I've added (at the bottom of the file) a DHCP reservation to the /Library/Preferences/VMware Fusion/vmnet8/dhcpd.conf file, with the following lines:

 

host fusion.test {
    hardware ethernet 00:0c:29:db:27:63;
    fixed-address 192.168.121.100;
}

 


This was working perfectly in Catalina, but since the upgrade I just get an IP-address in the same range, but ending with .2
The mac address hasn't changed since the upgrade. I've tried releasing and renewing the IP address on the guest, even tried setting a static address on the guest, removing the network adapter and re-add, but that all doesn't work. It seems  not honor the DHCP reservation, or even the range for that matter, because it should be between .128 - .254, but it assigns .2.

How can I fix this, or how can I set a static address for my client? The adapter is shared with my Mac.

With kind regards,

Tim

9 Replies
snobis
Enthusiast
Enthusiast

I have kind of the same problem. Even without a fixed address, my Windows guest always gets a 192.168.xxx.2 address via vmnet8. The config in /Library/Preferences/VMware\ Fusion/vmnet8/dhcpd.conf explicitly defines a range between .128 and .254 (of my manually choosen subnet). Additionally, in /var/db/vmware/vmnet-dhcpd-vmnet8.leases the MAC of my guest is explicitly mentioned and associated with an address like 192.168.xxx.134. But still, no luck getting any valid address via DHCP for my guest. The guest always gets the .2 address. What's worse: This is the address DHCP assigns for DNS (but the NAT host/gateway that also provides DNS is on .1). Thus network in the guest is quite broken (using plain IP works, but no name resolution is possible).

I tried to manually override some of the configuration files, like assign a different IP for the DNS server. But that does not work. When I shutdown Fusion, edit e.g. /Library/Preferences/VMware\ Fusion/vmnet8/dhcpd.conf and the restart Fusion, my changes are gone and the config file has been overwritten (I have no clue where the data is saved that is used to overwrite the config files).

It seems Fusion on Big Sur is currently in a rather shaky state (at least NAT/DHCP). My current workaround is to configure IP statically inside the guest and not use DHCP.

I hope this will get fixed soon. And any hints where Fusion currently stores its master settings for vmnet8 nat.conf and dhcpd.conf are also welcome!

0 Kudos
dmpm
Contributor
Contributor

The reason seems to be explained here: https://communities.vmware.com/t5/VMware-Fusion-Discussions/Big-Sur-hosts-with-Fusion-Is-vmnet-dhcpd...,

 

TL;DR: Big Sur does not allow Fusion to run its own DHCP server and forces it to use Apple's implementation.

0 Kudos
simonanthony
Contributor
Contributor

Yep, same problem. Thereby removing at a stroke one of the principal points for Fusion Professional (i.e. multiple subnet support). I have vmnet1, vmnet2, and vmnet3 in addition to the NAT vmnet8 to demonstrate and test various networking configurations. I do not believe that using Apple DHCP is a viable workaround.

0 Kudos
dmpm
Contributor
Contributor

Agreed, multiple host-only subnets without DHCP is the only reason I went for Pro.

0 Kudos
bauern
Contributor
Contributor

A big disappointment. Just upgraded Fusion and Mac OS. 
Hope there will be a fix to this. 
Working with lab "copy of customers real environment" on the go.
Need it's own DHCP setup integrated with AD. 

Anyone have a workaround other than downgrade ?

 

With kind regards

Knut Erik 

 

0 Kudos
nancyz
VMware Employee
VMware Employee

Hi @bauern ,

The IP range for VMs has been changed on Big Sur, this could be get in /Library/Preferences/VMware Fusion/vmnet8/nat.conf,  Could you try to  reassign the IP in your AD server and check if that could resolve your issue? Here's a link for your reference:

https://kb.vmware.com/s/article/80793 Hope that could help.

0 Kudos
nancyz
VMware Employee
VMware Employee

Hi @dmpm ,

The IP range for VMs has been changed on Big Sur. You may need to reset the IP range. Here's a link for your references:https://kb.vmware.com/s/article/80793. Hope it could help.

 

0 Kudos
dmpm
Contributor
Contributor

Thanks for your reply. Unfortunately it still seems to start a DHCP server. Setting a static IP in every VM every time is very annoying, and also creates a security risk (there is an active internet gateway in the private network that can route traffic outside of my dedicated firewall VM).

0 Kudos
jaearick1
Contributor
Contributor

I found a solution to this mess at the bottom of 

https://communities.vmware.com/t5/VMware-Fusion-Discussions/Big-Sur-hosts-with-Fusion-Is-vmnet-dhcpd...

but I will post it here too.  Create the file /etc/bootptab on your Mac via a terminal sudo/root login.  Also, read the manpage for bootptab first.  The file /etc/bootptab does not exist in "Bug" Sur and its creation will not affect your Mac's ability to boot up.  

In my case, for a Centos 8 vmware host named "blorg", I created the following file:

# bootptab file for Big Sur and VMWare Fusion 12.1 to get fixed IPs working

%%

# hostname hwtype hwaddr ipaddr bootfile

blorg.local 1 00:0c:29:28:25:f7 172.16.20.251 boot

After installing this file and rebooting my Centos vmware host, I properly got the 172.16.20.251 IP number I wanted for host "blorg".  This IP number is in the upper half of the class C 172.16.20.x, as specified in the /Library/Preferences/VMware Fusion/vmnet8 file.  The vmnet8 file was what I previously used in Catalina to specify fixed IP numbers, with "host" declarations therein.  Note: I did not know what to use for the hwtype and bootfile args, so I just followed the example from the manpage and it worked.

0 Kudos