asyfasyf
Contributor
Contributor

I can't download VMware Fusion 12 on Mac even though I have catalina

I tried to download VMware Fusion 12 on my mac 10.15.7 Catalina, but it says I need an 11.0 to download it. On the website, it says that VMware Fusion could be run on a 10.15+, so I'm confused about what to do.  

Screen Shot 2021-10-23 at 8.40.46 PM.png

0 Kudos
7 Replies
wila
Immortal
Immortal

Hi,

That's a case of the documentation not having catched up with the latest release.

VMware Fusion 12.2 needs at least macOS Big Sur to run. They just dropped Catalina off the list.
See:
https://blogs.vmware.com/teamfusion/2021/10/fusion-12-2-now-available.html

snippet:
"This update is provided to users on macOS 11 Big Sur and later, and extends the “general support” period of Fusion 12 Pro and Fusion 12 Player to December 2022, meaning we will continue to provide updates which include features, bugfixes and security enhancements."

For now you can download Fusion 12.1.2 here: https://customerconnect.vmware.com/downloads/details?downloadGroup=FUS-1212&productId=1040&rPId=5596...

That should work OK with Catalina.

Hope this helps,
--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Parrot60
Contributor
Contributor

Is version 12.1.2 still a free a free version for personal use? Also the link doesn't seem to work.

0 Kudos
Parrot60
Contributor
Contributor

I answered my own question. The link started to work, Yes 12.1.2 is still free and the 12.2 license works on 12.1.2.

0 Kudos
wila
Immortal
Immortal


@Parrot60 wrote:

I answered my own question. The link started to work, Yes 12.1.2 is still free and the 12.2 license works on 12.1.2.


I was just about to say "try the link again after you logged in", I've seen VMware's download links misbehave like that before.

Yes, the free 12.2 license should work for all 12.x versions. A paid license even lets you activate Fusion 11.x as well (and if I'm not mistaken VMware Workstation as well)

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
sennahoj
Contributor
Contributor

Hi Wila,

sorry but the 12.1.2 Fusion doesn't gos with Catalina. See my screenshot!

Is there a possible solution for Catalina?

Best regards

0 Kudos
wila
Immortal
Immortal

That's interesting as I literally installed it on an older mac down here earlier this week.

I suggest to (re)check you downloaded the 12.1.2 version and not the latest one, as that indeed won't work.

--
Wil

 

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
sennahoj
Contributor
Contributor

THX wila!

the Link mentioned from you above is the right one for Catalina!

0 Kudos