W6JHB
Enthusiast
Enthusiast

How to stop guest from suspending?

Jump to solution

I've just built a Windows 10 guest under Fusion 8.5.9. I primarily want to use this guest with a USB-attached software defined radio (SDR), the SDRplay RSP2pro. The software I use is their SDRuno and this combination works great. However, if I temporarily pause playing the radio and walk away for a while, when I come back the Windows guest has been put in suspend mode. Bringing it back to life works but at that point the USB SDR connection is broken, the radio application is confused, and I've got to end it and start over.

I don't recall this happening in prior versions of Fusion. How can I stop Fusion from suspending this guest?

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
bluefirestorm
Virtuoso
Virtuoso

A possible scenario is that the Apple Mac hardware is running on battery (such as MacBook Pro) and the "Passed power status to VM" is checked in the Advanced settings, the Windows 10 VM will see itself as a laptop running on battery. The msinfo32 will report platform role as mobile and the battery power icon is on the notification area.

If that is the case, you could tweak the Sleep time in the Power Options of the Windows 10 VM and maybe on the macOS power settings as well (e.g. Sleep timeout period should be longer in the macOS than the Windows 10 VM).

View solution in original post

3 Replies
bluefirestorm
Virtuoso
Virtuoso

A possible scenario is that the Apple Mac hardware is running on battery (such as MacBook Pro) and the "Passed power status to VM" is checked in the Advanced settings, the Windows 10 VM will see itself as a laptop running on battery. The msinfo32 will report platform role as mobile and the battery power icon is on the notification area.

If that is the case, you could tweak the Sleep time in the Power Options of the Windows 10 VM and maybe on the macOS power settings as well (e.g. Sleep timeout period should be longer in the macOS than the Windows 10 VM).

View solution in original post

W6JHB
Enthusiast
Enthusiast

No battery here - this is an iMac. However............. you jiggled something in my brain - I checked the Windows power settings and sure enough, it was set to turn itself off after 15 minutes. I set it to “never” and it no longer gets suspended by Fusion. What happens now, and is much more acceptable, is that I have to re-enter my password to get back to the Windows guest, AND the USB device is still connected. I can live with this. If I could stop it from “locking” the screen and requiring a password, I’d be done!

Jim

0 Kudos
dlhotka
Champion
Champion

I'd also make sure that the OSX Power setting 'Prevent sleep when screen blanks' is checked.

0 Kudos