bcarney
Contributor
Contributor

How to PERMANENTLY stop Fusion from opening apps in the VM instead of on my Mac?

Fusion is starting to drive me nuts.

In Settings / Applications / Default Applications

I have both Open Mac files ... and Open your Windows files ... UNCHECKED.

In the Configure button I've even gone in and removed all default apps so it is blank.

Yet, no matter what, every time I read a message in Mail on the Mac and click a hyperlink, Fusion insists I want to do it in Internet Explorer in the Virtual machine.

How to I permanently disable this "feature"?

3 Replies
admin
Immortal
Immortal

I have both Open Mac files ... and Open your Windows files ... UNCHECKED.

Yet, no matter what, every time I read a message in Mail on the Mac and click a hyperlink, Fusion insists I want to do it in Internet Explorer in the Virtual machine.

Hyperlinks are not files, you want Preferences > Default Applications > Open Mail (mailto) with: -- be sure to uncheck this, not just delete the line.

Edit: Oh, right, Configure goes there. In that case, try clearing out the helper applications:

  1. Make sure Fusion isn't running

  2. Get inside the .vmwarevm bundle of the offending virtual machine (see if you need help)

  3. Delete the Applications folder there

WoodyZ
Immortal
Immortal

In the Configure button I've even gone in and removed all default apps so it is blank.

Did you first click the Restore Defaults button before removing the Default Application listed? If not go back and click the Restore Defaults button and make sure its pointing to Mac applications not Windows.

Also in addition to what's already been said in the thread so far, RCDefaultApp is a nice freeware System Preferences pane application that easily allows setting the default application used for various URL schemes, file extensions, file types, MIME types, etc. and is very handy to have. You might want to check it out.

0 Kudos
jjohnson985
Contributor
Contributor

I am facing the same challenges.  Unfortunately all of the options above have not corrected the issue.  As a matter of fact, I don't even have GoToMeeting configured or installed on the Virtual Machine.

Thoughts?  Suggestions?

Thanks.

0 Kudos