Fusionuser009
Contributor
Contributor

How do fix the /dev/vmmon: Broken Pipe error, the failed to initialize monitor device error?

How do fix the /dev/vmmon: Broken Pipe error, the failed to initialize monitor device error, and the Transport (VMDB) error-14: Pipe connection has been broken error with my VMWare Fusion virtual machines? Also, why won't the Allow option show up under security and privacy? I've been told by Apple that the Allow Option won't show up under Security and Privacy because that feature is not supported by Apple's Mac OS X High Sierra Operating System. Also, I already tried the sudo spctl --master-disable command and the spctl --master-enable commands and I already tried the sudo spctl kext-consent add EG7KH642X6 command, but non of this help. Also tried reinstallling VMWare Fusion, which is VMWare Fusion 11.5.0 (146344996). I'm currently upgraded to Mac OS X 10.13.6, which is the highest that my Mac Book Pro 2011 17-inch can support because the AMD ATI Radeon 6770M with 1 GB of Video Memory can't support metal.

0 Kudos
2 Replies
scott28tt
VMware Employee
VMware Employee

Moderators will be along to move your thread to the Fusion area - this is something quite different to the vSphere security advisory area where you've created this thread...


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
wila
Immortal
Immortal

Hi,

In principle.. it should just work.

I just verified and the last version that runs on macOS 10.13 is VMware Fusion 11.5.3 (and the release notes appear to agree with that)

Try to download from here: VMware Fusion 11.5.3

See also: https://kb,vmware.com/kb/2088571

If you still can't run then you can try the workaround that appears to work for Mojave and later.

This would be to delete the /private/var/db/KernelExtensionManagement folder and reboot. After rebooting and starting VMware the folder will be recreated with the correct permissions.

See: https://github.com/pqrs-org/Karabiner-Elements/issues/2373

This is an apple bug that got introduced somewhere during an update of macOS.

The cure is to throw away your kernel extension staging folder & contents. It will be recreated on reboot.

This can most like be resolved by removing the /private/var/db/KernelExtensionManagement folder and reboot.

In the terminal run the following command:

sudo rm -rf /private/var/db/KernelExtensionManagement

Then reboot your macOS host and start VMware again.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos