drwff
Contributor
Contributor

Help with File Sharing Problems?

Hi, I am a brand new VMWare Fushion user. Just bought it 2 days ago. I have a MacBookPro and I have been running BootCamp to use both the Mac OS and a Windows XP (SP2) partition. I am excited about the ability to not have to re-boot to use my Windows. I am having some problems getting going, however, and I wrote to tech support and haven't gotten useful or timely replies, so I thought I would try the community forum for some help.

Basically, the only problems I am having are with the file sharing feature. Here is what I would like to be able to do:

1) have access to files stored on the Windows partition within my Mac (I used to be able to do this from BootCamp, the Windows Volume would appear as an "external harddrive" and I could open any file. Now, once I start up my VM Windows the Windows Volume Icon disappears and I see no way to access the drive from within my Mac OS. This is a bit of a drag when wanting to open a file that is stored on the Windows partition -- I now have to drag and drop each individual file. That is not very efficient.

2) One of the big disadvantages of BootCamp was that I had no access to files saved on my Mac partition from my Windows side. I read that I could enable "file sharing", but I am having problems with this. I used the Settings->File Sharing-> Enabled and browsed to my Mac Documents folder. I then went into Windows and "Mapped Network Drive" to a letter and chose //host./Shared Folders/ as the instructions said to do. I can open this folder from Windows Explorer, but if I spend more than about 30 seconds with it open, Windows Explorer crashes saying "It has encountered a problem and needs to close".

I was running Avast! 4.7 which apparently has some problems with file sharing, so I "uninstalled" it from my Windows, but the problem still persists.

Can anyone offer any advice on how to solve this problem?

Thanks,

dr wff

0 Kudos
16 Replies
46and2
Contributor
Contributor

#1-i'm not sure there is anything you can do about this

#2-i am experiencing the same thing, and this is even with fusion 1.1. the workaround is to not map a drive to the shared folder. instead, to access it open an explorer window and type in this path
.host\Shared Folders...explorer does not crash when i use this method to access my shared files..

cheers

0 Kudos
rcardona2k
Immortal
Immortal

While Fusion Shared Folders work in most cases, you can also share your Mac files by turning on Windows sharing under System Preferences > Sharing. In Windows you would go to Explorer > Tools > Map Network drive and enter the information from your Mac Sharing window. You can ignore the ".local" part if that is part of your Mac name.

0 Kudos
46and2
Contributor
Contributor

While Fusion Shared Folders work in most cases, you can also share your Mac files by turning on Windows sharing under System Preferences > Sharing. In Windows you would go to Explorer > Tools > Map Network drive and enter the information from your Mac Sharing window. You can ignore the ".local" part if that is part of your Mac name.

thanks rcardona2k, that works MUCH better

0 Kudos
marcelairmail
Contributor
Contributor

I can not seem to find 'Windows sharing'. Is this perhaps listed under a different name in os x?

Thanks,

M.

0 Kudos
rcardona2k
Immortal
Immortal

Yes in OS X 10.4.x (Tiger) it's called Windows Sharing under System Preferences > Sharing > Services > Windows Sharing

In OS X 10.5.x (Leopard) it's just called "FIle Sharing" under System Preferences > Sharing

0 Kudos
marcelairmail
Contributor
Contributor

Well... have not figured this out yet.

Perhaps I should describe what I'm trying to do. I'm running this on a brand new iMac with Leopard. Xp is XP home.

OS X with Fusion 1.1

VM has XP loaded.

I want to see 'My Documents' in OS X.

In XP I shared the My Documents folder. It is now a shared folder. File sharing is checked in XP so that the XP firewall does not block it, XP took care of this when I made this folder a shared folder.

Here is the thing that is strange: in OS X in Finder I can sometimes see the My Documents folder as a network connection. I can access the My Documents folder in Finder and use the files. I can switch back to XP, create and save a file, switch back to OS X and see the just created file in Finder in the My Documents folder in the network connection.

It does not appear to be stable though, since it does not always show up again, especially once I get back and log on again, ie log on to OS X and start the VM.

Also for info:

in OS X I have a printer which is shared (printer is shared and printer sharing is checked)

in XP I connect to this printer via Bonjour (for Windows)

networking is set to bridge

firewall in OS X is set to allow all incoming connections

This works just fine. Not sure if this is relevant to the file sharing issue but thought I mention it.

I have done some reading on this forum but mostly the solutions point towards sharing OS X folders with XP. It appears to me that I'm trying to go in the opposite direction (share XP folders with OS X) and therefor some of the solutions do not work?

Last but not least: I have tried to share OS X files with XP by selecting 'File Sharing' as mentioned in this string. I'm confused as to what option to select ie afp or smb. I also do not find the mac drive in XP once I did select File Sharing. (9.52 PM THIS NOW WORKS! I FIGURED THIS PART OUT)

I know these are a lot of questions, still new to iMac and Fusion, trying to figure it out while not all that compu savvy like some of the wizards on this forum!

Many thanks,

M.

0 Kudos
rcardona2k
Immortal
Immortal

Well I'm glad you got one part figured out.

I was going to suggest a possibly more stable network connection between OS X and Windows. One thing I will say is that OS X mounting an XP share over bridging should be stable, these steps take it up a notch:

1. Shutdown your Windows XP VM.

2. While the machine is on the dark screen with the big Play (>) button, select Virtual Machine > Settings

3. Click the + symbol in the lower left and Add Network..., change the default for this network from Bridged to Host only.

4. Restart Windows.

5. Open a command window (Start > Run > cmd > OK)

6. Type the following: ipconfig /all smb:// substitute IP address from above / sharepoint

See if this kind of connection is more stable than what you have been doing before.

0 Kudos
marcelairmail
Contributor
Contributor

I'm with you all the way except for the last bit:

Under 8, do I type in 'sharepoint' or something else.

Not sure what 'sharepoint' is.

Thanks for your help.

M.

0 Kudos
rcardona2k
Immortal
Immortal

If you do not know the network names (aka share points) of the folders that Windows is sharing, then in XP, open an explorer window (Start > Run > explorer > ok) and type the following address:

\ \ IP address of your machine \ ( note: there are no space between \'s or address, I have to format it this way for the forums )

You should various folders like Documents, SharedDocs, or MyXYZShare, to complete the address from OS X, the address look like these:

smb:// ip address /Documents

smb:// ip address /SharedDocs

etc

0 Kudos
marcelairmail
Contributor
Contributor

Many thanks!!! This now works too!

One more question (for now...).

Once I log off, come back a few hours later, it appears I will have to reconnect to XP in the Finder > Go > Connect to Server.

Can this be setup to where this happens automatically?

M.

0 Kudos
rcardona2k
Immortal
Immortal

You need to do two things to simplify connecting to an smb share. First is put your credentials for the share on your OS X keychain. Second is make an alias of the share volume. Then when you want to mount the share you just double-click the alias.

0 Kudos
marcelairmail
Contributor
Contributor

I added the credentials to the keychain.

Now for the alias: it does not give me that option.

If I select the shared drive (showing my IP address) in the sidebar of finder, the 'alias' option is not available.

Same applies if in Finder I select the folder that is on the shared drive, alias is not available.

M.

0 Kudos
rcardona2k
Immortal
Immortal

Same applies if in Finder I select the folder that is on the shared drive, alias is not available.

You are not doing this from the right place(s). When the smb share first mounts there's an icon that represents the volume on your desktop, it should be called the same as the network name like Documents, etc. Click on this icon, then press and hold the ctrl key and click on the icon again. You will get a context menu with an option called "Make Alias". I tested this so I know it works (in Leopard). After you choose Make Alias you will have another icon next to Documents with a small "arrow" on it. You can unmount the original Documents icon and you should be able to recall the share by double-click the alias.

e.g.

0 Kudos
marcelairmail
Contributor
Contributor

Thanks, I'll have to play with this a little since interesting enough

I never got the icon you mention when I first mounted the smb share.

All I have on my desktop is the Macintosh HD and the Time Machine

icons.....

If I can not figure this one out it is still doable and working pretty

good in the current set up, it does not take much to select 'connect

to server' etc, it would be cleaner with the icon (alias).

By the way, I do have 2 network connections now, one hosted (created

for the file sharing), one bridged (created the bridged one for my

shared printer).

Is this going to create a problem?

Thanks, you have been a great help.

Marcel.

0 Kudos
rcardona2k
Immortal
Immortal

The second network connection is no problem whether using Connect to server or an icon alias. There's a chance the default Finder settings do not show that icon (it's been a long time), to verify do this: go to Finder menu > Preferences and make sure under "Show these items on the Desktop:" that Connected servers is checked.

Thanks - good luck

0 Kudos
marcelairmail
Contributor
Contributor

That was it, it all works like it should!!

Wow, it's easy once you figure it out with some help...!

Thanks again!

M.

0 Kudos