briankendall
Contributor
Contributor

Guest OS's get unusably slow after a few hours / after restoring a snapshot

Jump to solution

Running an early 2009 Mac Pro with 10 GB of RAM, 2.66 Quad-Core Intel Xeon CPU, OS X 10.10.2. Fusion 7.1.1.

I have an issue where a guest OS I'm running under Fusion will inevitably get unusably slow after it's been running for a while. Usually what happens is when I start the system up, everything is running smoothly, and then after an hour or two, it will start performing very slowly. Very basic operations like moving a window around take several seconds to complete, and I can see the screen slowly updating as the window moves. Another example is clicking on a menu in the menu bar might take several seconds for the menu to even begin drawing, and then several more seconds for it to finish, and during that time the OS is otherwise unresponsive. Essentially, basic interaction with the OS is very difficult. If I shut down the guest OS and then start it back up again, it will resume performing normally for another hour or two.

If I save a snapshot of a system and then later restore, usually (but not consistently) that will trigger the poor performance, and I'll have to fully shut down the guest OS and start it back up again to fix it.

This occurs regardless of what the guest OS is. I've experienced it in OS X 10.6-10.9, Windows XP, and Windows 7 both 32-bit and 64-bit.

So far I've tried setting the hardware versions of these VMs to version 10, as it was recommended in other threads I've found for fixing this exact issue. However, it doesn't fix things for me.

Does anyone have any idea what's wrong? I'm quite liking Fusion so far, more than Parallels, but with this issue it's very difficult for me to get any work done. I hope it can be solved.

Thanks in advance!

0 Kudos
1 Solution

Accepted Solutions
cram501
Enthusiast
Enthusiast

I've been having the same problem since V7 came out.   At some point, from 1 hour to 7 days, all of my VMs would slow to a crawl.   The only solution was to close them all, close vmware, and restart.   I've spent months tweaking different settings.

I made a few manual tweaks after searching the net and seeing some common settings that were recommended.   After 4-6 weeks my problem has not reappeared.   I'm not sure which of those settings solved my problem but you may want to give them a try.   I do have an SSD so you may or may not want to use the virtualSSD setting based on your configuration.

The settings I have added are:

mainMem.backing = "swap"

scsi0:0.virtualSSD = 1

MemTrimRate = "0"

sched.mem.pshare.enable = "FALSE"

MemAllowAutoScaleDown = "FALSE"



As usual, back up your vm and use at your own risk.  They have worked fine for me so far but each install is different.

View solution in original post

14 Replies
wila
Leadership
Leadership

Hi,

There are some others who have reported similar issues who had been seeing benefit from applying the configuration setting from within the Host OS X terminal application as suggested here:

Re: Windows 7 VERY SLOW on Yosemite/Fusion 7.1

by vnephology.

Don't know if it will fix your problem as I personally have not seen the issue, but it appears to work for others.

Hope this helps,

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
dlhotka
Champion
Champion

Are you giving any individual VM more than 2 cores?  If so, you may be starving the host for CPU cycles.

0 Kudos
briankendall
Contributor
Contributor

I gave this a try, but it doesn't seem to have made any difference. Just had a Windows 7 system running in the background, and it got so slow I had to "power off" the virtual machine.

0 Kudos
briankendall
Contributor
Contributor

I'm still experiencing this problem with VMware Fusion 7.1.2. It's seriously hampering my ability to use any virtual machines, and is very frustrating. I don't think I'll be able to continuing using Fusion.

I just started up a Windows 7 32-bit system, and at first it was perfectly responsive. Right after I switched to another application and worked in it for a few minutes, I came back to the virtual machine and everything is incredibly slow. Clicking a window takes ten seconds for it to respond and redraw properly. A simple command in a terminal window like dir or cd takes several seconds to execute. On a couple of occasions a different virtual Windows 7 system got so incredibly slow and unresponsive I had to power it off. This would happen within an hour of starting it up.

Fusion worked perfectly for me in OS X 10.8 and earlier. As soon as I upgraded to 10.9, this problem started occurring, and has never gone away since. I'm disappointed as I very much like Fusion more than its competitors, but at this point it's failing to do the most basic things I require of it.

0 Kudos
dlhotka
Champion
Champion

What's the physical hardware (CPU/Cores and RAM), and how much do you have allocated to the guest?

0 Kudos
briankendall
Contributor
Contributor

Physical hardware for my mac was listed in my original post, but it again is: Early 2009 Mac Pro, 2.66 Quad-Core Intel Xeon CPU, 10 GB of RAM. I am now running OS X 10.10.5 and Fusion 7.1.2.


I allocate two cores to my Windows 7 virtual machines and 4 GB of RAM. It strikes me that that should be enough for a more or less responsive Windows 7 system. Note that on all of my Windows 7 guest systems I've turned off aero and set all graphics settings to maximize performance in the hopes that it would help alleviate this problem, but it doesn't seem to make any difference.

0 Kudos
cram501
Enthusiast
Enthusiast

I've been having the same problem since V7 came out.   At some point, from 1 hour to 7 days, all of my VMs would slow to a crawl.   The only solution was to close them all, close vmware, and restart.   I've spent months tweaking different settings.

I made a few manual tweaks after searching the net and seeing some common settings that were recommended.   After 4-6 weeks my problem has not reappeared.   I'm not sure which of those settings solved my problem but you may want to give them a try.   I do have an SSD so you may or may not want to use the virtualSSD setting based on your configuration.

The settings I have added are:

mainMem.backing = "swap"

scsi0:0.virtualSSD = 1

MemTrimRate = "0"

sched.mem.pshare.enable = "FALSE"

MemAllowAutoScaleDown = "FALSE"



As usual, back up your vm and use at your own risk.  They have worked fine for me so far but each install is different.

View solution in original post

dlhotka
Champion
Champion

Sorry, got lost in the replies.  That shouldn't be a problem for performance on the host.

Do you have any antivirus turned on inside the VM's?  Sometimes that'll trigger a scan and cause problems like this, as will system restore.

0 Kudos
wila
Leadership
Leadership

Hi,

Do you run other guests at the same time?

Are you using the Shared folders feature and if so, does the slowdown still happen if you turn that off?

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
briankendall
Contributor
Contributor

No antivirus, at least not on these VMs.

0 Kudos
briankendall
Contributor
Contributor

I used to successfully run other guests at the same time, but lately I've been avoiding it since it seems to trigger this problem.

I do use the shared folders feature, though I rely on it constantly and am going to try other possible solutions before I try turning it off. Furthermore, I've been using the shared folders feature since everything was working great back when my host system was running OS X 10.8 and earlier, so I don't really feel that turning it off is an acceptable solution. I really want to be able to use the full functionality of Fusion.

0 Kudos
briankendall
Contributor
Contributor

I've modified my virtual machines to include these settings. I'm hoping that it'll fix the problem, and will report back one way or the other. Of course since it comes up inconsistently I'll just have to use the software for a while longer to see what happens, so it might be a little while until I can confirm it's fixed.

0 Kudos
briankendall
Contributor
Contributor

Good news, changing these settings on my VMs seems to have fixed the problem. I'm not 100% sure yet since the issue isn't completely consistent but I was just running two Windows 7 VMs at the same time without any slowdown or problems, which I was not able to do at all since updating to OS X 10.9. So I've marked the answer as correct for now.

I think the issue has something to do with paging. Given that my VMs used to slow down whenever they were in the background, running for a while, or competing for memory with other processes or VMs -- which certainly points the finger at paging -- I'm guessing that changes to how virtual memory works starting with OS X 10.9 can interact badly with Fusion, and that for some reason my system is affected in a way others are not. (Otherwise I'm sure this would've been fixed -- if a majority of Fusion users experienced their guest systems becomg unusable after a few minutes I'm betting it would be fixed and quickly!)

Haven't tried VMware Fusion 8 yet, and I'm debating whether or not I want to keep these settings (given I'm not sure what other effects they may have) and hope that they've finally fixed this bug, or just keep them in since things seem to finally be working now.

0 Kudos
timun
Contributor
Contributor

This knowledge base article mentions additional parameters to reduce an I/O bottleneck causing slowness:

VMware KB: Troubleshooting hosted disk I/O performance problems

The parameter list overlaps somewhat with other postings that I've read.

MemTrimRate = "0"
mainMem.useNamedFile = "FALSE"
sched.mem.pshare.enable = "FALSE"
prefvmx.useRecommendedLockedMemSize = "TRUE"


Note: If you are using a Linux host, use the following entry instead of mainMem.useNamedFile = "FALSE". The mainMem.useNamedFile entry only applies to Windows Hosts.


mainmem.backing = "swap"

0 Kudos