ashleymoran
Contributor
Contributor

Fusion sends escape to FreeBSD when pressing command key

Jump to solution

When installing FreeBSD, if you press the command key as part of the Cmd-Ctrl combination to lose focus on the VM, Fusion sends an escape sequence to the VM. The escape key is interpreted as "cancel" by sysinstall. This makes it excruciatingly difficult to install FreeBSD! The issue does not appear to arise after the system is installed and booted normally.

I can't see any reference to this problem on the internet, but it has happened to me on two machines (Mac mini Core Duo, iMac Core 2 Duo). I have seen it on FreeBSD 6.2 and PC-BSD 1.4 (based on a recent -STABLE build). Has anyone else experienced it, and is there a fix/workaround?

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
rcardona2k
Immortal
Immortal

I would try to disable Preferences > Enable MacOS keyboard shortcuts, if that doesn't change anything, you can swap the alt and cmd keys using the configuration option in this thread:

An alternative to using the primary console is to use the built-in VNC server to access the Guest OS screen -- this is documented in

View solution in original post

0 Kudos
6 Replies
rcardona2k
Immortal
Immortal

I would try to disable Preferences > Enable MacOS keyboard shortcuts, if that doesn't change anything, you can swap the alt and cmd keys using the configuration option in this thread:

An alternative to using the primary console is to use the built-in VNC server to access the Guest OS screen -- this is documented in

View solution in original post

0 Kudos
bgertzfield
Commander
Commander

Try Control-Command.

You can also write to the FreeBSD folks, asking them not to treat the GUI (Windows/Command) key as an escape.

ashleymoran
Contributor
Contributor

Thanks! Turning off the mac keyboard shortcuts doesn't help (had already tried that), but the key-swapping hack works a treat. It's a shame it can't be done per-VM though.

If I get chance I will submit this as an issue to the FreeBSD team.

0 Kudos
EugeneKim
Contributor
Contributor

EDIT 20091231: This workaround no longer applies in VMware Fusion 3.x. See the next post for a document I have uploaded with new workarounds and solutions.

Hi all,

I've been hit (and annoyed as well) by this problem, and, after a bit of mucking around, have found a way to get around this.

The trick is: Although it does not matter whether you first press Ctrl or Cmd, make sure you let go Ctrl first, then Cmd.

To illustrate, there are good orders:

  • Ctrl down, Cmd down, Ctrl up, Cmd up

  • Cmd down, Ctrl down, Ctrl up, Cmd up

These, however, are not:

  • Ctrl down, Cmd down, Cmd up, Ctrl up

  • Cmd down, Ctrl down, Cmd up, Ctrl up

This is admittedly annoying, and certainly takes some getting used to (after all, we all have an existing habit on how we press the key combo which we may have to change), but once you make one of the good sequences a habit, you won't be bothered by this problem ever again.

HTH,

Eugene

0 Kudos
EugeneKim
Contributor
Contributor

Please see http://communities.vmware.com/docs/DOC-11677 for the updated solution that works in VMware 3.x. Unfortunately, the permanent solution described therein is applicable only after finishing initial guest installation; for sysinstall the method suggested by rcardona2k should still be used, but as a temporary workaround because it affects all VMs, not just the FreeBSD guest.

Cheers,

Eugene

0 Kudos
markshel
VMware Employee
VMware Employee

It is also possible to change the hard ungrab keyboard sequence in Fusion 3 so it does not contain the troublesome command key.

Unfortunately there is no UI option to change the ungrab sequence, though it is possible by editing the preferences file while Fusion is not loaded. "~/Library/Preferences/VMware Fusion/preferences"

To change the ungrab shortcut add the following lines to the VMware preferences file, or change them if they are already there:

pref.hotkey.shift = "false"

pref.hotkey.control = "true"

pref.hotkey.alt = "true"

pref.hotkey.gui = "false"

This will change the ungrab sequence to ctrl-option as opposed to the default ctrl-command for all VMs.

0 Kudos