krisk09
Enthusiast
Enthusiast

Fusion Pro 12 Graphics Perfomance Poor

Just updated to 12 Pro from 11.5.6 Pro.  The graphics performance is noticeably slower.  Tried reinstalling VMware tools and tried different Display settings with no change.  Just using some apps for programming.  In the apps you can basically see it slowly rebuild a toolbar for instance one icon at a time basically.

VM is Windows 10 Pro with latest updates.  2 CPU and 4gb dedicated to it.

Mac is a 2017 MBP 3.1ghz i7 with 16gb ram and an AMD Radeon Pro 560 4gb with MacOS 10.15.6

35 Replies
joserfonseca
VMware Employee
VMware Employee

We were able to reproduce this issue in-house, thanks to LowcountryLDC​​'s video and Autodesk Civil 3D template.

We now know this issue is related to GDI hardware acceleration, a feature we recently implemented and that in theory should accelerate ordinary GDI windows applications and save battery by moving the workload away from the CPU to the GPU, but on this case it appears to cause the drawing to ping-pong between the CPU and the GPU, effectively having the worse of both worlds.  We're still investigating why these applications are so adversely affected, and how to properly address it.

In the meanwhile, these performance regressions can be worked around by adding  guestinfo.svga.wddm.enableGDIHW=FALSE setting to the .vmx while the VM is powered off.  This will disable GDI HW acceleration, and have no other consequence (for example, Direct3D 11 should still work.)

krisk09, I hope this will also address Crestron Simpl and Crestron VTPro performance regressions too.

I can only apologise for not catching this before.  We are all well aware CAD applications are important to our users, and we do regularly test several of them, but we weren't exercising the UI operations where these performance regressions were most apparent.  Rest assured we'll include these particular operations on our test scripts/suites going forward.  I do appreciate all your help and assistance in identifying and diagnosing this issue.

LowcountryLDC
Contributor
Contributor

joserfonseca​ Wow, that made a huge difference.  I think you have found where the problem lies alright.  Performance appears to be back to what it was in 11.5.x.  I hope you guys get the GDI acceleration working for CAD, sounds like that will be awesome once it's working.  Let us know if we can be of additional help testing once the proposed fix is ready.  Thank you so much for jumping on this!

0 Kudos
krisk09
Enthusiast
Enthusiast

joserfonseca​ I added this as well guestinfo.svga.wddm.enableGDIHW=FALSE and have "Accelerate 3d Graphics" enabled and it working like 11.5.6 like @LowcountryLDC had reported.  Glad you were able to find the issue.

0 Kudos
jm33ng
Contributor
Contributor

I have disabled GDI acceleration and the overall performance seems the same, I found it's unacceptably slow on WinDBG and notepad++.

And the VM has 5GB RAM and 8GB video memory, 4 cores. Host is MBP 16 with 32 GB RAM

Video can be found here https://www.youtube.com/watch?v=9SPEXpZfVpo&feature=youtu.be

0 Kudos
MihailMladenov
VMware Employee
VMware Employee

jm33ng Did you make sure you restarted the VM after setting the "guestinfo.svga.wddm.enableGDIHW=FALSE" setting in the .vmx file? By that I mean Powering Off then Powering On, not just suspending and resuming. When I tested it there's not a noticeable difference between Native WinDBG and WinDBG inside Fusion with that option set. If the problem persists for you can you please provide us with vmware.log and mksSandbox.log so that we can try to diagnose it.

[odd formatting reset by moderator]

0 Kudos
rfhall
Contributor
Contributor

I also apparently have this issue.  Last week I installed Fusion 12 Pro and ever since I've had incredibly poor graphics performance.  This is an application I have developed and has been in use for quite some time.  Ran fine in pretty much all the prior versions of Fusion.  I spent some time and trace the bulk of the problem to a call to "GetPixel" which was consuming a great deal of time.  This call if fundamental to the application when it comes to erasing a group of pixels that may have been written with various colors so we read the pixel and write it again in XOR mode to erase it.  The performance of SetPixel however seems acceptable.

0 Kudos
krisk09
Enthusiast
Enthusiast

Does the version 12.1.0 that was released today(11/23) fix this issue?  There was nothing in the release notes specifically.

0 Kudos
gz152
Contributor
Contributor

Installed today, haven't fixed. 

0 Kudos
bigpawed
Contributor
Contributor

After upgrading to Fusion Player 12.1.0 from 11, I also am seeing poor graphics performance for an app I developed. The issue is cleared up when I uncheck "Accelerate 3D Graphics". BTW, the app is not specifically using any 3D drawing routines. It's during the drawing of a .NET DataGridView with some custom code, but not anywhere else I've seen yet. 

Editing the .vmx file did not solve the problem for me.

0 Kudos
FerryB
Contributor
Contributor

Hello,

I seems to have the same problem since I upgraded to 12.0 (and now to 12.1) after I upgraded my MacBook to Big Sur. The program I use to draw electrical drawings is SEE-Electrical and the graphics are bad since the updates.

I want to try de solution by adding the line guestinfo.svga.wddm.enableGDIHW=FALSE at the .vmx file, but where can I find that file? 

0 Kudos
marianopeck
Contributor
Contributor

Hi all,

I had the same issue when upgrading to Big Sur and Fusion 12. 

@LowcountryLDC thanks for all your effort on finding a reproducible case to VMWare

@joserfonseca thanks for the deep analysis and workaround. I can confirm that "guestinfo.svga.wddm.enableGDIHW=FALSE" did fix it for me as well.  BTW...something strange I noticed when migrating to Fusion 12 is that suddenly the recommended shared graphics memory is 8GBs...that's ridiculous.. the host (MacBook Pro Mid 2015) AMD Reading R9 M370X has only 2GB...Even more, in Fusion 11 the recommended was just 1 GB. So.... isn't it a bit too much changing from 1GB to 8GB for the recommended? And even more...when the recommended is way bigger than what my host has to offer. Do you want me to send a support case for this? open a  separate forum post? 

@FerryB the "vmwarevm" is seen as a file by Finder but actually its like apps..they are a directory. I did it from command line... You can just do something as below but updating your path:

open -a TextEdit "/Users/mariano/Trabajo/Instantiations/Mariano New Windows 10/New Mariano_Windows_10_x64.vmwarevm/New Mariano_Windows_10_x64.vmx"

mrgroen
Contributor
Contributor

Thanks for debugging this!
My development team is experiencing the same problems.
Disabling the GDI hardware acceleration feature solves the bad performance.

We are using Mendix Studio Pro for developing new applications.
Free to download: https://appstore.mendix.com/link/modelers/
I know a lot of other developers are also using VMware Fusion to run this software on there MacOS machines.

FYI, the setup I use:

Host:
MacBook Pro (13-inch, 2018, Four Thunderbolt 3 Ports)
Processor: 2,7 GHz Quad-Core Intel Core i7
RAM: 16 GB 2133 MHz LPDDR3
eGPU: Radeon Pro 580 8 GB (Blackmagic eGPU)
SSD: 500GB

Guest VM:
Processor: Intel(R) Core(TM) i7-8559U CPU @ 2.70GHz 2.71 GHz
RAM: 5,00 GB
Type systeem: 64-bits besturingssysteem, x64-processor
Edition: Windows 10 Pro
Versie: 20H2
OS-Build: 19042.662
Windows Feature Experience Pack 120.2212.551.0
SSD: 80GB (virtual space on the same disk as the host)

0 Kudos
FerryB
Contributor
Contributor

Hello Mariano,

I did add the given line (in a different way, but whatever) and started the VM machine and started the program See Electrical, and it just worked fine like before the upgrades!

So thank you a lot for the help!

0 Kudos
BeanCounterMike
Contributor
Contributor

I was/am experiencing the same problem after upgrading to fusion 12 and Catalina.  I found that after upgrading my SAP Business One Software painfully slow in redrawing and frighteningly it would sometimes simple crash.  Happily without loss of business records.

I am not a power enough user to understand your reference to guest user on .vmx.  I am certainly proficient enough to copy and paste your string but would have liked for there to be more of a step by step explanation on how to find and safely modify as you instructed.

Absent that ability I simply unchecked in Settings the "Accelerate 3D Graphics while VM was powered off and at least for the moment I seem to be back to living the dream so that worked for me.

In my search for resolution I have updated with latest update as well.  It would be nice to know when it is safe to update and turn things back on.  If after a few days the improvement does not last I will update this thread.  This was a real booger.  Not a power user of Fusion but a long time one and it was disconcerting for it to work so poorly after past experience with the product and it's sustained usefulness even through OS upgrades.

Thanks to all for figuring this out.

 

0 Kudos
angus4
Contributor
Contributor

I've been using a Windows app to access a networked Microsoft SQL Server database using various versions of Fusion for over 10 years. Never had a major issue. I just upgraded from 11.5.7 to 12.1. Immediately after up the upgrade and trying to access the database I noticed that the screen refresh was extremely slow. Previous to the update viewing a list from the database was almost instantaneous. After the update I could see each line added line by line. Extremely slow. On the Windows desktop icons would not fully appear unless you moved the mouse over them. After viewing this thread I shut down the vm and then turned off "Accelerate 3D Graphics" in the vm's System Settings->Display.

After starting up the vm the performance returned to normal.

2017 iMac Retina 5K 27 inch. 4.2 GHz Quad-Core i7. 40GB RAM. MacOS Catalina 10.15.7. Fusion 12.1. VM: Windows 10, 8GB RAM assigned to VM.

0 Kudos
MihailMladenov
VMware Employee
VMware Employee

@BeanCounterMikeThe step by step workaround is:

  • From the Fusion Virtual Machine Library, GUI select your virtual machine (make sure it's in powered off state) -> right click -> "Show in Finder"
  • Now in finder right click on the *.vmwarevm file that shows up and click "Show Package Contents" which should open a directory with the contents of this file
  • Inside this directory find the *.vmx file -> right click -> Open With -> Text Edit
  • Now Add the "guestinfo.svga.wddm.enableGDIHW=FALSE" string on new line without the quotes.

I suggest first trying this workaround instead of disabling 3D Graphics Acceleration altogether because disabling that will make 3D apps slow if you use any.

0 Kudos