Highlighted
Contributor
Contributor

Fusion Internet Speed is Super Slow compared to Host

Hello

I am new to the forums but a long time fusion user. Until recently internet speed was not an issue but I am seeing a huge loss of internet performance.

- Running an Early 2015 MBP with MAC OS Catalina with Fusion 11.5.6

- VMware Tools 11.1.0 Build 16036546

- Windows 10 all updated

The host machine (MAC OS) side gets upward of 643MB download speeds using the speed test however when I do a similar test on the Windows I never exceed 55MB. I have cycled through using the various network connections NAT, Bridge, Autodetect

I even went into  gpedit.msc >> Administrative Templates >> Network >> QoS Packet Scheduler >> Limit Reserve Bandwidth set to Enable and 100 and switched to 0.

I have endlessly tired various things.

Any help will be greatly appreciated in solving this. Happy to share any additional information if you give me the instructions to generate the relevant logs.

0 Kudos
26 Replies
Highlighted
Community Manager
Community Manager

If you go to the windows Network and Sharing Center in Control Panel, you should be able to see the network you're on.

If you click 'Ethernet0' or whichever number corresponds to your NIC, the window that comes up should have a row for 'Speed'.

Does it say 1 Gbps or 100 Mbps?

- Michael Roy - Product Line Manager: Fusion & Workstation
0 Kudos
Highlighted
Contributor
Contributor

Ethernet0

Speed 1Gbps

0 Kudos
Highlighted
Contributor
Contributor

1Gbps

0 Kudos
Highlighted
Community Manager
Community Manager

Hm, my first thought was it's negotiating at a sub-optimal rate (my iMac for example has been negotiating at 100Mbps lately, drove me nuts for a few days tracking that down...).

When you're using 'bridge', does it matter if you use a specific interface vs. autodetect?

Also, as a method of isolation, does another VM (say like an Ubuntu desktop) exhibit the same issue?

- Michael Roy - Product Line Manager: Fusion & Workstation
0 Kudos
Highlighted
Contributor
Contributor

No using a specific interface is not a big deal. However I do find that using Bridged (Autodetect) works best for all my work stuff. As for using another VM no I only have Windows running.

0 Kudos
Highlighted
Contributor
Contributor

Hello Mikero,

I quickly installed ubuntu the clean install gets me 300MB. So any ideas ...

0 Kudos
Highlighted
User Moderator
User Moderator

Hi,

Please add a vmware.log file to your reply here (you can attach a file with the "Attach" button at the bottom right of your reply window)

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Highlighted
Contributor
Contributor

How do I generate the log file?

0 Kudos
Highlighted
User Moderator
User Moderator

Hi,

It's already being made, you can find it in the VM bundle.

In VMware Fusion Library, right click on your VM, select "Show in Finder" to open Finder on the VM, then in Finder right click and select "Show Package Contents" from the context menu.

There you will find the vmware.log files for your VM.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Highlighted
Contributor
Contributor

I dont see the attach file option when I hit reply.

0 Kudos
Highlighted
Contributor
Contributor

See the file attached.

0 Kudos
Highlighted
User Moderator
User Moderator

Hi,

OK, you are currently using the Intel e1000e adapter in your virtual machine.


This isn't a bad adapter (it is a lot better than the e1000 one), but it is also not the fastest.

We're going to change the adapter to a faster one, but for that you will have to manually make some changes.

As there's always a chance of creating a problem with a change like this I strongly recommend to make a backup of your VM before going forward.

With the VM shut down (and VMware Fusion as well) make a copy of the whole VM bundle to an external disk to make that backup.

Now while VMware Fusion is still shut down, go to your VM and edit the vmx file of your VM.

Search for a line:

ethernet0.virtualDev = "e1000e"

and change it into

ethernet0.virtualDev = "vmxnet3"

Save and start your VM.

Please use a plain text editor for your edits (TextEdit works, but beware of the setting smart quotes in preferences, it should _not_ be set )

pastedImage_1.png

Once done, exit and save.


Then start VMware Fusion and run your VM again.

I do expect your network to be faster after this.

Also please note that your vmx file also has lines for other network cards (ethernet1 and ethernet2) that are still there from your experiments. They are not used and can be removed, but also don't hurt if you keep them. I'm only mentioning it that you do change the virtualDev for ethernet0 only and by accident change one of the unused ones and wonder why it didn't change anything.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Highlighted
Contributor
Contributor

So how do I clean these old/orphan network card entries up. I would like to have these all removed and have a clean base as much as possible.

0 Kudos
Highlighted
Contributor
Contributor

Also to make the copy I can just use Command C for the entire folder correct or is there a special way this should be done.

0 Kudos
Highlighted
User Moderator
User Moderator

Hi,

If you want to clean up those old entries then you can remove all the lines that start with ethernet1 and ethernet2.

For making a backup copy, yes you can use command+C and command+V or you can use drag & drop with Finder.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Highlighted
Contributor
Contributor

Mikerowila

Hey Guys did what Wila suggested no real improvements. attaching the log again.

0 Kudos
Highlighted
User Moderator
User Moderator

Hi,

I did take a look at your log file.

The vmxnet3 settings look fine to me.

Your CPU is an intel i5-5287U which has only two physical cores and 4 threads, that is a bit on the slim side for virtualisation and I suspect that to be one of your main limiting factors now.

Your VM has currently 2 vCPU's assigned which is the maximum you can assign it without impacting performance on the whole host.

Another thing I noticed about your VM is that it is booting via the legacy BIOS firmware and not via UEFI, it has been reported before that this has a performance impact.

However if it would also impact your network performance I'm not sure. You can''t just change it to try out either as the VM would not boot after changing it.

It involves a number of steps and going back isn't possible (unless you restore a backup).

I think that "this is it" for your current hardware.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Highlighted
Contributor
Contributor

Wow I am really surprised thats the end for my hardware... Ubuntu is pretty snappy and internet is fairly fast. I was wondering if it makes to do a clean Windows 10 build and see but sounds like that may be of no use.

How would I go about changing my BIOS firmware..

0 Kudos
Highlighted
Champion
Champion

You might try dropping the guest to 1 core actually.  The rule of thumb is N-1 where N is the physical cores. That can cause problems for some OS's (only having 1 core), but it's possible that if the host is starved for cycles, it could be causing the slowdown too.

0 Kudos