Highlighted
Enthusiast
Enthusiast

Fusion 8.5 - Upload OS X VM to server still broken after more than a year

Jump to solution

The upload to server feature in Fusion still will not upload an OS X VM to an ESXi 6 server in a condition where it works.  I just tried to use it to upload a clean Sierra VM and on boot it attempts to boot from optical and then the hard drive and then fails.  Does anyone know a work around for this?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Enthusiast
Enthusiast

Argh, figured it out.  For some reason the OS type got set to "Other" and "Other 32-bit".  If you try to fix this from the HTML5 client it throws an error saying the host optical drive is not present and you have to remove it from the config.  Removing it from the config does not solve the problem.  So it turns out that if you go get info on the VM from within Fusion and change the host type to OS X 10.10 from the general pane, the change will stick and the VM will boot.

View solution in original post

0 Kudos
4 Replies
Highlighted
Enthusiast
Enthusiast

Argh, figured it out.  For some reason the OS type got set to "Other" and "Other 32-bit".  If you try to fix this from the HTML5 client it throws an error saying the host optical drive is not present and you have to remove it from the config.  Removing it from the config does not solve the problem.  So it turns out that if you go get info on the VM from within Fusion and change the host type to OS X 10.10 from the general pane, the change will stick and the VM will boot.

View solution in original post

0 Kudos
Highlighted
Champion
Champion

Unless you're running ESX on Apple Hardware, you can't do it legally.  What's the server you're trying to upload to?

0 Kudos
Highlighted
Enthusiast
Enthusiast

I didn't see that a follow up question got posted, so apologies for the late reply. I am running vSphere 6 on Mac Mini's in rack mount thunderbolt enclosures from Sonnet so there is no licensing issue with virtualizing macOS.  The upload to server feature does not complain when you attempt to do this and it is a supported use that clearly is not well tested.  Given how difficult it is to build a new mac OS VM directly on a vSphere host, fixing the weirdness with this would be nice and probably pretty easy to do on the developer side.

For anyone keeping score, creating a new macOS VM and accepting the defaults creates a bogus file system that is only sort of a GUID partition table/journaled HFS+.  Disk Utility recognizes it as such but it will not work correctly with this partition map, preventing later resizing.  If you're baking a new macOS VM for any purpose, including uploading to a vSphere host, you will want to erase and put a fresh partition table on the virtual disk before continuing with installation of macOS.

0 Kudos
Highlighted
Champion
Champion

Interesting bug, thanks for sharing.

0 Kudos