huntharo1
Contributor
Contributor

Fusion 7.1 - Windows 8.1 plain vanilla VM is asking to "monitor all network traffic" - I didn't ask for it, how do I disable it?

Jump to solution

Hi All,

I created a Windows 8.1 VM on October 1st, 2013 with the current version, at that time, of VMWare Fusion (not Pro, which has the Network tab on Preferences and the checkbox related to whether to show this prompt) on my Mac.

Since then I've upgraded the OS X version to Yosemite and the VMWare Fusion version up to 7.1.1.

At some point, months or years ago, I started getting the prompt below:

VMWarePromiscuous.png

A virtual machine is attempting to monitor all network traffic, which requires administrator access. Type your password to allow this.

I do NOT want to allow this, as I never asked for this VM to use promiscuous mode, I don't want it to do so, and I can't find anyway to turn this off!

I always cancel out of the prompt and everything works fine.  The only discussions I can find of this in the forums are all relating to people using ESX of vSphere, neither of which I have any knowledge of or have every used.

I've had another Windows 8.1 VM on another Mac for the same time, that went through all the same upgrades, and it never presents this prompt.

Please help make this stupid prompt go away and to stop this VM from trying to use promiscuous mode!

Thanks - Harold

0 Kudos
1 Solution

Accepted Solutions
admin
Immortal
Immortal

Do you have the Hyper-V role installed in the VM?

View solution in original post

0 Kudos
3 Replies
admin
Immortal
Immortal

Do you have the Hyper-V role installed in the VM?

0 Kudos
huntharo1
Contributor
Contributor

Hi jmattson - That was it!  Not sure how that got enabled.  I followed the instructions on the page below to disable it.

Run virtual machines on Windows 8 with Client Hyper-V - Windows Help

Thanks!

Harold

0 Kudos
admin
Immortal
Immortal

You should also find that performance is a bit better now. Smiley Happy

0 Kudos