Thimee
Contributor
Contributor

Fusion 6, Retina and Display Resolution - Can I disable "auto fit"?

Jump to solution

Howdy all,

I upgraded my Fusion to 6.0 today, and am EXTREMELY happy about the changes to the display model in the newest version! Finally I can run Windows 7 / 2008 in a resolution higher that 1440 without the horrible blurry mess.

Here's what I did to get my display working:

1. I enabled "Use full resolution for Retina display" in the Display settings of my Windows VM.

2. I disabled "Automatically adjust resolution size in Windows" (to stop VMWare tools from adjusting my Windows display scaling)

3. Manually set Windows scaling to 100%

4. Changed my Windows screen resolution to a very workable 1680x1050 or even 1920x1200.

The only problem I've run into is that the VMWare tools automatically resize my display to 2880 x 1800 every time I start the VM, or switch from full screen to windowed mode and back. In VMWare Workstation I remember having an option to disable "auto-fit guest" to prevent VMWare from instructing the guest to change resolutions.

Is there such an option to disable automatic resolution adjustment in VMWare Fusion perhaps?

Thanks!

1 Solution

Accepted Solutions
mudaltsov
Expert
Expert

pref.autoFitGuestToWindow = "FALSE" that WoodyZ mentioned disables auto fit for Single Window mode.

pref.autoFitFullScreen = "stretchGuestToHost" should disable auto fit for Full Screen mode as well.

Note that this may not be ideal when using multiple monitors in the virtual machine, because Fusion generally expects the monitor layout to match between the host and the VM.

View solution in original post

20 Replies
WoodyZ
Immortal
Immortal

Try adding the follow setting to the ~/Library/Preferences/VMware Fusion/preferences file with the Virtual Machine(s) shutdown, not suspended, and VMware Fusion closed to see if this gives you what you're asking.

pref.autoFitGuestToWindow = "FALSE"

0 Kudos
Thimee
Contributor
Contributor

Thanks for that setting, I've just applied it to my environment...

Unfortunately, while the setting does prevent the guest from resizing when exiting full screen, it doesn't seem to work when going back into full screen mode (my windows guest resolution automatically still resizes back to the default retina 2880x1800 mode).

Are there any other settings that might do the trick of preventing my guest from resizing itself?

0 Kudos
WoodyZ
Immortal
Immortal

I hadn't tested that setting under VMware Fusion however that is the setting which gets toggled in VMware Workstation and thought it was worth a try.

I have been using two program called RapidRes and IconSaver to keep my Screen Resolution and Windows Desktop icons set/arranged the way I want as I've found it was the best way for me to deal with this type of issue both natively and in a VM so having relied on these I've not had a need to find another way.

0 Kudos
mudaltsov
Expert
Expert

pref.autoFitGuestToWindow = "FALSE" that WoodyZ mentioned disables auto fit for Single Window mode.

pref.autoFitFullScreen = "stretchGuestToHost" should disable auto fit for Full Screen mode as well.

Note that this may not be ideal when using multiple monitors in the virtual machine, because Fusion generally expects the monitor layout to match between the host and the VM.

View solution in original post

WoodyZ
Immortal
Immortal

Michael, thanks for the pref.autoFitFullScreen setting, this work very nice for what I need to do at times.  It would be nice it these setting were available from the Preferences UI vs manually having to edit files.   The nice thing about Unix, it is easy enough to write a script to toggle these values as needed from either Terminal or the AppleScript menu on the Apple menu bar however that said I prefer some check boxes in the Preferences UI! Smiley Wink

0 Kudos
mudaltsov
Expert
Expert

We're definitely considering future improvements to the auto fit and resolution setting logic. The existing preferences are the same as what's used by Workstation (which does have them in the Preferences UI), but they are not very flexible - they affect all VMs, and don't provide a good way to manage specific distinct resolutions in Single Window and Full Screen. Handling multiple monitors without auto fit is also a bit difficult.

0 Kudos
mbrms
Contributor
Contributor

Hello all,

I have exactly the same problem with Fusion 6 as Thimee. Every time I start VM Ware or change the screen to the host the resolution is reset again to 2880 x 1800.

So I added the following both lines

     pref.autoFitGuestToWindow = "FALSE"

     pref.autoFitFullScreen = "stretchGuestToHost"

to the preferences file. However, the problem is not solved.

My display settings are the same as Thimees:

  • "Use full resolution for Retina display" is enabled.
  • "Automatically adjust resolution size in Windows" is disabled
  • My Windows screen resolution is 1920x1200

Maybe the I have a different 3G Graphic Acceleration setting which is enabled. And I do not know the meaning of the step "Manually set Windows scaling to 100%". Is this the scalingt of the fonts etc. which can be set to 100, 125 and 150 %. Does this matter?

And I am not really sure if I have edited the correct preferences file. I can only find one file which is located at "Users/broy/Downloads/vm-01-29-13.2277/Users/broy/Library/Preferences/VMware Fusion"

I also updated today to Fusion 6.0.1 but also without success.

Has anybody a suggestion?

Thanks

Thimee
Contributor
Contributor

I think you are updating the wrong preferences file (the one in downloads would only be used during the install process), here's the location of the local machine preferences file:

~/Library/Preferences/VMware Fusion/preferences


It's a hidden folder in your user directory, to get to this location using finder, select the "Go" menu then select "Go To Folder..." and type in:  ~/Library/Preferences/VMware Fusion/

0 Kudos
mbrms
Contributor
Contributor

Yes, it works. Thank you. I am not the Mac expert so I searched for the preferences file. But the search seems to find only not hidden files. Now it works as expected. Thank you.

0 Kudos
Steven149031
Contributor
Contributor

So is everyone happy now with the retina display and fusion ?

I am thinking of upgrading to the macbook pro with retina but need VMWare Fusion to run smooth !

0 Kudos
edichome
Contributor
Contributor

I bought Fusion 6 just today (Macbook Pro Retina), but feel disappointed, it is not because resolution change automatically, most I feel impossible to use any resolution except 2560x1600, any other quality very low (it is we need accept?). Windows native - no problem, but other software - all just for way to broken eyes..

Maybe have any additional drivers?

0 Kudos
WoodyZ
Immortal
Immortal

edichome wrote: I bought Fusion 6 just today (Macbook Pro Retina), but feel disappointed

VMware Fusion is available with a free 30 day trial license, so if you purchased it without first using the trial license to insure it meets your needs/wants then the disappointment is of your own making! Smiley Wink

Maybe have any additional drivers?

If you have VMware Tools installed in the Virtual Machine then you have all the drivers available to the virtualized graphics card used by VMware in this product.

0 Kudos
edichome
Contributor
Contributor

Thank you for answer.

I should say sorry, i found in settings > Display > disabling full resolution for retina, it is what I need.

Now - all excellent. I satisfied and my previous topic not correct.

In fact, i used WMWARE test in other computer, older version, now v6 more smooth and faster.

Thanks for good software.

0 Kudos
Righardt
Contributor
Contributor

Hi I find that I am using my MBPR on two Samsung LED monitors which is set in Mavericks Resolution: Best for display.

When I load up the Fusion VM of Windows 8.1 the default screen resolves to the MBP and the resolution defaults back to the retina resolution (2560x1920). The other two displays are set for 1920 x 1080.

I will go and set the Default screen to one of the LED displays and set the MBP screen resolution down to 1920x1200, then reboot. After the reboot it has reverted back to the previous resolution and default screen.

The virtual machine settings is set to use "Accelerate 3D Graphics" and "Use full resolution for retina display" is unticked.

What can I do to fix this as I tried the editing the preference file. No luck....with multiple monitors is messed things up and the machine reverted to duplicated screens.

Thanks

Righardt

0 Kudos
joshcanfied
Contributor
Contributor

Just a quick note for those new to VMWare Fusion that to make these changes you need to add:

pref.autoFitGuestToWindow = "FALSE"
pref.autoFitFullScreen = "stretchGuestToHost"

to the

~/Library/Preferences/VMware Fusion/preferences

This resolved my issue with Ubuntu as a Guest OS resizing it's display on boot and when I resized the window in OSX. Thanks @mudaltsov for the solution.

0 Kudos
laurensds
Contributor
Contributor

Hi,

I'm new to all this so don't shoot me.

Yesterday I got my new macbook retina 15 inch, when I set all the settings as all of you advised in this topic, the max (usable) resolution I get in windows 7 ultimate is 1920x1200. Is this normal?

Also not really on topic but how much of the 8 processors and how many memory do you want to allocate to the VM?

http://i.imgur.com/5cp17VJ.jpg

0 Kudos
creativeboulder
Contributor
Contributor

Hi there @laruensds. So you should be able to go higher than 1920x1200 on Windows 7. I have a VM with Windows 7 Ultimate as well and after installing the VMWare Tools ('Virtual Machine' in Toolbar then 'Install VMWare Tools') you should be able to better handle the display. Let me know if that helps.

So as for the processors. For Windows and my Linux VM's I use 3 Processors and 2GB of RAM. It works like a charm. Any higher I found that OSX starts to lag.

Hopefully this is helpful.

0 Kudos
jason_farrow
Hot Shot
Hot Shot

For me a lot, if not all, of these resolution issues disappeared in the Technology Preview July 2014 of Fusion.

I have a MBP Retina 13" Late 2013 running 10.9.4 with Fusion 6.0.4 and the resolution needed to read the screen was never available with Retina enabled in the VM.

With the Tech Preview this has all gone away. I have Retina enabled and I can set any scree resolution I choose and it's all lovely and sharp.

0 Kudos
itkaas
Contributor
Contributor

The GM of our company has a 13" MBPRD. He is running Fusion 6.0.5  and is having this same issue. Every time he restarts the VM it resizes his desktop. So, I went in and modified the preferences file (~\Library\Preferences\VMware Fusion\) to no avail. When he sets the size he wants and restarts the VM it reverts back to the max retina display resolution. Also, if he sets the resolution he wants and does not restart the VM it will automatically reset the resolution within ~5 minutes making the screen virtually unreadable because it is so small.

Any brilliant ideas out there aside from the preferences file (since it didn't work)?

It may also come into play that this is a VM that was moved from an older MBP to this new one.

Thanks.

0 Kudos