Enthusiast
Enthusiast

Fusion 6.0.2 and OSx Mavericks 10.9.1 - Sleep Wake failure unless I shutdown or suspend my Win7Pro VM before closing lid

I recently bought a new macbook pro, tht is up to date with Mavericks 10.9.1

I bout Fusion 6 and migrated my VM from my old macbook that was running Fusion 4.

All seemed to go well.

The VM performs awesomely.

The problem is when I put the Macbook to sleep... I get the 'infamous' Sleep Wake Failure when I wake it up, and the macbook is restarted.

I say infamous, as there are many users of mavericks experiencing this for all sorts of causes.

In my case I singled the cause down to my VMware Fusion 6, running a Win7 Pro machine. If this is still running when I sleep the Macbook then I get the Sleep Wake Failure every time I wake the MacBook. If I shutdown or suspend the VM first, then this does not happen.

Please can this be looked at...

I used to work in this way with my old macbook (OSx Lion, Fusion 4) and never had issues sleeping the macbook and resuming.

Thanks

Simon

188 Replies
Contributor
Contributor

I was having this issue after I upgraded my MacBook Pro 17" Retina Display to Mavericks; still on VMWare 4.  The only thing that seemed to keep this from happening is to either shutdown the Windows 7 OS or suspend it as previously mentioned.  I just upgraded my MacBook Pro to Yosemite 10.10.2 and of course had to upgrade VMWare Fusion as 4 was no longer supported.  I've upgraded to Fusion 7 hoping this issue would be resolved.  It has not been resolved.  The issue continues.  Everything you hear about VMWare fixing things in a timely manner and from release to release is true.  It simply doesn't happen.  I used to work for a software vendor, will go unnamed, but at least we responded to major issues like this in a timely manner.  At least recognize that there is an issue.  Please?

0 Kudos
Contributor
Contributor

VMWare why do you hate the environment? I wonder how many people are using inefficient pmset modes to work around this issue by now. VMWare does not care about America or energy independence.  This is likely all part of a NWO plot to erode people's efforts to decrease reliance on centralized power. There's no way a company of your resources can truly be this incompetent. Every update to this thread without resolution reaffirms my belief that VMWare is an NWO shill.

If I happen to be wrong and you are not maliciously attacking America and its attempts at energy independence please respond by firing the Fusion Program Manager.

0 Kudos
Contributor
Contributor

Also: just noticed I missed the 1 year anniversary of this thread. Happy Anniversary all!

0 Kudos
Enthusiast
Enthusiast

Just had another sleep/wake crash. I am at this point forced to evaluate Parallels. I cannot live with a situation where I can't put my laptop to sleep without losing my entire working environment.

VMware, please tell me you're at least aware of the problem and working on a fix. If you're still sticking your head in the sand and going "la la la can't reproduce", please send a tech over and I'll be happy to reproduce it for him a thousand times.

0 Kudos
Contributor
Contributor

I have been troubleshooting this issue with VMware support fro over 3 months now. After all they did and did not solve the problem, I changed my MBP and even reinstalled Windows 7. Nothing helps.

This problem happens sometime daily and sometimes there are 2-3 days that I do not encounter it. But recently it has been daily.

Has anyone tried disabling Powernap. I say that because the issue for me always happens when I had my MBP on the charger and lid closed and did not seem to happen when charger was not connected. By default Power nap is enabled while power is connected. So I just disabled it and will test this out and post the results.

I wish VMware support was more active in this post and would say something.

0 Kudos
Contributor
Contributor

Don't waste your time.

I tried everything, nothing works.

In my case VMWare support closed the issue because 'it was opened for too long' and 'a fix will come in the future'.

I am not recommending this product any more and the fact that VMWare claims that it "cannot be reproed in-house" really says something about their QA team.

Contributor
Contributor

I gave up on getting a fix from VMWare on this issue.

While OSX should not crash, a driver could crash the kernel. It seems to me like the AppNap is not getting sent to the VM correctly. Disabling AppNap / hibernation etc does not help either. Guess the driver for vmware seems to be not listening (well) to suspend events.

I remembered that didnt have a problem early on, but my Linux VM would take time to resume, whenever my mac resumed, it no longer happens for some reason and I get SWFs.

The way I am solving this for now and seems to work reliably is to use the  Sleepwatcher (bb's Homepage) and scripts for suspend/resume use the command line vmware commands to force suspend and resume from system sleep.

-----------

cat ~/.wakeup

/Applications/VMware\ Fusion.app/Contents/Library/vmrun -T fusion start <vmx>

-------

cat ~/.sleep

/Applications/VMware\ Fusion.app/Contents/Library/vmrun -T fusion suspend <vmx>

-----------

The setup of sleepwatcher is simple and provided in the Readme. It requires some command line operations.

0 Kudos
Contributor
Contributor

Exactly the same problem on mid 2012 Macbook Pro 15 with Retina.

Even had my main board changed in Apple Store, no difference. It started with upgrade to Maverics, save issues with Yosemite. Tried opening ticket with vmware, never got a reasonable reply only some kind of try vague tips that led nowhere. happening with both 6 and 7.

It is big shame of company like vmware that they cannot fix this and acknowledge the issue.

I strongly suggest everyone to look for competitive product (parallels). I'm from SW industry, it is ok to have bugs. But the ignorance of vmware shows they do not care at all about their customers.

Contributor
Contributor

xsima78xsima78 , I have confirmation from vmware support that this is acknowledged as a bug. Their development team is working on it but obviously they can't provide an ETA.

For me sudo "pmset -a hibernatemode 0" so far seems to have worked (2 days with no crash). Have you given it a try? Setting Hibernate mode to Zero is not ideal but a good interim solution until the fix is available.


Cheers

Here is my pmset -g custom results:

Battery Power:

lidwake              1

autopoweroff         1

autopoweroffdelay    14400

standbydelay         4200

standby              1

ttyskeepawake        1

hibernatemode        0

darkwakes            0

gpuswitch            2

hibernatefile        /var/vm/sleepimage

displaysleep         15

sleep                15

acwake               0

halfdim              1

lessbright           1

disksleep            10

AC Power:

lidwake              1

autopoweroff         1

autopoweroffdelay    14400

standbydelay         4200

standby              1

ttyskeepawake        1

hibernatemode        0

darkwakes            1

gpuswitch            2

hibernatefile        /var/vm/sleepimage

womp                 1

displaysleep         15

networkoversleep     0

sleep                60

acwake               0

halfdim              1

disksleep            10

Contributor
Contributor

Same here. I work in software, too. It's not a good sign, how long this bug has been denied & ignored. Raises troubling questions. Zero priority or resources or QA = Lack of commitment to the product. Is the company planning to discontinue Fusion? If the company doesn't take it seriously, should I?

Apple replaced the battery, the logic board. I reset PRAM, reinstalled OS X, upgraded to 10.10. Upgraded VMware to version 7. Enabled "Pass power status to VM." Disabled disk spin down while connected to the power adapter, disabled various nap and autosave settings. Nothing worked. Next step is to downgrade to VMware 5, which means downgrading OS X too, and all software... not practical.

Only happening since VMware Fusion 6.0.2 -- 5 was stable. Happens when Windows 7 VM is running. Never for Linux-based VMs e.g. CentOS, FortiGate.

VMware 7 "upgrade" did not fix it. Speed is nice, yes, but I need to know that when I walk away from my computer, VMware won't play Russian roulette...

VMware 6 and 7 are stability downgrades.

MacBook Air (13-inch, Mid 2012)

OS X 10.10.3

VMware Fusion Pro 7.1.1

0 Kudos
Contributor
Contributor

I gave up altogether. I am very sure that VMware fusion fried my last 4 Mac book pros in the last 7 months. Every time I opened the Mac it was one of 3 possibilities, Mac would wake up or Mac would not wake up and I had too restart it or Mac would be just dead. Took the 4 that died to apple store and in all cases they said mother board needs to be replaced as something was fried on it..

Then with the 5th MBP, I just decided not to install VMware fusion. It has been 6 weeks. Not a single wake issue. Mac still alive and well.

Contributor
Contributor


It does seem absurd that this has been going on for so long.  I know many people having this issue.  I've tried every proposed fix and have not found anything that is reliable.

Has anyone heard any updates from VMWARE on this?

John

0 Kudos
Contributor
Contributor

Yes, it still happens. Because it's VMware Fusion that is triggering it -- not Yosemite, Mavericks, etc.

One person reported that support acknowledge the bug. Dev is working on it, they say, but no ETA.

0 Kudos
Contributor
Contributor

Wow nriahinriahi. Is VMware going to compensate you?

0 Kudos
Contributor
Contributor

Did not ask. Was all company MBP, covered by Apple warranty. Time lost troubleshooting, priceless.

0 Kudos
Contributor
Contributor

I think this bug might be gone. It didn't repro on my 10.10.3 with 7.1.1 anymore for the full weekend. I put the laptop to sleep about a half dozen times now. I hope I am not speaking too soon.

0 Kudos
Contributor
Contributor

No, it's still there. Mine crashed yesterday (10.10.3 with VMware 7.1.1).

Sometimes it's 6 days between crashes for me. If you reboot a lot, that might have an effect of clearing out the RAM back to initial state before it reaches a crisis; I do not reboot unless forced, and don't quit VMware unless forced either.

Today, upgraded to VMware Fusion 7.1.2. Logged a ticket with support. Quick initial response. But it seemed he had not fully read my initial ticket, because he began asking things I'd already said I tried.

I doubt it is fixed yet.

0 Kudos
Contributor
Contributor

11" Air, Mid-2012 (i7, not i5), OSX 10.10.4, VMWare Fusion 7.1.2, Win7 guest. I get the same problem.

I did not notice it on 10.10.3, although it's not often that I leave a VM running and suspend. It seems the issue is more strongly related to Win7 guests, as I don't recall ever seeing the issue with Win8.1 or Linux guests, which I do often forget about when closing the lid.

0 Kudos
Contributor
Contributor

Ticket open for 1 month. Multiple crash logs uploaded.

Still no fix.

0 Kudos
Contributor
Contributor

The only thing that works for me is to suspend the VMWare instances before putting the MacBookAir to sleep.  This is really a huge inconvenience as when I do forget once in a while, after a while the computer will crash and I will loose any unsaved work in the VMWare instance.

0 Kudos