delsvr
Contributor
Contributor

Fusion 2.0.1, Spaces, Full Screen Mode

Fusion 2.0.1 has the behavior of not knowing which Space the VM window is in when it switches to full screen mode; i.e. when switching to fullscreen mode, the fullscreen will not necessarily appear in the space of where the VM window currently resides.

To reproduce:

  1. Start Fusion in window mode in Space 1

  2. Move the VM window to Space 2

  3. Switch to fullscreen mode

Notice that the fullscreen mode is now in Space 1; it didn't realize that we moved the window to Space 2.

Workarounds:

  • Force Fusion to work in only one space. In the Spaces configuration, you can setup Fusion so that it only runs in, say, space 2. Fusion will now always switch to full screen mode into space 2.

  • Move Spaces manually. After switching to full screen mode, press F8 (by default) and rearrange your full screen instance of Fusion onto another space by dragging it somewhere else.

I don't consider either workaround to be a good solution to this problem.

Is VMWare aware of this issue? May we expect a fix soon? This is the only thing preventing me from purchasing Fusion =(

Thanks.

0 Kudos
3 Replies
borisdusek
Expert
Expert

I guess the answer (I am not VMware employee, I just follow this forum and remember this being discussed before) is that VMware is aware of this, but there is little they can do about it because it's Apple who has not yet provided software developers a way to work with Spaces. So I guess the resolution could come only with Snow Leopard, if at all (i.e. if Apple decides to make the API to work with Spaces public in Snow Leopard, which, "thanks" to NDA, you can hardly know, unless you yourself have the paid ADC subscription).

I use both of your workarounds: What I do is that I setup Fusion to be on Space 2 in the preferences menu as you described. I do normal OS X stuff (browsing web, reading PDFs) on Space 1 and have Windows XP with development stuff (Visual Studio) fullscreen on Space 2 and switch between them with keys. Only seldom do I need another VM, if that is not Linux (to which I ssh from OS X instead of viewing it in Fusion), I fullscreen it and drag it manually then to another Space, again as you described. I guess if you are not starting and fulscreening new VMs every few minutes, this is acceptable, however it really depends on your usage pattern or taste for perfection Smiley Happy

federicodeis
Contributor
Contributor

I haven't had the problems you mention. In System Preferences -> Spaces I've set Fusion to start in Space 2, then, when I go to full screen, Fusion stays in the selected Space, allowing me to move between spaces with my defined shortcuts

0 Kudos
AntennaGuy
Contributor
Contributor

That's actually a great workaround. I was already using Spaces to force Space2 for vmware. But now that I am using 2 VMs (XP & Windows 7), I couldn't figure out how to full screen them each into individual spaces.

Who knew you could drag a full screen image in (All) Spaces mode activated? (i didn't).

Great workaround, guys! Not a big deal to F8 and drag to Space4.

I agree, however, once the developers can access Spaces, it would be a nice preference for each VM.

0 Kudos