erikread
Enthusiast
Enthusiast

Fusion 12 w/ Big Sur Display Flicker

Just upgraded to Big Sur and, among other issues, my Windows 10 VM flickers in full screen mode. It did not do this in Catalina using the same version of Fusion.

My system is 2019 15" Macbook Pro i9 with 32GB RAM.

In full screen my display flickers but not in windowed mode. My display is a Dell U3818DW running at 3840X1600. Again this worked yesterday before upgrading to Big Sur.

95 Replies
ockarl
Contributor
Contributor

I tried the workarounds, like trying to disable 3D support or switching the renderer. Unfortunately, dimming & brightening is still there.

0 Kudos
ockarl
Contributor
Contributor

I tried the workarounds, like trying to disable 3D support or switching the renderer. Unfortunately, dimming & brightening is still there.

PS: I'm sorry, wasn't logged in when posted the answer... Didn't know that works...

0 Kudos
Toms_Mac_Pro
Contributor
Contributor

The workaround is to chose a different colour profile for your Monitor.

go to -> System Preferences / Display / Color

0 Kudos
JonathanWickens
Contributor
Contributor

Another workaround which seems to do it for most people is having the Full Screen Minibar set to Always Show in the View menu. I think for me I had to reboot before it took effect. 

0 Kudos
widmerkarl
Enthusiast
Enthusiast

I'm currently working only with the integrated MacBook screen, I only have one color profile, and this is active.

Best regards,
Karl
Blog: https://www.driftar.ch | Twitter: @widmerkarl
0 Kudos
widmerkarl
Enthusiast
Enthusiast

I think the workaround with the full screen minibar set to always show will actually help.

I had to restart / shutdown the Windows VM and I also restarted my Macbook, and until yet it seems that there is no flickering. Weird.

 

Best regards,
Karl
Blog: https://www.driftar.ch | Twitter: @widmerkarl
powershell_guru
Contributor
Contributor

Same here unfortunately. 

  • MacBook Pro (15-inch, 2016)
  • 2.9 GHz Quad-Core Intel Core i7
  • 16 GB 2133 MHz LPDDR3
  • Radeon Pro 460 4GB
  • 1 Kensington TB3 dock station with 2x Dell 24" displays. 

As mentioned in a comment below, the problem was rectified by disabling Nightshift so perhaps macOS is trying to apply dark mode or something?  Not sure but my fans are screaming and this Radeon setup is killing me softly.

0 Kudos
misterbell
Contributor
Contributor

The full screen minibar workaround has been reliable for me for quite some time now.

I normally work with my VM on an external monitor. This might help someone... Yesterday, the annoying flicker returned (which does appear to be an intermittent cycling change in colour & brightness), and the minibar was not showing for som reason. Changing the menu setting back and forth so that the minibar should always appear, or show in a different location on the screen did not persuade it to reappear, and the flicker continued. It wasn’t until I moved the mouse pointer from the external monitor to the laptop display and clicked there that the minibar suddenly returned, and the flicker was gone.

0 Kudos
ryrij
Contributor
Contributor

I'm also affected by this bug. I'm on 2018 Macbook Pro, latest big sur 11.1 and VM on latest hardware version. 

Enabling full screen mini bar overlay fixes it or disabling night shift schedule in Mac OS settings. 

0 Kudos
icefrogik
Contributor
Contributor

It's worked for me 🙂

0 Kudos
joaodmoradei
Contributor
Contributor

I have a 2019 16 inches model and was having problems with the external Acer display (flashing and flickering) but the problem was using an external USB-C hub from Satechi with an HDMI port. After I changed the connection to a direct USB-C-HDMI cable the display problems went away. Are you seeing the problem only when using Fusion or does it also happen with other heavy tasks?

0 Kudos
Jeer007
Contributor
Contributor

I resolved the same issue with my external Dell U2715H monitor by selecting Mac OS-->System Preferences-->Display and then select Color-->Calibrate... for the Dell monitor.

 

I'm running Fusion 12.1 on Big Sur and Windows 10 as guest OS.

0 Kudos
stefanovesa
Contributor
Contributor

Hello,

problem seems solved for me updating Video Driver as suggested today by Windows Update:

stefanovesa_0-1612961545951.png

 

 

0 Kudos
maximusgeekus
Contributor
Contributor

Spot on Jonathan, worked perfectly; flickering gone, thank you! Actually the minibar when dragged to the top of the screen is also quite useful indeed! This is of course a workaround and hopefully the VMWare team will include a proper fix soon.

thedevdad
Contributor
Contributor

Same issue here gets resolved by always displaying the minibar, but would love a true fix. Bummer that I paid to upgrade in order to keep working with VMs on Big Sur just to have this bug be such a nuisance.

Specs:

  • MacBook Pro 13-inch, 2020
  • 2.3 GHz Quad-Core Intel Core i7
  • 32 GB 3733 MHz LPDDR4X
  • Intel Iris Plus Graphics 1536 MB
  • VMware Fusion Player Version 12.1.0 (17195230)

This is happening on my built in display as well as on an LG Monitor

ekinney
Visitor
Visitor

How do you turn off True Tone?   Is the in the VM or the Mac?

0 Kudos