erikread
Enthusiast
Enthusiast

Fusion 12 w/ Big Sur Display Flicker

Just upgraded to Big Sur and, among other issues, my Windows 10 VM flickers in full screen mode. It did not do this in Catalina using the same version of Fusion.

My system is 2019 15" Macbook Pro i9 with 32GB RAM.

In full screen my display flickers but not in windowed mode. My display is a Dell U3818DW running at 3840X1600. Again this worked yesterday before upgrading to Big Sur.

95 Replies
eirannejad
Contributor
Contributor

I'm not impressed that after this much reporting, from so many users, @VMware still hasn't pushed a fix for this.

Victoria9
Contributor
Contributor

I only use one app on my VMware, and I only have one display. I rarely go online because I can do that from my iMac side. I don't have the complicated set up that most of you have. I can pull the dock up, and yes, the flickering stops. But, I am unable to leave the dock up because it obscures information I need to see at the bottom of my screen. I hope VMware is working on this and it's fixed soon. They are usually pretty good at keeping this app clean and running smoothly.

0 Kudos
JonathanWickens
Contributor
Contributor

Hi,

The dock is not the same as the minibar. If you click the View menu item in the VMFusion menus you can see an option for minibar which includes always hide and always visible. If you select always visible you get a small toolbar at one edge of the screen which is hardly noticeable and that will stop the flickering for now.

Victoria9
Contributor
Contributor

Thanks so much for the clarification, Jonathan. Problem solved.

0 Kudos
lakewash
Contributor
Contributor

thanks for this tip.  I am using three monitors so can't figure out how to employ this fix and still use all three because if I take out of full screen I cannot extend the VM beyond the main monitor. thanks

0 Kudos
winonmac
Contributor
Contributor

Thanks minibar always visible on left, right, bottom worked for me - no more flicker on full-screen.

0 Kudos
cordvarty
Contributor
Contributor

I wasn't having an issue with display flicker but my screen was freezing every 1-2 seconds for about 200ms. This would only happen while in full screen mode. Enabling the Always Show option for the Full Screen Minibar resolved the issue. Thanks!

0 Kudos
raitosan
Contributor
Contributor

Also encountered this issue, Always Show Minibar also fixed the issue for me. Very irritating bug. Thanks!

0 Kudos
JonathanWickens
Contributor
Contributor

Hi @zhus , as an VMware employee are you able to give us any indication of when this might be fixed?

I see a steady stream of people adding to this thread with the same flicker symptoms and also one or two who seem to be getting the screen temporarily going black issue. Most appear to benefit from the minibar workaround but obviously it continues to incovenience VMware users and there are probably many more who don't report their issues here.

Please let me know if I can supply any more traces, logs etc. to help get it resolved.

0 Kudos
Toms_Mac_Pro
Contributor
Contributor

The Flicker happens in Full Screen mode with all guest OS on the Intel iGPU. On the Radeon Vega it is not Flickering.

The Mini-Bar Trick is working and choosing a  different Colour Profile in "System Preferences - Displays - Color" also works.

0 Kudos
jwpro
Contributor
Contributor

I just did an upgrade to VMware Fusion 12.1.0 and I have the same issue on macOS Big Sur as well.

0 Kudos
Toms_Mac_Pro
Contributor
Contributor

Yes, I am using Big Sur 11.0.1 and VMware 12.1.0

0 Kudos
Sandaman
Contributor
Contributor

Same here. Big Sur host running Win10 in Fusion 12. flickering in every Win 10 guest I have.

Even when creating new Win10 guest, the Windows installer shows the same already.

Tried reverting "Use hardware version" from 18 back to 16 again in Fusion Compatibility settings: no luck

Tried reinstalling screen driver in Win10 (safe mode - remove driver - restart - run updates): no luck

Tried different Win 10 graph driver settings: no luck

Thanks to suggestions here, resolved for now:

Full Screen Minibar - Always Show  - BUT NOT WHEN POSITIONED AT TOP OF SCREEN - showing on left side works for me.

0 Kudos
Toms_Mac_Pro
Contributor
Contributor

Read the post 3 positions above yours.

0 Kudos
jowy
Contributor
Contributor

Any fix ?

0 Kudos
jowy
Contributor
Contributor

same here, Big Sur, fusion 12 , all guests ... 

0 Kudos
RickB_Lanboss
Contributor
Contributor

I have the same, New MacBookPro, Big Sur, VMware 12 latest, Win 2016 (Server) guest... flicker on window create or any mouse movement.  

Wanted to add that the flickering also manifested as a change of colour of my backdrop, which was set to white.  During a flicker, it would temporarily go to blue then back to white, reminscent of a monitor colour adjustment.

0 Kudos
widmerkarl
Enthusiast
Enthusiast

Hi there,

Same issue here. The background brightens and dims repeatedly. It's not that annoying at the moment because I just installed a VM, but it might get really annoying when I'm going to work on that VM.

Setup:

  • MacBook Pro 15" Retina, Late 2013
  • macOS Big Sur 11.1
  • VMware Fusion 12.1.0
  • Windows 10 Pro 64 Bit, 20H2 (19042.746)
  • VM HW version 18

Cheers,

Karl

Best regards,
Karl
Blog: https://www.driftar.ch | Twitter: @widmerkarl
0 Kudos
RickB_Lanboss
Contributor
Contributor

I gave up and reverted my MacBook to Catalina, far too many issues with Big Sur.  Not just Fusion, but many other apps too. 

One word of caution, if you have a recent Mac of any sorts with the T2 security chip, you MUST remember to turn on the ability to boot from external media, before you zap the partitions in Disk Utility.  Otherwise you will be in for a very frustrating time, as the tools you need to use is in the recovery partition you just erased.

0 Kudos
Toms_Mac_Pro
Contributor
Contributor

Try reading some postings. The issue has been solved. There 2 workarounds available.

I have no problems with Big Sur. On the contrary, Big Sur is much more stable and has less bugs than Catalina.

0 Kudos