erikread
Enthusiast
Enthusiast

Fusion 12 w/ Big Sur Display Flicker

Just upgraded to Big Sur and, among other issues, my Windows 10 VM flickers in full screen mode. It did not do this in Catalina using the same version of Fusion.

My system is 2019 15" Macbook Pro i9 with 32GB RAM.

In full screen my display flickers but not in windowed mode. My display is a Dell U3818DW running at 3840X1600. Again this worked yesterday before upgrading to Big Sur.

95 Replies
Hutchi07
Contributor
Contributor

Same symptoms here with Big Sur and Fusion Player 12.  Windows 10 VM. MacBook Pro (Retina, 15-inch, Mid 2015) - i7/16GB.

 

0 Kudos
JonathanWickens
Contributor
Contributor

I only have one VM space, and haven't plugged and unplugged while running the VM. I don't think this issue applies. Like most people here this issue has only arisen since using VM Fusion 12 on Big Sur. I was running VM Fusion on Catalina no problem (and no flickers) and this issue appeared directly after the upgrade to Big Sur, without any other changes to VMFusion version

0 Kudos
zhus
VMware Employee
VMware Employee

Could you please provide the logs as below if convenient?

  Fusion UI log: /Users/YOUR_ACCOUNT_NAME/Library/Logs/VMware\ Fusion/vmware-vmfusion.log

  VMX log: PATH_OF_.vmwarevm/vmware.log

It would be better if someone could attach a short screen recording.

Thanks a lot.

0 Kudos
robkersey
Contributor
Contributor

Hey @zhus any way to message you or email them direct rather than posting to a forum?

 

0 Kudos
ChrisSmithIT
Contributor
Contributor

here you go logs and video... I also am experiencing same issue only in full screen mode and without dock... all VM display settings have not made a difference.

0 Kudos
robkersey
Contributor
Contributor

Even More strange behaviour today... seems to be related to running Microsoft Teams.

Resolution seems to resize after Teams meeting has been running for some time with another user presenting. Looked like it went to 800x600.

I've then been logged out of windows and all apps closed, this happened twice.

 

0 Kudos
zhus
VMware Employee
VMware Employee

My email: zhus@vmware.com

Thanks for reporting.

I failed to reproduce the flicker issue locally, so the logs or support bundle(better) could be helpful.

0 Kudos
zhus
VMware Employee
VMware Employee

@ChrisSmithIT Got it, I'll forward it to team. Thanks a lot.

0 Kudos
JonathanWickens
Contributor
Contributor

I've also sent the two log files requested, in case it helps. I recorded the screen using quick time and shift-ctrl-5 and in both cases the flickering refused to appear. As soon as I stopped recording it came back. I updated Fusion to 12.1 this morning but am still getting the flicker. For me displaying the fullscreen minibar still fixes the flicker which reappears as soon as I hide the minibar. The flicker also seems to be a small increase or decrease in brightness sometimes separated by several seconds depending on how much you move the cursor or where it hovers. For example if I move my cursor to the bottom of the screen to display the Mac dock, the dock displays and the brightness changes and then when I move the cursor away and the dock disappears there's another change in brightness. However I've had it flipping very quickly when hovering over the windows start icon.

0 Kudos
DIRIT
Enthusiast
Enthusiast

Just realised that my problem may be different.  That in my mind is way worse.  Mine is annoying but semi-usable.  My screen had been going black for a few seconds and then coming back.  As of late it seems to make the windows program I am running disappear showing only the background and then coming back usually requiring some sort of input.  Very interesting.  If people could let me know if @ChrisSmithIT 's video is typical of what they are experiencing and if I am the only one where it either goes to black or background for a couple of seconds then comes back.  I will create my own discussion.  @ChrisSmithIT very good to see your video as I thought of mine as a flicker but yours seems to be illness inducing from what I can tell.

0 Kudos
robkersey
Contributor
Contributor

@DIRIT My problem is similar to yours, screen goes black for a second and then comes back. This seems to be the start of things going south. 

it’s way worse when viewing another persons screen in MS Teams. Eventually it gets worse and worse and then drops to 800x600 res in the guest and then logs me out. pretty annoying part way through a customer call!

I will collate logs and send in. 

0 Kudos
JonathanWickens
Contributor
Contributor

Hi, as far as I can tell my issue is the same as or similar to @ChrisSmithIT . When I shut down my VM or start it up I see a flicker which seems to pulse once a second, but I don't get the screen going black. Once the VM is up and I've logged in to Windows then I see slight brightness changes which are much more intermittent and seem in many cases to happen in response to a change in what's being displayed, e.g. a mouse pointer movement, output from a program, the dock appearing etc. I'm assuming  the regular change in focus on @ChrisSmithIT video is the phone getting thrown off by the flicker

0 Kudos
ChrisSmithIT
Contributor
Contributor

@DIRIT does sound like your issue is slightly different to mine. I've enabled the dock in the full screen mode and it is fine but I find the dock a little irritating as it obscures view in some apps.... Prefer to have no dock but the constant screen flicker dimming brightening over and over again is indeed illness inducing! 

0 Kudos
ChrisSmithIT
Contributor
Contributor

@JonathanWickens Yes this was the phone, like you suggest auto focus reacting to the flicker, but equally could be my camera skills!!! The resolution and screen remains in focus on the VM. I've tinkered with all settings to try and overcome but the only workarounds are coming out of full screen mode and or having the dock in view. Def was not having this issue with 12.1 Fusion running on Catalina.

0 Kudos
robkersey
Contributor
Contributor

I can't recreate this issue using MS teams on my mac sharing the screen to the teams on my Guest VM... all day I have had problems with screen share and remote call to someone else? NOw I try to recreate in a controlled inevironment and it doesn't play up?

I wonder if it's got something to do with network latency?

0 Kudos
misterbell
Contributor
Contributor

I've been working with the workaround (always display the minibar in full screen) for quite a while - no flicker.

This morning, I had a weird one where the minibar wasn't actually showing for some reason. I was alerted to this because my screen started flickering again.

Once I'd convinced the minibar to display again, the flickering stopped.

0 Kudos
JonathanWickens
Contributor
Contributor

Same here, the minibar is a reliable work round. I had an email conversation with Shan Zhu (@zhus) in last day or so, after sending my logs, who asked me to create a config file with a line which forced VMware to use OpenGL renderer rather than the Metal renderer and that also fixed the issue so seems to be something with the way the app uses Metal. Maybe .. I'm not an expert. However the minibar fix allows the app to use whichever renderer it wants and has the same effect so is still probably the least impact workaround - I hardly notice it now on the right. I assume the full fix will appear when the developers have worked out what's happening with the Metal Engine.

0 Kudos
demky
Contributor
Contributor

Minibar workaround fixed the flicker for me as well on a 2018 Mac Mini

0 Kudos
eestar
Contributor
Contributor

Same symptoms with mbp16, Big Sur and Fusion Pro 12.1.0. The default color profiles for macOS and Windows (yes, I used a custom color profile for both) fixed the issue. The mini bar is disabled.

0 Kudos
DIRIT
Enthusiast
Enthusiast

For those that are having a problem of their screen flashing as if VM is changing resolutions intermittently and Windows 10 is redrawing:  I created a separate subject after viewing one of the videos as to what was meant by "flicker".  Mine ended up not being the same symptom so I wanted to separate out the symptoms I was having.  So I apologise to @erikread if I mistakenly hijacked your thread.  I have created a new thread at "Fusion 12 Big Sur - Screen going black for a few seconds".

Sounds like @robkersey is having an issue more like my issue.

0 Kudos