Highlighted
Contributor
Contributor

Fusion 10 on 10.12 won't start any virtual machine

I just upgraded to Fusion 10 (from Fusion 8.5.8) and I'm still on Sierra, preparing my upgrade to High Sierra.

But: After migration the virtual machines to the corresponding internal Version (14) I'm still not able to launch them. They are all stuck with an "internal error in the virtual machine" (sorry, no exact translation as I'm using the German version). Basically, after a normal start of a machine, I run into an error saying the machine can't be launched.

I even tried to install a new machine, but the error is happening too - right before the very first start (not Windows setup at this point). It seems as if Fusion 10 isn't able to launch any virtual machine, even complete new ones.

Anyone having this problems too?

38 Replies
Highlighted
Contributor
Contributor

I got the same error on High Sierra. Just upgraded to Fusion 10 and no virtual machine will start (not even a newly created).

As soon as I hit the "play" button the vm stops and Fusion is reporting (translation from german) "There has been an Error and windows was shut down" all I can do is to click "ignore" "report" or "restart windows".

If i upgrade the machines from version 12 to 14 makes no difference. It seems the error lies in the graphics acceleration. When I disable it the machines will start, as soon as I reenable it the error comes back. It makes no difference if there is an external monitor connected or not.

Fusion 10.0.0 (6665085)

macOS High Sierra 10.13 (17A365)

MacBook (Retina, 12-inch, Early 2015) (MacBook 8,1 1.2 GHz, 8 GB RAM, 500 GB SSD)

PS: on my iMac all machines run fine, looks like something is wrong with the graphics implementation...

0 Kudos
Highlighted
Contributor
Contributor

Same problem here. If I disable 3D Accelerated Graphics in the VM-settings then it works fine. There seems to be a problem with the svga-driver? This is from my log-file:

2017-09-27T09:17:16.367+01:00| svga| E105: PANIC: Failed to create library from source, error Compilation failed:

2017-09-27T09:17:16.367+01:00| svga| E105+

2017-09-27T09:17:16.367+01:00| svga| E105+ <program source>:68:19: error: too many elements in vector initialization (expected 4 elements, have 😎

2017-09-27T09:17:16.367+01:00| svga| E105+    TEMP[0].yzw = (float4(5,00000000e-01f, 0,00000000e+00f, 0,00000000e+00f, 5,00000000e-01f)).yzw;

2017-09-27T09:17:16.367+01:00| svga| E105+                   ^       ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

2017-09-27T09:17:16.367+01:00| svga| E105:

2017-09-27T09:17:16.367+01:00| svga| I125: Panic: can't get userlevel lock.

2017-09-27T09:17:16.367+01:00| svga| W115:

2017-09-27T09:17:16.367+01:00| svga| W115+ The core dump limit is set to ZERO; no core dump should be expected

2017-09-27T09:17:16.368+01:00| svga| I125: Writing monitor file `vmmcores.gz`

2017-09-27T09:17:16.375+01:00| svga| W115: Dumping core for vcpu-0

2017-09-27T09:17:16.375+01:00| svga| I125: Beginning monitor coredump

I had this problem before upgrading to High Sierra. Tried both mys windows 10 and windows 7 VM, same issue, regardless of Virtual Machine Hardware version (12 or 14)

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hallo ckater,

Would you please try to add mks.enableMTLRenderer = "0" into vmx file and see if it helps?

Please shutdown your VM and before you add this line into vmx file.

mfG,

-Rick

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi gabhau,

Are you using  German version of MacOS as well?

Regards,

-Rick

0 Kudos
Highlighted
Contributor
Contributor

Hi,

Thanks for the quick answer!

Adding the option mks.enableMTLRenderer = "0" Solved the problem. Now both my Virtual machines work with 3D enabled. I'm using the English version on a swedish-locale macOS.

/ Gabriel

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi gabhau,

Is the crash issue still reproducible after your host upgrade to High Sierra (macOS 10.13)?

Regards,

-Rick

0 Kudos
Highlighted
Contributor
Contributor

Very interesting - disabling 3D acceleration brings the VM to start. I use High Sierra. I hope an easy fix will be provided soon. At least, I can use Windows 10.

Thx , MK

regards, Michael
0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi mkummer,

Would you please inform about the hardware specification of your Host and the language version of your macOS?

Thanks,

-Rick

0 Kudos
Highlighted
Contributor
Contributor

I have an iMac 5K 27 inch late 2015, 32 GB  and SSD 1 TB with German macOS high Sierra.

regards, Michael
0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi mkummer,

Thanks for the quick response. As temporary workaround, you can try either of following ways:

1) Switch to English language in your macOS host (Restart required)

or  2) Add mks.enableMTLRenderer = "0" into vmx file

or) 3) Disable 3D acceleration in VM settings

Sorry for any inconveniences.

Regards,

-Rick

Highlighted
Contributor
Contributor

Looks like I shall stick to 3) for the time being. It works and I use mainly financial software.

Please keep me informed about further development - i.e. if 3D can be activated again. 

MK

regards, Michael
0 Kudos
Highlighted
Contributor
Contributor

Hallo Rick,

yes, mks.enableMTLRenderer = "0" did the trick.

I can confirm:

- after migrating macOS to 10.13 the problem persists

- adding the value into vmx fixed it for me

- I've got the German version of Fusion 10

My machine is a MacBook Pro 15'' 2016.

Hope that helps to fix the problem!

0 Kudos
Highlighted
Contributor
Contributor

Hi,

Yes, I have the samme problem on 10.13 too.

/ Gabriel

0 Kudos
Highlighted
Contributor
Contributor

Hi,

I have the same problem with Fusion 10 on MacOS High Sierra 10.13, MacBook Pro (Retina, Mitte 2012), German Language set.

Disabling 3D works and changing system language also works, but both workarounds cannot be a permanent solution.

When will VMWare provide a fix?

regards

Dietrich

0 Kudos
Highlighted
Contributor
Contributor

Hi,

I'm having the same problem with Fusion 10 on MacOS High Sierra 10.13, MacBook Pro (13-inch, 2017), German Language set.

Kind regards,

Dieter

0 Kudos
Highlighted
Contributor
Contributor

Hello,

Just want to add that there I am having the same issue with VMware 10 running under High Sierra (French) - The VM will crash on start unless I disable 3D acceleration.

Denis

0 Kudos
Highlighted
Contributor
Contributor

Hello Forum,

I experience the same problem here on:

MacBook Pro (Retina, 15-inch, Mid 2015) (MacBookPro11,5)

2,5 GHz Intel Core i7

AMD Radeon R9 M370X 2 Go

Intel Iris Pro 1536 Mo

High Sierra  macOS 10.13 (17A365)

French Canadian Language

Disabling the 3D acceleration did the trick.

0 Kudos
Highlighted
Contributor
Contributor

macOS 10.13 and Fusion 10 on 2015 MacBook Pro, 13"

On starting a VM, I get the "Internal Error" sheet

Adding mks.enableMTLRenderer = "0" to VMX file / or disabling 3D Acceleration has no effect.

I did a full re-install of VMWare Fusion.

Nothing interesting in the logs (which logs to look at?)

0 Kudos
Highlighted
Contributor
Contributor

I have the same problem.

I have mac OS Sierra 10.12.6 on late 2013 Macbook pro 15 retina display with spanish language set.

Pls, tell me what do i have to do?

0 Kudos