Enthusiast
Enthusiast

Fusion 10 doesn't recognize "purgeable" disk space as "available" disk space

I'm running Fusion 10.1.1 on macOS 10.13.3 (High Sierra).

Fusion doesn't recognize "purgeable" disk space as "available" disk space when trying to resize or shrink a virtual disk.

My situation... Free space on my host SSD (APFS) fell to 30 GB, so I deleted a bunch of files.  The result was 210 GB "available" of which 180 GB was "purgeable".  Then I opened Fusion and tried to resize a 100 GB virtual disk.  It failed because "there is not enough space on the file system for the selected operation" even though 210 GB is "available."  Then I opened the guest (macOS 10.12) and tried to shrink the virtual disk.  That also failed due to insufficient space.

The solution to the problem was to force macOS to reclaim the "purgeable" space.  The approach that worked for me was to use Disk Utility to create several huge files and then delete those files.  See "Creating a Huge File with Disk Utility" for instructions:

     http://osxdaily.com/2013/05/31/create-large-file-mac-os-x/

The creation/deletion process caused the "purgeable" space on my SSD to drop all the way down to 4 GB.  Then I was able to resize and shrink the virtual disk.

I'm not sure whether this is a Fusion issue or macOS issue, but I wanted to pass along the solution in case anyone else bumps into the same problem.

1 Reply
Champion
Champion

It's a MacOS issue.  They changed how time machine works - it always backs up to the local drive first then copies those backups to the external disk. I'm in the process of migrating my hourly backups to Carbon Copy Cloner and disabling time machine as a result.

This makes it *critical* that the virtual machines are excluded from the time machine folders explicitly.

You can purge the local backups from tmutil at the command prompt.

0 Kudos