Fusion 10.1.1 Bootcamp Windows 10 Blue Screen on Boot


after a complete clean install (macOS 10.13.3) I installed Windows 10 with Bootcamp normally. Everything worked.

Then I tried to access it with the current VMware Fusion app. After seeing the spinning points for a while I get a Blue Screen:

"Your pc ran into a problem and needs to restart"

With the error number: 0xc000021

Booting normally in Bootcamp worked perfectly before. Now it wants to repair stuff, but I still get it to boot in Boot camp.

I can also do some of the windows automatic repair things in VMware but as soon as it tries to boot for real I get the Blue Screen again.

I already tried reinstalling VMware Fusion completely. And I also disabled SIP (I had to do this for previously for Win8.1) but it didn't change anything.

Before the clean install I had a working Bootcamp/VMware Fusion setup with Windows 8.1.

It's running a MacBook Pro Mid 2015.

Any suggestions are welcome.

0 Kudos
4 Replies
Hot Shot
Hot Shot

Here are some suggestions:

1. Have you tried deleting the metadata files? VMware Knowledge Base

2. Try repairing the disk and snapshots of the affected VM VMware Knowledge Base

3. If your machine has a SCSI controller, try removing it as well VMware Knowledge Base

* if this doesn't work for you, remember to re-add the controller afterwards

4. You can also try to change the SCSI controller to a different type VMware Knowledge Base

* same as before, reverse the change if it doesn't resolve your issue

5. Try booting the VM in safe mode

6. Check your Mac's hard drive for errors VMware Knowledge Base

7. Check your Mac's RAM status VMware Knowledge Base

If all of the above won't resolve your issue, please do let me know and post the screenshots of all bluescreens you're seeing in your VM.

Cheers, Paul Wilk
0 Kudos

1. If I remove the "metadata" files I remove the Boot camp entry from VMware. Yes I tried removing and re-adding the virtual machine several times.

2. Repairing with `vmware-vdiskmanager` didn't output anything on the .vmdk files. I'm guessing because the disk is actually the Boot camp partition.

3./4. SCSI isn't used anywhere. I've just created the Boot camp VM and the only thing I changed was the number of CPU cores.

5. I can boot into safe mode (After unsuccessfully booting 3 times). There I get a "sihost.exe – System Warning: Unknown Hard Error". Not sure what to do about that.

6. / 7. I'm pretty sure it's not my Mac's hard drive or RAM. I can boot into macOS and Boot camp totally fine. And I also created a new virtual machine with Windows 10 (not from the Boot camp partition) ant this also works.

I can only assume it's the combination of this VMWare fusion version with Boot camp and Windows 10.

Any more ideas how I get the Boot camp partition booting in VMware Fusion? (Which was the main reason why I bought VMware fusion!)

0 Kudos
VMware Employee
VMware Employee

Hi FusionUser42 ,

Which version of Windows 10 is your Boot Camp, is it 1709 or 1703?

0 Kudos

The Windows specifications are:

Edition: Windows 10 Pro

Version: 1709

OS Build: 16299.15

0 Kudos