Highlighted
Enthusiast
Enthusiast

Fusion 10.0.1 + VMWare Tools - macOS 10.12.6 resolution changes to HiDPI variant when logging in

I have a fresh install of macOS 10.12.6 in VMWare Fusion 10.0.1, the VM has the latest VMWare Tools installed in the guest OS. I've set the resolution of the VM to 1920x1080 by dragging the window size to that particular resolution.

When I log in, the guest OS kicks back down to a 960x540 HiDPI resolution. Adjusting the resolution in System Preferences works until the next log out & log in cycle, where it resets the resolution of the VM back to the 960x540 HiDPI resolution.

This issue also occurs when the Default for display option is selected in the Display preference pane.

Monitor is a 27" 2560x1440 display.

VM Settings has Use full resolution for Retina Display disabled.

Attached is a video of the issue.

*EDIT* - I should note, this issue does not​ occur in my 10.13 VM.

Anyone else experienced this? What fix (if any) has been applied to resolve this annoying behaviour?

12 Replies
Highlighted
Enthusiast
Enthusiast

Ok, so, for a temporary fix, I've had to remove the /Library/LaunchAgents/com.vmware.launchd.vmware-tools-userd.plist to stop this resolution from changing.

0 Kudos
Highlighted
VMware Employee
VMware Employee

Is it a Retina display? Could you check the "Use full resolution for Retina display" checkbox on Display settings panel, then uncheck it to see if it works?

0 Kudos
Highlighted
Enthusiast
Enthusiast

Sorry I haven't replied sooner, completely forgot about this.

Enabling/disabling the 'Use full resolution for Retina display' does not resolve the issue; it only happens after the VMWare Tools are installed.

0 Kudos
Highlighted
VMware Employee
VMware Employee

hi plasticphyte,

you can set

~/Library/Preferences/com.vmware.tools.plist

""""

<key>enableAutoHiDPI</key>

<false/>

""""

Highlighted
Contributor
Contributor

I have a same resolution display (2560x1440). It happens to me too.

It's totally a bug when you use the UI to change settings but they don't apply/persist.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Yes, definitely a bug, I see the same problem on multiple hosts and VMs.  Display settings are overridden and you get the HiDPI switching/display settings not sticking.  Leaving "Use full resolution" enabled avoids this, and it is kind of tolerable with one macOS VM running, but with several at the same time the performance hit from having so many virtualized high resolution displays starts to become very apparent.

0 Kudos
Highlighted
Enthusiast
Enthusiast

For what it's worth, I have not had this problem on Fusion running a 10.12 guest, but I did have use entire resolution option selected.  I recently installed ESXi on a Mac but the display settings doesn't have this option.  Can I assume that setting enableAutoHiDPI option to false on the vm should solve this?  The system is offline until later next week when the machine is going to be added to our vCenter set up, but I will try it at that point.

0 Kudos
Highlighted
VMware Employee
VMware Employee

Maybe, the mac tools is not the latest version. So auto high DPI is not enabled. If you update the tools with latest version, and the auto high DPI will be enabled, you can change the display option. if you want to disable "auto high DPI", you can set the flag of "enableAutoHiDPI" to false.

Highlighted
Enthusiast
Enthusiast

Hi xiangk​ - I have since got a new Mac laptop and can't replicate the issue in the VM that was affected.

0 Kudos
Highlighted
Enthusiast
Enthusiast

I can confirm that disabling the auto high dpi resolved my problem with ESXi server (connected via Fusion client).

The problem was that it was always enabling hidpi mode even when the resolution was set to be very low.  All software is up to date (ESXi, Fusion, and VMWare Tools), so there appears to be a bug in this auto hidpi feature.  I believe it is detecting my hidpi monitor and using its presence to dictate the setting rather than considering the resolution being used.

Regardless, it is easy to disable the feature, so I can move forward.

0 Kudos
Highlighted
Contributor
Contributor

hi plasticphyte,

you can set

~/Library/Preferences/com.vmware.tools.plist

""""

<key>enableAutoHiDPI</key>

<false/>

""""

has the solution.

0 Kudos
Highlighted
Enthusiast
Enthusiast

has the solution.

Actually xiangk had given a workaround (a good one - I'm using it).  The solution requires fixing this bug in the VM Tools.

0 Kudos