lensv
Enthusiast
Enthusiast

Function keys

I can see that the keyboard setting "Use all F1, F2, etc. keys as standard function keys" isn't avaliable in the guest machines' System Preferences. Is it not possible to make the "special keys" work in a VMware Fusion Mac guest VM?

0 Kudos
30 Replies
lensv
Enthusiast
Enthusiast

Anyone with knowledge about this here?

0 Kudos
wila
Leadership
Leadership

Hello Lennart,

I think it is because the VM is not presented the laptop keyboard directly, but instead gets a virtualised version of the keyboard and so gets to see a more generalized version of the keyboard.

As you are talking about a Fn key, I take it you have a macbook (pro/air) with a physical keyboard, not that light strip thingy (touch bar)?

I'm not exactly sure what you want to do, but if you want to -for example- change the volume from within your guest, then you should normally be fine with also changing the volume on your host.

Under preferences, keyboard & mouse -> Mac Host shortcuts

you can select a checkbox that all the mac host keys go to the host instead of the guest.

(which does not appear to make a difference on my MBP here, but I never use that functionality)

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
lensv
Enthusiast
Enthusiast

Hi Wil!

Nice to see you here Smiley Happy

I'm actually using an iMac in this case (with an external Apple keyboard), but I believe that it may behave the same way as an internal keyboard on a laptop.

What I would want is to pass over all those Mac specific keys from host to the guest VM, such as the media buttons (play, stop, forward, reverse), Mission Control, Launchpad etc.

The setting that you refer to don't seem to work here either...

0 Kudos
lensv
Enthusiast
Enthusiast

Anyone else with ideas?

0 Kudos
wila
Leadership
Leadership

Lennart,

Hmm... I have to take back my "it doesn't work" statement. At least when I just tested it on my new MBP with Fusion 11 it works fine.

The trick is to make sure that the keyboard profile that you are editing and enabling the Mac host shortcuts for is the same as the keyboard profile that is selected in your VM.

Eg. I was testing on a Windows 8 guest and adjusted the setting for "Profile - Default" while my Windows 8 guest of course had the "Windows 8" keyboard profile.

Another thing to watch out for is the setting "Enable per virtual machine shortcuts" checkbox on the Preferences -> General tab page. If you have that checked you will have to adjust the settings at your VM and not at Fusion Preferences.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
lensv
Enthusiast
Enthusiast

So, you are actually able to activate Mission Control, Dashboard etc. within the VM from the host's keyboard?

I use VMware Fusion Professional Version 11.0.2, but it won't work for me. The closest I get is that there's no response at all from the specific keys when navigating in VM and the "Enable Mac OS Host Keyboard shortcuts" is unchecked (and Mac Profile is activated). If I check the setting the host responds as normal to the keyboard, even when VM windows is active. Something is wrong, I just don't know what?

Btw... I don't get notificaton emails anymore from this forum (when a thread is updated). Is that a setting somewhere?

0 Kudos
wila
Leadership
Leadership

Lennart,

Yes, it works for me. Just tested also on another host with a macOS Mojave VM.

First you check the VM settings -> Keyboard & Mouse to see what profile it is using.

pastedImage_4.png

In the menu "Fusion" -> "Preferences" -> "Keyboard & Mouse" tab  I first Select "Mac Profile" in the "Keyboard & Mouse Profile" and then in Mac Host Shortcuts I check the Enable Mac OS Host Keyboard Shortcuts.

pastedImage_0.png

and to keep things more simple, I have the per-virtual machine keyboard settings disabled.

pastedImage_1.png

Normally that should do it.

Re. Email confirmations. If you haven't changed anything then it should still work. Yes you can disable it in your profile IIRC, but that should not change by itself.

There are however times when the email notifications stop working and that is a forum issue. FWIW, I haven't seen it happen in the past week, but it might be region specific.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
lensv
Enthusiast
Enthusiast

Weird!

I have the same settings and Mac OS Mojave is running on both host and guest, but it still fails...

Can you see the keyboard setting "Use all F1, F2, etc. keys as standard function keys" in the guest machines' System Preferences? It's not there at all in my VM.

Concerning the email issue...it's been years since I last got such a notification. Anyway, I found the profile, but I can't se any specific settings for messages from the forum. Don't really know what to change here  :smileyconfused:

0 Kudos
wila
Leadership
Leadership

Hi,

Weird indeed.

As for the "Use all F1, F2, etc. keys as standard function keys" checkbox, I only see that at my macOS Sierra host (no touch bar), not at my macOS Mojave host (has a touch bar). None of the guests have this checkbox. My guess is that it has to do with the selected keyboard. It does not however appear to affect the mac host shortcut behavior.

re. email notifications. Let me see. Click your name at the top right, then choose Preferences.

My settings look like this:

pastedImage_0.png

The "Receive Email" and "Email Watches" setting would normally control this.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
lensv
Enthusiast
Enthusiast

OK,

"Everything in my Inbox page, except direct social actions" was set to Off. After changing that setting notifications seems to be sent again Smiley Happy

Concerning the keyboard problem... If there are no other settings, it might just have to do with the external keyboard. Could this be a bug? I really think that Fusion should be able to recognize an external keyboard as well as an internal.

0 Kudos
wila
Leadership
Leadership

Lennart,

It's not a matter of using an external keyboard. I use my MBP as a mobile desktop so have hooked up an external keyboard and big screen as well.

The older MBP I tested with earlier is now without anything connected externally.

Both setups worked fine with the macOS host shortcuts. I'm a bit puzzled as to what your problem is and if I was in your situation I might try a re-install of VMware Fusion.

Oh wait... in your Mojave guest, I take it that you installed VMware Tools, right?

Did you also check -in the guest- under apple settings -> Security & Privacy -> Accessibility ?

In my guest there's an entry for vmware-tools-daemon and it has to be checked.

Also make sure there's no item on the Security & Privacy page under the general tab page that has to be allowed still.

This is a really painful security -and in my personal opinion pretty useless- mechanism that apple came up with.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
lensv
Enthusiast
Enthusiast

VMware Tools are installed and the Security & Privacy settings here are similar to yours.

I thinkt that I'm on something though... In the guest VM's System Preferences / Mission Control - F11, F12 and a few other keys are set and they actually work (unlike the dedicated keys). Something tells me that everything would work as expected if just that setting "Use all F1, F2, etc. keys as standard function keys" was available

0 Kudos
wila
Leadership
Leadership

Lennart,

I think that checkbox is a red herring.

See for example here:

"use all as f1, f2, etc as standard keys" vanished in system prefs | MacRumors Forums

If the checkbox is there or not depends on the keyboard that your macOS sees.

None of my macOS guests have that checkbox, yet the macOS host shortcuts work from within these guests.

It also works from within my Windows guests, not sure if you have those, but that could be another thing to try.

Personally I would reinstall Fusion and see if that helps.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
lensv
Enthusiast
Enthusiast

Now I have reinstalled both VMware Fusion and Tools, but still no difference. Nothing just happens when guest is in focus and these special keys are pushed. As soon at the mouse pointer leaves the VM window the host responds as usual. I just don't understand why the guest don't want to play... Smiley Sad

0 Kudos
wila
Leadership
Leadership

Sorry, running out of ideas atm.

Perhaps an employee from VMware still has some ideas?

-

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
lensv
Enthusiast
Enthusiast

Do we have any employees from VMware hanging around here?

0 Kudos
lensv
Enthusiast
Enthusiast

While we are waiting for some VMware fellow to respond to the main question, maybe someone can help me with the forum settings (again).

After the last change it seems that I get email notifications for ALL updates in the VMware Fusion section. I only want responses for action in those threads that I subscribe to. Is that possible?

0 Kudos
wila
Leadership
Leadership

Hi,

re. email from all of  Fusion.

On the forum view where you have tabs for "Documents", "Discussion" etc.. there's a "Follow" button at the top right. Click that and things should get back to normal.

re. are VMware employees in the forum. Yes, but it is voluntary and they might skip a long thread... Perhaps it is easiest if you open a support case with VMware.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
lensv
Enthusiast
Enthusiast

Thanks Wila!

I'll try that switch...

I keep this thread open, so anyone with a solution or just ideas about the "Apple keys-issue" are welcome to comment here. Smiley Happy

/LS

0 Kudos