EHays
Contributor
Contributor

Full Screen on 2nd monitor

Jump to solution

Hello,

I have a Macbook Pro running Sierra version 10.12.6 with a 27 in. Thunderbolt display connected by using a QWC Thunderbolt 3 Dock. I installed Fusion 10 Pro the day before yesterday and am using a Windows 7 VM. Yesterday, I could run the vm on the thunderbolt display and the Mac OS on the MBP and everything was fine. I suspended the vm then shut down VWmare by right clicking on the dock icon and then clicked "Quit'. I then shut down the MBP and went home for the day. This morning, I plugged the MBP into the dock, started the mac os and then once on the desktop, started the VM. The vm moved to a new screen that made the screen on the MBP black and I now have to use my Bluetooth mouse to slide the vm to the right to be able to view the MBP desktop. I do not know what happened to cause this but I need to be able to view both desktops at the same time instead of having to slide back and forth. I originally created the VM using Fusion 7 Pro on a Macbook Air and I was able to view both screens with that set up as well. I have tried viewing the VM in Single Window then moving it to the Thunderbolt display and then making it Full Screen and and that does not work. ( I was able to do this on the MBA and it worked fine) How can I get it back to the way it was when I first set it up?

Thank you in advance for any help.

1 Solution

Accepted Solutions
EHays
Contributor
Contributor

I figured it out. I went into the System Preferences then to Mission Control. I put a check mark in "Displays have separate Spaces", shut down the VM, logged out and back in to my MBP, opened the VM and it is now on the Thunderbolt display in full screen and I do not have to slide the screens. Found the answer by going to Essential Tools & Tips for Working With Multiple Mac Monitors  which was found from a different post.

View solution in original post

3 Replies
EHays
Contributor
Contributor

I figured it out. I went into the System Preferences then to Mission Control. I put a check mark in "Displays have separate Spaces", shut down the VM, logged out and back in to my MBP, opened the VM and it is now on the Thunderbolt display in full screen and I do not have to slide the screens. Found the answer by going to Essential Tools & Tips for Working With Multiple Mac Monitors  which was found from a different post.

View solution in original post

henchms
Contributor
Contributor

Great find EHays...After my update to 10.1.1 I had the same issue. You saved me!

0 Kudos
Goobysnack
Contributor
Contributor

What if we don't want screens in separate spaces?

0 Kudos