VMware Communities
gen843620
Contributor
Contributor

Fixed super slow resume in Fusion 11.0.0 / Win7

Fusion 11

Mojave 10.14.1

Windows 7 (Fusion hardware version setting 16 in Settings, Compatibility)

I've run Fusion for years.

11.0.0 was quick but recently the resume function starting taking forever (10-20 minutes).

I shutdown the VM and used Settings/General to clean the VM, which was already set to automatically clean. This didn't help.

But on restart I noticed an error that didn't appear during suspend or resume: something about not being able to connect to an .iso file in the DVD drive (it named the full iso file name).

About 15 days ago I installed a program in Windows 7 from an iso file mounted as a virtual DVD on the Mac side (the Windows connected to this [virtual] DVD drive).

About 5 days ago I moved that iso file that was still sitting on the Mac side to an external hard drive not involved with Fusion.

Fusion was obsessed with re-connecting the DVD drive with that particular iso file.

FIX

I shutdown Windows, then went into Fusion Settings, clicked the icon CD/DVD (SATA), then unchecked the "Connect CD/DVD drive" checkbox. Before then I also clicked off the iso file name on the pull-down list but forgot the exact order of clicks it took to get rid of the iso file listing. After I finished, the box was unchecked and the pull-down menu (only didn't have the iso file listed on it anymore).

Anyhow, I left "Connect CD/DVD drive" unchecked and now the VM resumes super fast like it used to.

Maybe this will help someone else.

10 Replies
Borgo1971
Contributor
Contributor

I have the same problem, after I upgraded to Mojave (converting my fusion drive to APFS) and upgraded VMware Fusion from 8.x to 11.x. Even in VMware Fusion 8.x, where Windows 10 wasn't supported, I didn't have any problem before the macOS+Fusion upgrades. And the problem is not only with my main virtual machine (borne with Windows 7 and upgraded to Windows 10 in Fusion 8.x), but even in Windows XP VM (not as serious as with Windows 10 VM). I must say that's not an every time issue... sometime VM resumes normally, but sometimes Windows 10 VM need about an hour... really frustrating. And all computer becomes really slow in the meantime.

But I invite you and all the people that experience this issue to contact VMware support ( https://my.vmware.com/group/vmware/get-help/ ), tell them about your experience and give all the reports you can (starting reading this: VMware Knowledge Base ), as I did. They are working on the issue, but more reports there are, and better and sooner they can solve the problem.

Reply
0 Kudos
Mikero
Community Manager
Community Manager

Agreed that letting our Support team know about it is helpful and worth doing!

This is one area we are specifically focused right now, so we're aware and we are working on it, as well as other performance areas.

-
Michael Roy - PM/PMM: Fusion & Workstation
Reply
0 Kudos
Borgo1971
Contributor
Contributor

I think I've solved the issue thanks to VMware support that called me and interacted about two hours after I opened a ticket and provided the data they requested. They invited me to do more things, so I can't say what was the mistake in my Mac or my VM. And I added some maintenance operation on my Mac too... mybe, they helped too. But for now (I'll write again if somthing changes), VM resumes pretty fast. So, what I did?

- I clered the VM with Windows tool, and after with VMware settings (so, this made I more times before, but didn't help alone)

- I cleared all VMware files around my disk with AppCleaner.

- I installed newly VMware Fusion and repaired the tools in Windows.

- I made a new VM taking a copy form VirtualDisk in my previous VM (until here, are VMware support suggestions, the next things are my idea)

- I cleaned boot caches restarting the Mac with shift key pressed

- I enabled trim on my SSD part from fusion drive (that's my main boot disk)

As I said, now VM's resumes as fast as they did in HighSierra and HFS+...

Reply
0 Kudos
Borgo1971
Contributor
Contributor

Unfortunately I'm here again, because after a few days where the VM resumed up really fast, today the problem reappeared it took 27 minutes. I invite all that experience this issue, to open a ticket at VMware to let developers know how widespread the problem is, and better targeting they efforts.

Reply
0 Kudos
ColoradoMarmot
Champion
Champion

If you're using a Fusion drive, that could be the problem.  There's no way to ensure that MacOS doesn't move the VM to the metal disk from the SSD, and if that happens, resume times will increase dramatically.  Do you have a dedicated SSD you can move the VM to and test it there?

Reply
0 Kudos
Borgo1971
Contributor
Contributor

True, Fusion Drive could be part of the problem. But not alone, because I have it as main boot disk from about five years, and didn't experience this kind of slowness resuming VM's before upgrading to Mojave (converting Fusion Drive to APFS) and VMware Fusion 11.x

Tonight I converted back the Fusion Drive to HFS+ (cloning the content to another disk, initialising the Fusion Drive as HFS+ and cloning back the data)... but now I have to wait at least a week, without the issue to occur, before I can think of having solved it.

And in any case, VMware should find a patch or at last, clarify that VMware Fusion won't work right on APFS formatted Fusion Drive (if it's the case).

Borgo1971
Contributor
Contributor

Hello to all. I hope to write in this thread for the last time, because I guess to have solved, or at last I have found a good workaround, for the slow resume problem. What I did? I've converted back my main drive (homemade fusion drive where I hold system, application and virtual machines) to HFS+. Since I converted the drive, and now it is about two weeks, VM resumes normally fast.

Reply
0 Kudos
ColoradoMarmot
Champion
Champion

I'm not sure Fusion can fix this, as the rolloff of data is controlled by Apple.  It's likely that APFS has changed things, especially given how it handles snapshots, which will be dramatically slower on Fusion or other metal disks.

And you may very well find that it slows down again as the drive ages out the VM to the spinning disk.

Reply
0 Kudos
vr8ce
Contributor
Contributor

it took 27 minutes

Responders are acting like 27 minutes is to be expected for a spinning drive. That's ridiculous. That's two orders of magnitude worse than what it should be. A spinning drive isn't even one order of magnitude faster than an SSD (even an NVMe SSD) in real-world usage. I use an NVMe MBP, and I switched to it because of the speed. But it's not that much faster.

If it's taking 27 minutes, there's a serious problem, and whatever it is, it's far more than just a spinning disk. And IMO it's a Fusion problem until they prove otherwise.

Reply
0 Kudos
pr74
Contributor
Contributor

It's all due to APFS and the fact it creates highly fragmented files. It's a real killer on Fusion and normal hard drives. I don't think VMWare can fix this.

There's a really good article about it here:

https://eclecticlight.co/2017/11/19/last-week-on-my-mac-the-extent-of-apfss-problems/

I highly recommend watching Tim Standing's presentation mentioned at the beginning of the article, the crucial bit starts around 22nd minute or so.

Reply
0 Kudos