Fix for Windows 10 Upgrade - VMware SVGA 3D issues

So I have successfully upgraded my Windows 7 Pro X64 - Virtual Machine to Windows 10 Pro. It runs great. Please note that I am using the VMware Technology Preview however I am sure it will run on VMware 7 as well.

For those that have the Windows 10 upgrade icon in the system tray but are having trouble due to the Windows 10 Compatibility appraiser indicating that the VMware SVGA 3D driver is incompatible skip directly to Part B. For those that are not even seeing the upgrade icon follow Part A instructions followed by Part B.

Part A:

1) Make sure you have KB3035583 is installed. If you already see the Windows 10 upgrade icon in your system tray then you do. If you don't see the icon verify that the update is installed by going to Windows Update -> Installed Updates.

3) Open regedit.exe and go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\UpgradeExperienceIndicators and make sure the string values UpgEx and UpgExU exist there and are set to Green. If not, create the string values UpgEx and UpgExU and enter Green as the value.

4) Repeat the same for HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\UpgradeExperienceIndicators\Reduced and make sure both UpgEx and UpgExU show Green there.

5) Reboot. Now the Get Windows 10 Upgrade Icon should show up in the system tray, however do not click on it yet.

Part B

1) Before you click the Get Windows 10 Upgrade Icon, open the file C:\Windows\AppCompat\Appraiser\Telemetry\Appraiser.JSON in Notepad.exe

2) Delete the contents and replace with the following:


"JsonSuccessfullyWritten" : true,

"JsonVersion" : 3,

"JsonCreationTime" : "130800491614668440",

"CompatSectionCount" : 0,

"CompatSections" :




3) Save the file

4) Now click on the Get Windows 10 Upgrade Icon, you should now be able to reserve your free Windows 10 upgrade and continue with the download and installation. You will not be told that the SVGA driver is incompatible anymore. Upgrade will be smooth. Reinstall VMware tools after upgrade is complete.

9 Replies

Windows 10 32-bit installed on iMac running 'El Capitan Beta Public Preview 2'

upgraded the Windows 8.1 Pro VM ( VMware Fusion 7.1.2)

Had the exact issues as others , getting the SVGA error.

Actually went smooth...  Downloaded the ISO from Microsoft onto my mac, clicked on vmware toolbar - connect CD/DVD - and then chose the disk image.  ( mind you, my super drive is broke, and my external drive is at my daughters).

Took about 20 minutes to install, updates are being applied now.

Followed these instructions :http://www.mikeroysoft.com/windows-10-and-vmware-fusion/

As he points out:

Luckily, there’s actually a REALLY EASY workaround.  Rather than use the upgrade method within the VM, download the .ISO and mount it to Fusion to perform the upgrade.

Community Manager
Community Manager

Thanks for pointing to my post, I was just about to 😃

We're putting a KB together at the moment with more detail.

IMHO, deleting things and editing files is not a good idea and could unexpectedly break things later on.

The fix is really just to use the .ISO to install.  Microsoft did a really good job of making that available to everyone, so while back int he day installing from ISO was a bit of a nuisance just getting the file in the first place, it was a (unexpectedly!) easy to download.

Michael Roy - PM/PMM: Fusion & Workstation
0 Kudos

I used the ISO installation method described above to upgrade Windows 8.1 in-place. VMWare Fusion 7.12

I had one glitch.

My guest machine's display resolution was maxed out at 1152 x 864. Win 10 display settings would go no higher.

I used Win 10 Settings / Apps and Features to remove VMWare Tools. Then reinstalled VMWare Tools (and restarted the guest machine).

All resolutions are now available as before.


‌I was able to get windows 10 up and running with my MacBook After receiving the svga unsupported error.

- I went to the windows,10 upgrade site and chose to upgrade by downloading it to my VM.

- I did not download the ISO version - I tried that first & it did not work due to no license key

- Selected to run the installer

- I went through the upgrade process and when Windows 10 started it did not recognize the svga driver.

- I repaired the VM Tools installation which reinstalled the svga driver and windows recognized the svga driver


0 Kudos

I had the same trouble with the VMWare SVGA 3D.

I downloaded the windows 10 pro update from microsoft to my mac.

Than I installed it from the ISO Version - just like zoemax described.

After that I reinstalled and installed the VMWare Tools again - just like russcusimano described.

It works perfect. No windows licence trouble, all was fine.

Thank you guys for these informations.

VMWare 7.1.2

MacOS 10.10.4

iMac with ATI Radeon HD 4670 256 MB

0 Kudos

I was able to install Windows 10 via ISO on my Mac Book Pro and finally got through the SVGA bug. I'm not sure if its a Video/Graphics controller issue or a drivers issue  but the retina display resolution on Windows 10 is very bad. For Ex: Eclipse shows some menu's big enough and other options too small or tiny to see. Is there is an update to Fusion 7 that can fix this. Im on fusion 7.1.2. Any help is appreciated.

0 Kudos

Doesn't quite work for me. I was getting the SVGA compatibility issue before.

I see the Windows icon, so I performed only Part B.

When I click on the icon, I still get a message that there's a compatibility issue. But when I view the compatibility report, it says that everything is OK.


0 Kudos

I already had the Registry keys mentioned in Part A. They were set to Red, so I modified them to Green.

After doing that, I was able to reserve Windows 10.

0 Kudos

Hey NylonCA,

Thanks for the post, worked a treat for me! Smiley Wink

I ended up making  a simple batch script to do the below:


move "C:\Windows\AppCompat\Appraiser\Telemetry\Appraiser.JSON" "C:\Windows\AppCompat\Appraiser\Telemetry\Appraiser.JSON.old"

echo { >> "C:\Windows\AppCompat\Appraiser\Telemetry\Appraiser.JSON"

echo "JsonSuccessfullyWritten" : true, >> "C:\Windows\AppCompat\Appraiser\Telemetry\Appraiser.JSON"

echo "JsonVersion" : 3, >> "C:\Windows\AppCompat\Appraiser\Telemetry\Appraiser.JSON"

echo "JsonCreationTime" : "130800491614668440", >> "C:\Windows\AppCompat\Appraiser\Telemetry\Appraiser.JSON"

echo "CompatSectionCount" : 0, >> "C:\Windows\AppCompat\Appraiser\Telemetry\Appraiser.JSON"

echo "CompatSections" : >> "C:\Windows\AppCompat\Appraiser\Telemetry\Appraiser.JSON"

echo [ >> "C:\Windows\AppCompat\Appraiser\Telemetry\Appraiser.JSON"

echo ] >> "C:\Windows\AppCompat\Appraiser\Telemetry\Appraiser.JSON"

echo } >> "C:\Windows\AppCompat\Appraiser\Telemetry\Appraiser.JSON"

REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\UpgradeExperienceIndicators" /v UpgEx /t REG_SZ /d Green /f

REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\UpgradeExperienceIndicators" /v UpgExU /t REG_SZ /d Green /f

REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\UpgradeExperienceIndicators\Reduced" /v UpgEx /t REG_SZ /d Green /f

REG ADD "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\UpgradeExperienceIndicators\Reduced" /v UpgExU /t REG_SZ /d Green /f



Thanks again Smiley Wink

0 Kudos