tommoyer
Contributor
Contributor

Escape Key not registering in VMs

I have VMware Fusion Pro 11.5.3 installed on Mac OS 10.15.4. I am having a problem where my virtual machines don't seem to register me hitting the escape key. I have noticed this for both Windows VMs and Linux VMs. I have not changed any settings for the keyboard in the VM settings or anywhere else. The only thing that I have changed on my Mac is mapping my caps lock key to act as a control key, but that shouldn't make a difference. This happens with both my laptop keyboard (with Touchbar) and an external keyboard with a physical escape key. This makes it difficult to use several applications in the VM. Has anyone else experienced this?

0 Kudos
2 Replies
JPTechJP
Contributor
Contributor

I have the same issue on MacOS with both Fusion 11.5.3 and 11.5.5. I have the latest version of MacOS Catalina (10.15.5) and I know this issue with the ESCAPE key not registering has been going on for a while now. I have tried multiple keyboards including the internal keyboard on the Macbook Pro (touchbar). The ESCAPE key does not register in Windows 10, Windows 7, MacOS, or Ubuntu VMs. Infact, if I press the ESCAPE key, it seems as if things just start to lag in the VMs. After a minute of not pressing the ESCAPE key, things seem to go back to normal speed.

0 Kudos
JPTechJP
Contributor
Contributor

Update on this issue because I think I've figured it out. Do you perhaps have BetterTouchTool installed and do you perhaps have any shortcut or preset that perhaps is listening to the ESCAPE key press down and up? If so, then BTT is intercepting it and not passing it through to VMWare Fusion. If you disable BTT, then you'll find the ESCAPE key will work again. You can also make it so that BTT is disabled when you are actively using VMWare Fusion. When you click out of Fusion or hover over another app, BTT can re-enable itself. This works and the ESCAPE key works for me again!

0 Kudos