Highlighted
Enthusiast
Enthusiast

Enabling legacy OpenGL support in Fusion 11

Jump to solution

"No 3D Support is available from the Host - The 3D features of the virtual machine will be disabled" error shows up when I launch my bootcamp VM in Fusion 11.

I'll admit my setup is unusual: a Mac Pro tower with an Nvidia graphics card (running Nvidia's web drivers) and Sierra 10.12.6

In Fusion 10, adding this line to the VMX file would switch it to legacy OpenGL mode and provide basic 3D support, but it appears to no longer work in Fusion 11, or at least not with my setup.

mks.enableMTLRenderer = "0"

Setting it to 1 or 0 doesn't matter now.  The same error message always appears.

I do plan to upgrade to Mojave when Nvidia releases a graphics driver for it, but in the meantime is there any way to carry on with legacy OpenGL mode?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Community Manager
Community Manager

Are you also adding the GL tenderer enable flag?

mks.enableMTLRenderer = “0"

mks.enableGLRenderer = “1”

- Michael Roy - Product Line Manager: Fusion & Workstation

View solution in original post

0 Kudos
6 Replies
Highlighted
Hot Shot
Hot Shot

It certainly looks like Fusion 11 went all in on the new Metal API. I have a mac mini mid-2011 which the system requirements say is fine, but is too old for Metal support. I get the same warning when I launch my VMs: No 3D support from the host machine. And this machine's final OS is High Sierra so it's not like I can get onto Mojave where Apple has started to rip out OpenGL.

0 Kudos
Highlighted
Community Manager
Community Manager

Are you also adding the GL tenderer enable flag?

mks.enableMTLRenderer = “0"

mks.enableGLRenderer = “1”

- Michael Roy - Product Line Manager: Fusion & Workstation

View solution in original post

0 Kudos
Highlighted
Enthusiast
Enthusiast

Thanks!  That did the trick.  (Might want to edit the quotation marks as copy / pasting them in that format won't work.)

0 Kudos
Highlighted
VMware Employee
VMware Employee

One thing to remind is that this config is not officially supported.

0 Kudos
Highlighted
Contributor
Contributor

I'm also having same No 3D Support is available from the Host message,

Using Fusion 11 on Mac Pro mid 2010 dual xeon. High Sierra 10.13.6

The Fix you wrote, where do you enter this text? Are quotes needed?

mks.enableMTLRenderer = "0"

mks.enableMTLRenderer = "1"

Thanks

0 Kudos
Highlighted
Contributor
Contributor

I tried these settings and they did not work.  Got an error when booting up.

Found this link to enable OpenGL settings and this solved the issue.

https://apple.stackexchange.com/questions/343473/how-to-resolve-no-3d-support-is-available-from-the-...

In a nutshell, you put these settings in the Preference file; not in the vmx file.

You can also add the setting:

mks.gl.allowBlacklistedDrivers = "TRUE"

to the vmx file as well.

I made both these settings and the issue went away.

Macbook Pro 8,3 (17") running 10.13.6 and Fusion 11.1.0 (13668589)

0 Kudos