R41L
Contributor
Contributor

Editing Networking and nat.conf

Hi guys, 

For my studies, I need to deploy severals computers for an entreprise. I have downloaded the demo of VMware Fusion Pro 12 and I am using it instead of VB which seems to be recommended on my projet. I am on Catalina 10.15.7.

Well, for my projet I need to set many parameters. One of it is the gateway address which must be 192.168.56.1 .

So on VMware, I am going to "VMware Fusion/Preferences/Network"
Then, I unlock the settings, I am adding vmnet3, I check "Allow VMs on this network to connect to external network using NAT protocol" and also "Connect Mac Host to this network".

Then, with Nano, I am editing this file "/Bibliothèque/Preferences/VMware Fusion/networking" exactly like that : 
answer VNET_3_DHCP no
answer VNET_3_HOSTONLY_NETMASK 255.255.255.0
answer VNET_3_HOSTONLY_SUBNET 192.168.56.0
answer VNET_3_NAT yes
answer VNET_3_NAT_PARAM_UDP_TIMEOUT 30
answer VNET_3_VIRTUAL_ADAPTER yes

With those settings, I am good for my projet. On my terminal's host, if I use "ifconfig" I can see that the vmnet3 address of my host is 192.168.56.1.
But apparently, the NAT gateway address is located on this file "Bibliothèque/Preferences/VMware Fusion/vmnet3/nat.conf" and the file set the NAT gateway address to 192.168.56.2. 

But the project request is that the gateway must be in .1. Of course, if I use .1 on my server and my VMs, none of them are able to go online. And with .2 well it is working just fine. I have try everything I can to change this parameters with nano but every time VMware is starting, it just keep smashing my editing on the nat.conf. I have tried to fix my host address with "VNET_3_VIRTUAL_ADAPTER_ADDR 192.168.56.2" to be able to define the NAT Gateway in .1 without any success. 

Please could someone explain me how is it possible to configure the NAT gateway address ? Or having the NAT gateway on the same address than my host ? 

I will really appreciate any help the community can give me. 

Best Regards, R41L

Labels (3)
Tags (3)
0 Kudos
0 Replies