chronos2g
Contributor
Contributor

ERR_SSL_PROTOCOL_ERROR Windows 10 on Fusion Pro 12 on Big Sur 11.1

I upgraded my 2019 Macbook Pro to Big Sug 11.1 today, and now keep seeing ERR_SSL_PROTOCOL_ERROR on Edge Chrome or Google Chrome on VM Windows 10 Pro.

I have to keep hitting the refresh button to continue, but it's now taking longer to get stuff done through HTTPS connections.

Has anyone else experienced this?

5 Replies
bKarl
Contributor
Contributor

Yes, I'm seeing it too.  Same version of Fusion, MacOS and Win10.  VSCode updates give the error consistently. 

0 Kudos
chronos2g
Contributor
Contributor

It seems that there is an issue with the VM image and using bridged network adapter vs NAT on 11.1. Apparently this was an issue during 11.0 beta, and does not seem to be resolved.

0 Kudos
mistapony78
Contributor
Contributor

I am having the same issues and its driving me bonkers, anyone have a solution?

0 Kudos
barkingfoodog
Contributor
Contributor

I ran into a similar issue on 11.6 with Fusion 12.1.2. After trying various steps in Windows (resetting SSL cache, verify the date/time, clearing browser cache, etc.) I found solution. I have a Hyperdrive adapter on my MacBook Pro with a gigabit ethernet cord that is usually connected to the router. I also have Wifi enabled (same network) with a lower priority in macOS Network. The Windows VM is set to use a Bridged (Automatic) connection. Digging into the VM settings, I noticed the gigabit connection showed as offline. I checked and the cable wasn't complete plugged in. As soon as I connected the cable, sites started loading correctly in Windows.

You might check to see if you have an offline network adaptor in macOS and try deactivating or deleting it. It's almost like the Fusion adaptor was routing some connections through the offline adaptor, but not others (I could ping valid IPs across the internet).

Don't know if this will help, but hopefully my experience benefits someone!

0 Kudos
gringley
Hot Shot
Hot Shot

Wi-Fi on Bridged mode has been broken for a long time.  No idea when they will fix it.  If you want bridged mode with Fusion 12 you have to use Ethernet.

0 Kudos