DaronMc
Contributor
Contributor

Display Grid lines or square pattern using MS Remote Desktop

Jump to solution

HI All,

I've had this problem since Fusion 3.0.  I've upgraded to 3.01 and now 3.02 (232708) - running latest snow leopard patches on the unibody macbook pro.

I've searched but maybe I'm using incorrect keywords as I cant find any text on this problem.

The current problem is when I use MS RDP to connect to and manage my windows 2003 and 2008 HP and Dell servers, gridlines, or horizontal and vertical lines corrupt my remote desktop's display.  (My desktop/display continues to work ok). I have attached a screenshot of the RDP screen as an example.  This problem manifests itself when I using either fusion's windowed or fullscreen mode.  I tried connecting to a windows 2000 server, and did not see this

problem.

I've activated and deactivated 3d acceleration to troubleshoot this issue.

My Fusion Guest OS is Windows XP SP2, built from scratch in Fusion 3.0.

Any help would be appreciated.  Thanks.

0 Kudos
1 Solution

Accepted Solutions
rcardona2k
Immortal
Immortal

You should look at this Microsoft patch:

A hotfix is available for Remote Desktop Client (RDC) 5.1 to fix a drawing failure after you apply t...

In particular the description:

>gridlines are visible in the terminal session window.

>Notes

>This issue may occur regardless of the operating system that is installed on the terminal server.

>This issue is more likely to occur when the terminal session window is open but not maximized.

>When this issue occurs, you can temporarily resolve the issue by maximizing the terminal session window.

>This issue does not occur if you use RDC 6.0.

View solution in original post

0 Kudos
6 Replies
Mikero
Community Manager
Community Manager

That's an interesting issue... does it persist if you use RDC/RDP to the Mac Host also?

As well, does the issue persist with the recently released public beta?

http://communities.vmware.com/community/beta/fusion

-
Michael Roy - PM/PMM: Fusion & Workstation
0 Kudos
DaronMc
Contributor
Contributor

Hi Mikero,

I do not have this problem using MS remote desktop connection for Mac connecting to my servers.

I did read the release notes and did not see anything that specifically addresses my issue.

I will try to get a test MAC HOST machine going and play with the beta if troubleshooting doesnt help.

0 Kudos
EVW
Enthusiast
Enthusiast

The resolution of your own computer might be slightly different from the resolution of the guest. I had the same problem a few months ago when I accessed Windows servers from my Windows desktop using RDP. You need to do some ajustment to the settings of the RDP client and try different resolutions, screen sizes, 16:9 vs 4:3.

DaronMc
Contributor
Contributor

Hi Evw,

I tried different resolutions, i.e. 1024x768 on vmguest OS then, set my rdp client to 1024x768. I connected and it didnt help.

I then tried my RDP client in full screen mode and the problems disappeared. I then restored my RDP screen to window mode, the gridlines reappeared. Maximizing the RDP Window did not help. By using CONTROL-ALT-BREAK, I put the RDP screen into full screen mode, not ideal, but workable for now.

It didnt matter what resolution my vmguest was while trying to match it to the RDP client. It only displayed properly in full screen mode.

0 Kudos
rcardona2k
Immortal
Immortal

You should look at this Microsoft patch:

A hotfix is available for Remote Desktop Client (RDC) 5.1 to fix a drawing failure after you apply t...

In particular the description:

>gridlines are visible in the terminal session window.

>Notes

>This issue may occur regardless of the operating system that is installed on the terminal server.

>This issue is more likely to occur when the terminal session window is open but not maximized.

>When this issue occurs, you can temporarily resolve the issue by maximizing the terminal session window.

>This issue does not occur if you use RDC 6.0.

0 Kudos
DaronMc
Contributor
Contributor

Hi rcardona2k,

Since the hotfix must be downloaded by contacting microsoftm, I merely upgraded my terminal services client to 6.0. I dont like it as much but at least this solved my problem. Thanks for pointing me in this direction.

Thank you all for your suggestions and help!

0 Kudos