VMware Communities
MikeFromABQ
Enthusiast
Enthusiast
Jump to solution

Disable shortcut keys that cause suspend of the VM

When I'm working in VMWare 11 Windows 10 client side, I often bump some key combination that causes the Suspend of the VM.  This seems to happen mostly when I'm using numbers 5 and/or 6 on the MacBook Pro 2016 (High Sierra and Mojave) keyboard along with arrow buttons as I'm editing any numeric value.  I could be accidentally pressing a number key and and arrow key at the same time, and I also could be bumping the trackpad as I'm typing.

What I'd like is to just disable all ways of triggering a Suspend of the VM except by explicitly choosing it in the VMWare menu, or by closing the lid.

1 Solution

Accepted Solutions
wila
Immortal
Immortal
Jump to solution

Hi,


The profiles are confusing. That's not what I meant (perhaps it is my explanation lacking)

If you go to the settings for a virtual machine, then select keyboard and mouse there, you get this screen:

pastedImage_0.png

So the VM called "temp" here has the Windows 10 Profile set as the active one.

This might be different per VM and the "Profile - default" is not always the default profile!

I use an external keyboard most of the times, which might be why I am not bumping into this.

Still wondering what the key combination is though Smiley Wink

edit: do you have a touch bar? My current MBP does and the suspend option is just above the 5 key. I do remember now that years ago I did bump into the occasional suspend if macOS still had the focus and I hit the wrong key combo, but forgot details on it. If your mac doesn't have a key combo, you could see if changing the fn key default in macOS makes a difference.

pastedImage_0.png

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva

View solution in original post

Reply
0 Kudos
5 Replies
wila
Immortal
Immortal
Jump to solution

Hi,

Not possible AFAIK and I wouldn't even know the keyboard shortcuts myself, wasn't it Command + S ? (nope, that's the snapshot screen)

However if you say that you bump into this when in the VM then that's a bit peculiar.

Do you by any chance have the "Mac Host keyboard shortcuts" enabled?

Beware that this is a setting PER keyboard profile.

So if your windows 10 VM is using the "Windows 10 Profile" instead of the default one that is displayed here then checking or unchecking that setting won't make a difference until you change the profile from the combobox.

pastedImage_0.png

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos
MikeFromABQ
Enthusiast
Enthusiast
Jump to solution

I do have "Profile - Default"

I do NOT have the "Mac Host keyboard shortcuts" enabled

Does that combination tell us anything about my symptoms?

I forgot to mention that I encounter this on the laptop's internal keyboard and trackpad, but when I'm working with an external keyboard and the Apple Magic Trackpad, I don't think I've encountered this.... that's what makes me think I'm bumping something on the laptop keyboard or trackpad that I don't do on the external keyboard.... which is the large external keyboard with full-size arrow keys that are not surrounded by any other keys.

Thanks for your help

Reply
0 Kudos
wila
Immortal
Immortal
Jump to solution

Hi,


The profiles are confusing. That's not what I meant (perhaps it is my explanation lacking)

If you go to the settings for a virtual machine, then select keyboard and mouse there, you get this screen:

pastedImage_0.png

So the VM called "temp" here has the Windows 10 Profile set as the active one.

This might be different per VM and the "Profile - default" is not always the default profile!

I use an external keyboard most of the times, which might be why I am not bumping into this.

Still wondering what the key combination is though Smiley Wink

edit: do you have a touch bar? My current MBP does and the suspend option is just above the 5 key. I do remember now that years ago I did bump into the occasional suspend if macOS still had the focus and I hit the wrong key combo, but forgot details on it. If your mac doesn't have a key combo, you could see if changing the fn key default in macOS makes a difference.

pastedImage_0.png

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos
MikeFromABQ
Enthusiast
Enthusiast
Jump to solution

Yes, my laptop is the 15" MacBook Pro WITH the touch-bar, which I mostly love.

AND I think you have probably guessed correctly that since the Suspend option is often offered on the touch-bar just above the 5 key, bumping it is what I'm doing.  If that's the case, it has nothing to do with profiles or short-cut key assignments.

Since the whole purpose of the touch-bar is to have generated buttons that change in accordance with context, I will have to run the apps in which this problem occurred to note what is in the touch-bar at that time.

I think my previous answer, lacking a screen-shot, failed to convey that I did go to that Preferences screen and saw the settings that indicated "Profile - Default" and that the other box you asked about was left un-checked.  I'm only running one VM on this machine, so there's no confusion there.

I will see if I can change the contents of the touch-bar so that the Suspend button and all other Fusion-related buttons are elsewhere in the bar, or absent entirely.

To stress why I know the provided answer must be correct, let me remind a key part of the description of the symptom:
"This seems to happen mostly when I'm using numbers 5 and/or 6 on the MacBook Pro 2016 (High Sierra and Mojave) keyboard"

Here we see the placement of the Suspend virtual key on the touch-bar is above and almost exactly between the 5 and 6 keyboard keys.

unnamed-2.jpg

Reply
0 Kudos
wila
Immortal
Immortal
Jump to solution

Hi,

Just bumped into an old post I had marked as "good to know" but forgot about.

Please see the answer of this thread:

Fusion 10 MacBook Pro Touch Bar configuration?

I think it will help you (and make the Touch Bar wayyy more useful when in a VM)

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos