phizz
Contributor
Contributor

Disable Keyboard Mapping features of VMWare Fusion 1.1.1

Jump to solution

A new feature of VMware Fusion 1.1.1, which I'm sure most are aware of, is transparent key mapping for some keys (e.g. Cmd-X, Cmd-C, Cmd-V) in single-window and full screen modes.

Question: How do I turn this off?????

The blog entry at http://blogs.vmware.com/vmtn/2008/01/vmware-fusion-1.html suggests it can be turned off in VMWare > Preferences. But I see no such option - in fact it is the same screen as 1.1. (There is one option - "Enable Mac-OS keyboard shortcuts", but turning it on or off does not affect this transparent key remapping, only mac shortcuts like Cmd-Tab).

Anybody? Maybe in the preference files (I can't read the binary ones but if I have to i will)

0 Kudos
1 Solution

Accepted Solutions
Guddler
Enthusiast
Enthusiast

This has been answered in another thread only yesterday: http://communities.vmware.com/thread/123617?tstart=25

There is an option that you can add manually to the config file to switch the new behaviour on and off.

Martin.

View solution in original post

0 Kudos
7 Replies
grdpix
Contributor
Contributor

I have also not been able to find the preference to disable this. It seems this is a popular complaint with 1.1.1. I don't mind so much the cmd-c -> ctrl-c, etc remapping, but I am living in the Netherlands (= euro keyboard), and the enter key on the number pad no longer sends an 'enter' character to Mathematica. So, I'm back to space-return; annoying. I appreciate that they made this new feature, but it should be optional.

(I got a MacBook from work and we can't order them ourselves, and we all got Apple's crummy Dutch keyboard. Even the Dutch hate this keyboard. Why oh why does it exist?!?! Oh, the humanity!)

0 Kudos
Guddler
Enthusiast
Enthusiast

This has been answered in another thread only yesterday: http://communities.vmware.com/thread/123617?tstart=25

There is an option that you can add manually to the config file to switch the new behaviour on and off.

Martin.

View solution in original post

0 Kudos
phizz
Contributor
Contributor

Thanks Guddler - Sorry can't believe I didn't see that.

For all users who found this thread, the answer is:

1. Quit VMware fusion

2. Open the file ~/Library/Preferences/VMware Fusion/preferences in TextEdit (or other) and add the following line to the bottom:

pref.mapMacShortcutKeys = "FALSE"

3. Start VMware fusion again

Problem solved!

0 Kudos
grdpix
Contributor
Contributor

The referenced thread says to put this in ~/Library/Preferences/VMware Fusion/preferences

pref.mapMacShortcutKeys = "FALSE"

This works for ctrl-c, ctrl-v, etc, but enter still gives AltGr. As I said, I don't mind the remap for ctrl vs. cmd. How can I get back 'enter'?.

0 Kudos
Guddler
Enthusiast
Enthusiast

At this stage i believe it's all or nothing but can't confirm as I don't have the numeric keypad on my keyboard.

0 Kudos
grdpix
Contributor
Contributor

I'm not sure how 'all or nothing' applies here... It doesn't seem that the enter/AltGr thing is connected to the ' pref.mapMacShortcutKeys = "FALSE" ' entry.

0 Kudos
admin
Immortal
Immortal

This works for ctrl-c, ctrl-v, etc, but enter still gives AltGr. As I said, I don't mind the remap for ctrl vs. cmd. How can I get back 'enter'?.

0 Kudos