Contributor
Contributor

Cursor trapped in host windw

I have a problem with a particular windows 7 virtual machine.  It was  upgraded from vmw2 to 3 and exhibits a behaviour where the cursor will not transition across the window boundary - in essence, when I am in the vm window the cursor is trapped there.  I can free the cursor with <cmd>-<ctl> but I cannot smoothly move it from the vm to the host and back again.  The puzzle is that this is not the case with new vms created on vmw3 - only this one which was move from vmw2.  I have tried reinstalling both fusion and the tools - nothing seems so make any difference.  It seems like there is a switch set somewhere that I am unaware of.  Has anyone seen this behaviour - better still, is there a fix.

Thanks in advance,

Al

0 Kudos
2 Replies
Contributor
Contributor

Further my last, the problem seems to be related to Vmware's SVGA driver.  If I revert to the normal windows VGA driver then thge cursor move between host and vm as I'd expect.  If install the SVGA driver then the cursor is trapped - most curious.  Are there any setting that might affect this?

Thanx,

Al

0 Kudos
Contributor
Contributor

Hi

I've seen this behaviour and it is also for a Fusion 2.0 upgraded to 3.0 setup. I'm using XP, not Windows 7. The problem goes away if I restart the virtual machine, but occurs if I suspend and resume. I asked on this forum over a year ago, but didn't get any replies.

http://communities.vmware.com/thread/253973

I eventually settled on using Fusion in Unity mode, which doesn't exhibit this problem.

Sorry I haven't helped solve it, but it's nice to know someone else has seen this.

Phil

0 Kudos