VMware Communities
sak1364
Contributor
Contributor
Jump to solution

Cursor stuck in Windows - can't get to Fusion menus

I am running VMWare Fusion 5.0.5. I suddenly got this problem where I click in the Windows environment and the cursor won't move out of that window. For example, if I want to select one of Fusion's menus I can't get to it. Or if I want to move the cursor into the Mac environment in the background (or on a different screen), it can't. It doesn't matter if it is in full screen mode or not. The only way to escape is to press Command + Tab to switch to a different program.

I used to be able to move the cursor anywhere on the screen without any trouble. So I'm guessing some setting got changed. In fact, I think I might've had this problem once before.

Anyone know what I'm doing wrong?

Tags (2)
1 Solution

Accepted Solutions
wila
Immortal
Immortal
Jump to solution

That checkbox is the same for me and here I can move out of the VMs with just the mouse.

Have you by any chance set the Gaming preference to something else as "Never optimize mouse for games" or have you enabled the "per virtual machine keyboard short cuts" option?

edit: Just reread your original question, Fusion 5.05 does not have "per VM keyboard short cuts" but the mouse gaming preference question still stands.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva

View solution in original post

5 Replies
wila
Immortal
Immortal
Jump to solution

Hi,

Welcome to the VMware community forums.

Sounds to me like your VMware Tools needs to be reinstalled as that is the software that takes care of the smooth mouse transitions between host and guest.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos
sak1364
Contributor
Contributor
Jump to solution

Thanks for your reply. I tried reinstalling it but it didn't make a difference.

In the Preferences there is a checkbox for keyboard options that says "Ungrab Mouse and Keyboard". But it is grayed out so I can't uncheck it. There's a key command for it (Command + Control). When I press those keys it releases the mouse so I can roll the cursor out. So I'm pretty sure if I could clear that checkbox it would solve my problem. But I don't know how to do that.

Reply
0 Kudos
wila
Immortal
Immortal
Jump to solution

That checkbox is the same for me and here I can move out of the VMs with just the mouse.

Have you by any chance set the Gaming preference to something else as "Never optimize mouse for games" or have you enabled the "per virtual machine keyboard short cuts" option?

edit: Just reread your original question, Fusion 5.05 does not have "per VM keyboard short cuts" but the mouse gaming preference question still stands.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
sak1364
Contributor
Contributor
Jump to solution

I didn't change it on purpose. :smileylaugh:

Aaaahhhhh that did it! The gaming thing was set to "Auto detect..." I put it on "Never optimize..." and it works fine now.

Thanks so much for your help! Smiley Happy

wila
Immortal
Immortal
Jump to solution

You're welcome, glad to hear the problem is resolved.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos