diddyone
Contributor
Contributor

Could not open /dev/vmmon: Broken pipe.

Jump to solution

upgraded to mojave on mac vmfusion is no longer working same problem as everyone else.

would greatly appreciate the help.

71 Replies
benau_99
Contributor
Contributor

That did the trick for me. Thanks for taking the time to reply.

0 Kudos
imikem
Contributor
Contributor

Thanks much @CharlieSMF,  your solution did the trick for me at last!  Of course along the way I lost a pretty extensive configuration from doing a full-on kill-it-with-fire VMware Fusion removal. Smiley Sad

Mike

0 Kudos
esac5555
Contributor
Contributor

I am on Catalina 10.15 Beta, and even have the issue. So whatever it is, it is still there I presume in newer Mac OS's coming out. I have enabled everything I can in System Prefs, upgraded to VMWare Fusion 11.1.1 yesterday. Deleted some VM's I used, and need, and still no luck. This was an upgrade but I had uninstalled Fusion 8.5 earlier, then re-installed. I am getting the 'broken-pipe' error.

0 Kudos
nathanatbyc
Contributor
Contributor
THIS WORKED FOR ME.  I wasn't getting the security notice button in preferences.  I did have the full disk access option either.  My Mac Pro on can go up to High Sierra 10.13.  I was on HS 10.13.5 and did an update to 10.13.6.  After the update installed, I started have the issue on Fusion 11.4 Pro.  I upgraded fusion to 11.5 Pro and it was still a problem.  Below is the only option I had available to me.
32. Re: Could not open /dev/vmmon: Broken pipe.

lurch999Lurker

This solution works for cases where the "Allow" button does not appear in Security & Privacy > General:

Using Terminal, get the TeamIdentifier value from the VMWare Fusion version you're using (the % is the prompt, so omit that):

   % codesign -dv --verbose=4 /Applications/VMware\ Fusion.app

From the results of that command, find the "TeamIdentifier" value, for example:

   TeamIdentifier=EG7KH642X6

Write that down, and note this is case-sensitive.

Reboot your Mac into Recovery Mode (hold down Command + R at boot)

In Recovery Mode, open Terminal, then:

  % /usr/sbin/spctl kext-consent add EG7KH642X6

Reboot, and you should be good to go now.

0 Kudos
Virtual_Dan
Contributor
Contributor

For me this issue was because fusion was not licensed (i.e. in Trial mode).

The Security and Privacy window showed the message "System Software from Developer "VMware, Inc." was blocked from loading".  However pressing 'Allow' did nothing and the button just remained there.  I couldn't believe it but I was only able to press 'Allow' and something happen once I'd added a licence key to Fusion!

How do VMware expect users to trial their product if it doesn't actually work until you've paid for it?   I've already flagged this with the pleasant chap at VMware support who unfortunately advised he couldn't help me as it was for a trial version (even though I'm a paying customer using a different machine).  Fortunately in my case I was able to use my licence key on this other machine to discover that being a trial prevented the 'Allow' button from working.  Hopefully it helps others with this crazy situation and saves someone some time, though in lieu of a licence perhaps the other suggested steps in this thread are the only way to resolve this while in trial mode.

0 Kudos
iamxCPx
Enthusiast
Enthusiast

CharlieSMF

Thank you!!!

Your workaround did the trick.

Just recently updated the macos to catalina and also upgraded to fusion 11 and guess what? Fusion stopped working with no VMware notification under Security & Privacy/General tab - Allow apps downloaded from.

So for people here that trying to help by giving a suggestion to hit allow on "vmware", please note that not all of us get that notification.

I certainly didn't before (commented on page 1 and 2) and also now after the upgrade to catalina and fusion.

It's super frustrating.

VMware Fusion® (for Mac) @vmware @apple needs to seriously take a good look at this and figure this out.

Good luck y'all!!

0 Kudos
stevebert57
Contributor
Contributor

I have VMWare Fusion 11.5 on macOS 10.15.1 (Catalina). I ran into the same issue described on this post.

For me, the following fixed the issue:

* Open System Preferences -> Security & Privacy preference pane

* If needed click "lock" icon at bottom of preference pane and authenticate as user with administrative access

* In General tab, verify that VMWare Fusion app is not blocked (lower 1/3 of pane), or click Allow button if indicated

* In Privacy tab, select Accessibility from left-hand list, then check the box next to VMWare Fusion to enable access

* In Privacy tab, select Full Disk Access from left-hand list, then check the box next to VMWare Fusion to enable access

* Click on Apple menu in top-left corner menu bar and select Restart.... confirm by clicking Restart in dialog displayed

After restarting, I re-launched VMWare Fusion, then opened each of the virtual machines. VMWare Fusion asked to confirm that I had moved or copied the VMs (I had) and I confirmed this. After that, the VMs were once again functional with no further errors.

0 Kudos
dtbrigh
Contributor
Contributor

This is NOT the right answer.

Have VMWARE reopen Support Request Confirmation Number: 17625069911

I have used Migration Assistant SEVEN or Eight TIMES to move all Data from my  2017 iMac to 2019 iMAC

I have checked the System Preferences==>Security & Privacy==>general, & have verified that VMWare Fusion App has FULL CONTROL OF my IMac which

"Allow apps downloaded from" is App Store and identified developers.

pastedImage_0.png

I have verified this some twenty times after performing Apple Migration process some 8 times.  VMWare Fusion Version 10.1.6 (12989998) will not create the VMWARE Fusion kernel /dev/vmmon

Apple has confirmed the issue is on your VMWARE side. Please fix this issue.

2019iMac:~ dtbrigh$ ls -slag /dev/vmmon

ls: /dev/vmmon: No such file or directory

2019iMac:~ dtbrigh$

Support Request Confirmation Number: 17625069911
(2017) Issue category

Fault/Crash

(2017) Issue description

  Trying to recover a virtual machine from a Time Machine backup from another computer "Windows XP Professional" on an iMac. Entered my Key & attempted to startup VM & receive error: "Cannot find a valid peer process to connect to"


I have Windows XP Professional.vmwarevm in my Documents Virtual Machine folder.

I have been using VMWare Fusion since version 1.1.3 in 2008  Please make this work for me.  This thread is completely bogus answer.  Everytime I check out this issue on the web in comes up with this same stupid f. answer. That is not the problem   I am quite frustrated that a company that I have been supporting fro some twelve years does not provide me with free technical support. I have been fighting this issue since October.

0 Kudos
dtbrigh
Contributor
Contributor

I followed the actions of # 23 & 46 & finally discovered that under System Preferences "General" tab VMWare fusion was blocked. As soon as I clicked on "I Copied it" when I was notified that the Virtual machine had been moved, my VM started right up. Thanks guys. Fought this for a month. Did not realize there were more answers to the fix of the problem after I had  logged in to the VMWare Fusion community

0 Kudos
dtbrigh
Contributor
Contributor

21 & 46

Thanks

0 Kudos
TSHou
Contributor
Contributor

This was the only thing that worked for me with Fusion 11.5 running on MacOS Catalina and a Win10x64 VM.

I searched for days for this solution as none of the other things worked. Thank you @lurch999!

This solution works for cases where the "Allow" button does not appear in Security & Privacy > General:

Using Terminal, get the TeamIdentifier value from the VMWare Fusion version you're using (the % is the prompt, so omit that):

   % codesign -dv --verbose=4 /Applications/VMware\ Fusion.app

From the results of that command, find the "TeamIdentifier" value, for example:

   TeamIdentifier=EG7KH642X6

Write that down, and note this is case-sensitive.

Reboot your Mac into Recovery Mode (hold down Command + R at boot)

In Recovery Mode, open Terminal, then:

  % /usr/sbin/spctl kext-consent add EG7KH642X6

Reboot, and you should be good to go now.

bradsjm
Contributor
Contributor

Thank you, that fixed it!

0 Kudos
MRomine
Contributor
Contributor

I sure wish that this was the answer for me.

When I run this command in Terminal: % codesign -dv --verbose=4 /Applications/VMware\ Fusion.app

Get this as the response: no such job

Running OS 10.13.6 and Fusion 11.0.1

I have checked Security and Privacy and I have VMware Fusion box checked.

Need help!

0 Kudos
Ken_H
Contributor
Contributor

I was running macOS 10.13.6 High Sierra when I made the mistake of upgrading VMWare Fusion to 11.5.5.  It turns out Fusion 11.5.5 needs macOS 10.14 or higher so I upgraded to macOS 10.14.6 Mojave and now when I try and boot my windows virtual machine I get:

> Could not open /dev/vmmon: Broken pipe.

> Failed to initialize monitor device.

> Transport (VMDB) error -14: Pipe connection has been broken

I ran System Preferences > Security & Privacy > General but there was no Allow button for VMWare.

Under Security & Privacy > Privacy > Accessibility, I've confirmed that VMWare Fusion.app has a checkmark.

Under Security & Privacy > Privacy > Full Disk Access, I added VMWare Fusion.app, added a checkmark, and rebooted.  The problem remains.

Opened a terminal app and ran:

     codesign -dv --verbose=4 /Applications/VMware\ Fusion.app

Found:

     TeamIdentifier=EG7KH642X6

Booted into recovery mode > Terminal > ran "/usr/sbin/spctl kext-consent add EG7KH642X6" > rebooted normally.  The problem remains.

Opened terminal and ran "kextstat | grep -i vmware", zero rows are returned.  Ran "kextstat | grep -v com.apple" and only get one row back:

Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>

  164    0 0xffffff7f83cf4000 0x8000     0x8000     com.malwarebytes.mbam.rtprotection (4.4.11) EE770DFC-3C8D-31D3-91DF-4D97FEEB2576 <6 5 3 1>

Disabled malwarebytes.  The problem remains.

Have opened a ticket with VMWare support.

0 Kudos
DanSnelson
Contributor
Contributor

The following command worked in macOS 10.15.5 sans booting to macOS Recovery:

/usr/sbin/kextcache --clear-staging

0 Kudos
Ken_H
Contributor
Contributor

I did the following:

> Enabled root

> Switched to root user

> Opened Terminal

> Ran "kextcache --clear-staging"

> Closed Terminal

> Returned to normal signon and disabled root

> Rebooted computer

> Ran VMWare Fusion

> Tries to boot Windows virtual machine:  Got the same errors.

Ken

0 Kudos
Ken_H
Contributor
Contributor

Also tried:

> Enabling root

> Open Terminal

> su -

> Get root prompt

> Run "/usr/sbin/kextcache --clear-staging"

> Run VMWare

> Boot Windows VM:  Get same error

0 Kudos
DanSnelson
Contributor
Contributor

The following script may prove helpful to remove Fusion: VMware Fusion Remove.sh

In my case, after running the above script and downloading a fresh installer from Download VMware Fusion | VMware, all worked as expected.

My previous installer, created via AutoPkg, doesn't appear to include the Staged Extensions. You may wish to validate the following directory:

ls -lahR /Library/StagedExtensions/Library/Application\ Support/VMware/

0 Kudos
Ken_H
Contributor
Contributor

Update:  I run a premium version of Malwarebytes and thought it might be causing problems with VMWare Fusion so I stopped the real time protection thinking it might be the problem.  VMWare Fusion still didn’t run.  It was then that I notices I was also NOT able to re-enable the Malwarebyte real-time protection.  It appeared my macOS was messed up and was affecting multiple applications.

I ended up restoring the entire computer to macOS 10.13.6 High Sierra - just prior to the upgrade to macOS 10.14.6 Mojave.  I then disabled Malwarebytes real-time protection, re-downloaded and installed Mojave.  This took quite some time (10 hours?) but I have good news:  Upon starting VMWare Fusion, it gave the normal message about System Preferences > Security & Privacy > Accessibility > grant access to VMWare Fusion.app.  After doing this, I did a reboot and my VMWare Fusion is running!

I’ve also turned the real-time Malwarebyte protection back on.  This problem has been resolved for me and it is pretty clear my problem was not a VMWare Fusion problem but an issue with running the Mojave upgrade while Malewarebytes realtime protection was enabled.

Thanks for your help

0 Kudos
Ken_H
Contributor
Contributor

Ugh.  Went camping for a week to get a break from this COVID mess and came back to find my VMWare Fusion broken again.  Ran through all the fixes like running the command as root, booting to safe mode, etc.  I have another ticket open with VMWare support but it's been days since the ticket was open and I've not heard back from them. 

0 Kudos