D_Lewis
Contributor
Contributor

Could not create image for Boot Camp

Hi, I have a Boot Camp partition with Vista Home Premium, and whenever I try to load it in VMware, I get the error:

"Could not create the virtual disk for your Boot Camp virtual machine."

I've tried re-installing VMware by following these instructions: http://communities.vmware.com/thread/118740 but it still happens.

I can create a new virtual machine fine, but it just wont load the Boot Camp partition.

Does anyone know of a solution? Thanks.

0 Kudos
40 Replies
WoodyZ
Immortal
Immortal

Hi, I have a Boot Camp partition with Vista Home Premium, and whenever I try to load it in VMware, I get the error: "Could not create the virtual disk for your Boot Camp virtual machine."

Follow these steps to rebuild the Boot Camp partition Virtual Machine...

Highlight the Boot Camp partition entry in the Virtual Machine Library window and then press the delete key.

Next close Fusion (From the VMware Fusion menu bar not just closing the Virtual Machine Library window)

Next delete the "/Users/$/Library/Application Support/VMware Fusion/Virtual Machines/Boot Camp" Folder.

Reboot your Computer.

Start Fusion and the Boot Camp partition entry on the Virtual Machine Library window should reappear, highlight it and click Run.

Note: If Boot Camp partition entry does not appear on the Virtual Machine Library window after a minute or so then close Fusion and reopen Fusion. It should now appear at the bottom of the list.

Next an Authenticate dialog box appears. "VMware Fusion requires that you type your password." Enter your Name and Password then click OK. (This is necessary to unmount the Boot Camp partition for Fusion to have direct access to it.)

Next you should see a Boot Camp partition message stating "VMware Fusion is preparing your Boot Camp partition to run as a virtual machine. This may take a few minutes. This will happen once."

When the Boot Camp partition Virtual Machine boots for the first time after this VMware Tools will install/update and reboot the Boot Camp partition Virtual Machine.

0 Kudos
D_Lewis
Contributor
Contributor

Nope, that doesn't work either. I get the error message once I click Run - before an Authenticate dialog box appears.

0 Kudos
gavin8or
Contributor
Contributor

Yeah I'm having the exact same problem. This is a waste....

0 Kudos
benjuang
Contributor
Contributor

Got it. It's because VMWare Fusion either:

a) isn't able to request authentication to eject the disk

b) can't eject the disk because it's busy (can verify this - open Disk Utility and try to unmount the disk there.)

Fix:

Open Terminal (in your Applications folder, under Utilities), run the following command:

sudo umount -f /Volume/BOOTCAMP/

This will forcefully eject the bootcamp partition. (Will ask for admin password.)

After that, try to open it again.

0 Kudos
ElCamino
Contributor
Contributor

I'm having the same error "Could not create the virtual disk for your boot camp virtual machine " I typed sudo umount -f /Volume/BOOTCAMP/ Any ideas?

How can I remount the drive back? I get Resource busy when I try to mount the drive like it was before.

0 Kudos
sweetpummello
Contributor
Contributor

I'm not sure I have an answer to your problem, but I have a question. I am having the same problem and I wonder whether you are running 10.5.2. I had VMware Fusion running perfectly, but had other major problems and finally Genius Bar found a hardware problem and replaced my laptop. It came with 10.5.2. I used Boot Camp to partition and install Vista Business. I installed the additional Leopard drivers as instructed by Boot Camp that included a Boot Camp control panel. I then installed VMware Fusion and it's update Version 1.1.1 (72241). The Boot Camp partition shows up, but I got the same error message you are talking about. I went to Vmware Fusion File>Open Recent and it shows Vista. I clicked on Vista and it told me it couldn't find it, but gave me 2 choices for an answer and noted if I didn't know which to choose, to select "I copied it" which I did. It then opened my Windows Vista. Now Windows Vista shows up as a choice in the list. When I select it, and hit "run" it will bring up the Windows Vista, but without the Boot Camp control panel. However, my internet works as does my usb printer. The Windows is unstable, however and crashes often with a different error message than I have seen before. I think the Windows was more stable in 10.5.1. I don't know if this will help you. I'm still interested in accessing my Boot Camp Partition in VMware as I did previously, if anyone knows how to do this safely.

0 Kudos
ElCamino
Contributor
Contributor

I'm actually using Tiger 10.4.11 with the latest VMware also. This all started also after I replaced my hard drive with a bigger 320GB and loaded boot camp and installed Vista Ultimate on it. Then loaded VMware with no luck, just the same error. I went as far as loading Parrallels to see if that would work and no luck. I will try what you did by opening recent under VMware. I just have to wait until I get my Macbook Pro back from Apple. I just dropped it off today Saturday, my optical drive was malfunctioning, so they are changing it out under warranty. I should get it back Tuesday the 2nd. In the mean time I just have to wait and see if anyone else ppost something else. By the way anyone know what command under terminal will mount the Windows Untitled drive back. I type sudo mount /dev/disk0s3 /Volumes/Untitled and I get a resouses busy so it doesn't mount the drive. But this doesn't affect how VMware sees the drive though it still sees it.

0 Kudos
ElCamino
Contributor
Contributor

I'm actually using Tiger 10.4.11 with the latest VMware also. This all started also after I replaced my hard drive with a bigger 320GB and loaded boot camp and installed Vista Ultimate on it. Then loaded VMware with no luck, just the same error. I went as far as loading Parrallels to see if that would work and no luck. I will try what you did by opening recent under VMware. I just have to wait until I get my Macbook Pro back from Apple. I just dropped it off today Saturday, my optical drive was malfunctioning, so they are changing it out under warranty. I should get it back Tuesday the 2nd. In the mean time I just have to wait and see if anyone else ppost something else. By the way anyone know what command under terminal will mount the Windows Untitled drive back. I type sudo mount /dev/disk0s3 /Volumes/Untitled and I get a resouses busy so it doesn't mount the drive. But this doesn't affect how VMware sees the drive though it still sees it.

0 Kudos
sweetpummello
Contributor
Contributor

Have you tried restarting holding down the option key? This is supposed to show all the partitioned drives you have and give you the choice of which drive you want to mount and start. It's supposed to work in both 10.4 and 10.5 OS. Hope this helps.

0 Kudos
ElCamino
Contributor
Contributor

Yes I can boot to Vista or Mac fine. If I choose Vista while booting up under bootcamp it works great. Its just when I try to run Vista with VMware that I get the error. Thanks for the suggestion.

0 Kudos
benjuang
Contributor
Contributor

Rebooting should remount the disk. Alternatively, you can try opening Disk Utility and mounting the disk from there. "Resource is busy" is odd - that implies that something is using the disk, which... shouldn't be happening if it's not mounted? (You don't/didn't see it on your desktop anymore, right?) Although I can't say for sure - much of my conclusion for my "fix" was educated guessing.

0 Kudos
benjuang
Contributor
Contributor

Ah, here's a possible reason for "resource is busy" - I can get that error if I try to mount the drive when it's already mounted:

benjamin-juangs-macbook-pro:~ benjamin$ df

Filesystem 512-blocks Used Available Capacity Mounted on

/dev/disk0s2 222035968 207870744 13653224 94% /

devfs 212 212 0 100% /dev

fdesc 2 2 0 100% /dev

map -hosts 0 0 0 100% /net

map auto_home 0 0 0 100% /home

/dev/disk0s3 11710944 11206240 504704 96% /Volumes/BOOTCAMP

benjamin-juangs-macbook-pro:~ benjamin$ sudo mount /dev/disk0s3 /Volumes/BOOTCAMP/

/dev/disk0s3 on /Volumes/BOOTCAMP: Resource busy

Perhaps you didn't successfully unmount the drive?

As for remounting, open Disk Utility (in /Applications/Utilities/), then select your grayed out bootcamp volume (if it's not grayed out, you didn't successfully unmount it). Then click "Mount" or go to "File" > "Mount "BOOTCAMP"", where "BOOTCAMP" will be whatever you named your bootcamp volume.

The command you listed "sudo mount /dev/disk0s3 /Volumes/BOOTCAMP/", may or may not work for you... after I unmounted and tried to use the mount command, I got the error "mount: realpath /Volumes/BOOTCAMP: No such file or directory". I think you may need to do a mkdir /Volumes/BOOTCAMP first, so there's a place to mount to? Not sure, never did this in MacOS X this way.

0 Kudos
sweetpummello
Contributor
Contributor

Ditto with your situation; interesting that you began having problems after having the larger HD installed. When I was given a new MacBook Pro to replace the one with the defective hardware under warranty, I opted to spend a little more and get a 250 HD with a 2.5 processor. We seem to have common difficulty with Vmware after getting the larger HD using two different OS. Very odd indeed.

0 Kudos
ElCamino
Contributor
Contributor

Yes this is very odd after installing the larger hard drive. I did increase the space for bootcamp. Before the larger hard drive I had reserved 30GB, and now with the larger hard drive that I installed I made 80GB for Vista Ultimate.

Also about mounting the Drive, it does show up on my Mac OS desktop but the eject icon doesn't show up next to the drive after I ran this comand from a earlier post I typed "sudo umount -f /Volumes/BOOTCAMP" I can see it fine but thought I might need it to show the eject icon if I every get VMware working. I would post a screen shot of what I mean but my Macbook Pro is at the Apple store getting the optical drive replaced and wont get it back until about the 2nd.

0 Kudos
ElCamino
Contributor
Contributor

benjuang- Does your windows drive you created with bootcamp show a eject icon next to it when you view it in finder? Because mine doesn't after I ran the sudo umount -f /Volumes/BOOTCAMP command in Terminal. The drive shows up in my desktop and if I go to disk utility I can high light the drive which bootcamp named Untitled and click unmount and it will unmount it and will show light color. Maybe I'm wrong about it suppose to have the eject icon but I do remember it having that icon. Maybe I will bootup my wife's macbook pro and see if the eject icon is there on the Untitled partition.

0 Kudos
sweetpummello
Contributor
Contributor

Regarding partitioning larger HD. I also increased the size of the partition for Windows from 38 to 65. Particularly puzzling and frustrating since it was working on the previous HD with NTFS formatting and 10.5.2. But the defective MacBook Pro was Tiger with Leopard Upgrade and then downloaded patches to 10.5.2. I don't know if Genius Bar has any answers, or VMware tech support. I've put in a support request w/VM. I'll be interested in any help they give. If you are interested, I'll post their reply...should be by end of Monday. Beware of the Windows you see in the VMware File>Open. I loaded an application there, but when I did the boot using the option key to see the application in Boot Camp Windows as a double-check, the application doesn't show up in the list of all programs. How does something like this happen? Is it possible that there are 2 Windows...1 in each application?

0 Kudos
ElCamino
Contributor
Contributor

Maybe VMware doesn't support larger bootcamp drives or partitions. We have simalir problems after increasing the size of BootCamp for windows. Yes if you can post VMware reply to your support question that would be great hopefully they have some kind of answer to this. Hopefully my Macbook Pro will be ready Tuesday for pickup at the Genius Bar.

0 Kudos
sweetpummello
Contributor
Contributor

Re: VMware not supporting larger partitions...I tried partitioning thru VMware w/o Boot Camp and where you put in the size partition you want, there didn't seem to be a partition limit (no end size that I saw). I'll post what their support says. Might be interesting to ask genius bar about phenomenon, but I doubt they will have much to say especially since it isn't their software.

0 Kudos
ElCamino
Contributor
Contributor

I asked the genius bar tech Saturday when I dropped off my Mac to get the Optical drive replaced, and he said that to reload boot Camp. Pretty much since they don't support it they didn't seemto interested in helping or had any ideas. Hopefully Vmware will get back to you guys with afix and you can post it here.

0 Kudos