Mohannad
Contributor
Contributor

Control+F1

I have a program that requires me to input the combination Control+F1 in order to get some things done. Problem is that when I'm running Windows 2K or XP in Fusion, I can't seem to get that shortcut to work. It is the only way to function with the program, in other words, there is no other input method other than the shortcut. Can anyone help?

0 Kudos
5 Replies
rcardona2k
Immortal
Immortal

This is an FAQ.

On the Mac, function keys are mapped to other functions like brightness, volume, etc. To use the "real" function key locate the fn key (usually lower-left on the keyboard), use the fn key like Shift, control, etc. so Control-F1 should be Control-fn-F1

If you use this key so often you want F1 without pressing fn-F1, you can change the function key setting in System Preferences > Keyboard & Mouse > Keyboard > Use all F1, F2, etc as standard function keys.

This information is "Using Mac keyboards" in Help > VMware Fusion help > search for > function

0 Kudos
Mohannad
Contributor
Contributor

I've tried that, the problem is that it doesn't work while holding down Control as well. The combination of Control+F1 is what doesn't work.

0 Kudos
rcardona2k
Immortal
Immortal

Did you also try the System Preferences change for function keys? You can run the onscreen keyboard to verify that Ctrl+F1 is working. The onscreen keyboard is available via Start > Run > osk > (ok button). Click the Ctrl key then click F1 and see if your program recognizes it. The onscreen keyboard works in all applications as an assistive application.

0 Kudos
Mohannad
Contributor
Contributor

Figured it out!! You have to uncheck the Enable Mac OS X Keyboard Shortcuts option. Once that's done the Guest OS maps the keys correctly. Thanks for your help!

0 Kudos
rcardona2k
Immortal
Immortal

You figured it out yourself. Smiley Happy Congratulations.

0 Kudos