VMware Communities
tm8747a
Contributor
Contributor
Jump to solution

Connect to something running on VMWare Fusion host from guest

I'm running an elasticsearch server on my Mac and would like to connect to it from Windows 10 running in VMWare Fusion 11. I have my adapter running in Bridged mode. Everything I read seems to say I should just be able to use the Mac IP address to connect, but it's not working. I have firewalls turned completely off on both the Mac and Windows. I'm trying to access Kibana from Windows, so doing http://[mac ip address]:5061 from Windows browser, keep getting ERR_CONNECTION_REFUSED in Chrome. I'm able to ping the IP from the guest, so clearly it can see the host, but something is blocking the connection. I tried forwarding port 5601 on my router, that didn't work either. Oh, and I also switched from Bridged to NAT just in case, that didn't work either. So I'm fast running out of ideas on how to figure out what's blocking this connection. Any ideas?

1 Solution

Accepted Solutions
wila
Immortal
Immortal
Jump to solution

Hi,

This appears to be a common Kibana configuration issue.

Go to:

Configuring Kibana | Kibana User Guide [6.6] | Elastic

and search on that page for "server.host", it looks like the default setting is "localhost".

You cannot access another machine's localhost from a remote IP.

So you would have to change that setting to the actual IP address you want to access it on.

After that, restart kibana and try again.

hope this helps,

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva

View solution in original post

Reply
0 Kudos
2 Replies
wila
Immortal
Immortal
Jump to solution

Hi,

This appears to be a common Kibana configuration issue.

Go to:

Configuring Kibana | Kibana User Guide [6.6] | Elastic

and search on that page for "server.host", it looks like the default setting is "localhost".

You cannot access another machine's localhost from a remote IP.

So you would have to change that setting to the actual IP address you want to access it on.

After that, restart kibana and try again.

hope this helps,

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos
tm8747a
Contributor
Contributor
Jump to solution

Thanks, you were indeed correct. I changed Kibana config file to bind to 0.0.0.0 instead of localhost. I thought binding to localhost or 127.0.0.1 automatically made it also include the LAN IP, but you learn something new every day...