VMware Communities
digicuity
Contributor
Contributor

Configure VMware Fusion 11.0.2 to Force Dedicated VRAM in Windows 10

I'm trying to get VMware Fusion to allow a full 2GB of dedicated VRAM in windows so I can take better advantage of my GPU and hopefully run iRacing in VM.  I have searched the forum and tried several suggestions for older versions of Fusion that have you edit the config file but none of those options have been successful.  This included the following:

  • Setting min VRAM Size:  svga.minVRAMSize = "2147483648"
  • Turn off SVGA auto detect: svga.autodetect = "FALSE"

My configuration is as follows:

Host System:

  • Mac Pro 5.1 - 2 x 3.46 GHz 6-Core Intel Xeon x5890
  • Mojave Mac OS
  • 64GB RAM
  • Samsung 850 EVO SSD dedicated to Virtual Machine
  • Sapphire RX580 Pulse 8GB VRAM GPU
  • VMware 11.0.2 configured as follows
    • 6 cores allocated
    • 8GB RAM allocated
    • Shared graphics memory set to maximum (3072MB)
    • Using HW version 16

VM System:

  • Windows 10 Home Edition, ver. 1803, OS build 17134.648

Currently in Windows display setting only minimal VRAM of 4MB is dedicated (see attached screen capture).  I can't seem to find a way to change this and force dedicated VRAM to take advantage of the 3GB allocated.  I'd like at a minium to have 2048MB of dedicated video memory in Windows.

Screen Shot 2019-03-21 at 9.42.49 PM.png

Is this possible?

Reply
0 Kudos
2 Replies
Mikero
Community Manager
Community Manager

Hi there,

Unfortunately this is not possible. the vGPU will use (up to) all of the 'Shared' memory.

What was the underlying reason you would like the vRAM to be 'dedicated'?

-
Michael Roy - Product Marketing Engineer: VCF
Reply
0 Kudos
digicuity
Contributor
Contributor

Thanks for your quick reply.  That is dissapointing news to say the least as some 3d graphics apps and iracing in particular check for and require a certain minimum dedicated vram to run.  So this means without a way to change dedicatd vram in VMware I will no longer be able to use it as my Windows solution on my Mac.  I will have to set up windows directly and reboot which I was hoping to avoid.

Reply
0 Kudos