macdamit
Contributor
Contributor

CapsLock stuck ON in Windows 10 Guest

CapsLock keeps turning on in my Windows 10 guest.  Upon booting the guest and being presented with the Login screen, when I go to enter the password the CapLock indictor is turned on.  I've tried pressing the CapsLock button on the keyboard and manually sending CapsLock signal via the VMware Fusion menu. Nothing I do seems to turn off CapsLock for more than a few seconds.   I've seen references of similar issues on this forum in years past but none of those work arounds seems to fix the issue.   HELP!

I'm running:

  • MacBook Pro 13", Late 2016 version
  • Fusion Professional Version 11.1.1 (14328561)
  • Host: MacOS Mojave Version 10.14.6 host
  • Guest: Windows 10 Pro guest OS
  • Apple Bluetooth Magic Keyboard
0 Kudos
5 Replies
HurcoMv
Contributor
Contributor

I've had this happen very occasionally and I don't know what actually triggers it. I do have my keyboard profile (in Fusion settings for the VM) set to Windows 8 Profile. Just noticed there's now a Windows 10 Profile which has probably been there for a while, but not something I've needed to change.

Also have a Mac external keyboard connected to my MacBook Pro 2018 but it is connected via USB.

I can clear caps lock generally by returning to the the Mac, for example clicking in the address bar in Safari, make sure you select caps lock and type a few characters, then return to Windows VM and toggle back to caps lock off.

I don't know if VmWare Tools has anything to do with this - I guess make sure you've installed VmWare tools and/or updated to the latest version on your VM.

Note also that I'm using Fusion 11.5 but I've had the issue on all Fusion releases from about 8 or whatever it was back in 2013 when I started using it.

0 Kudos
JessieZhang
VMware Employee
VMware Employee

macdamit​,

It sounds like a problem with Fusion 10, but the problem had been solved since Fusion 10.1.2, see the first resolved issue in Fusion 10.1.2 release notes (VMware Fusion 10.1.2 Release Notes ). It is weird to know that the problem happens again in your environment.

Please have a try with below steps to see if that can help solve your problem:

Step 1: Quit Fusion

Step 2: Create a file and name it as "config", make sure the file has no extension name

Step 3: Add this line to the config file:

        mks.keyboard.setHostLEDs="FALSE"

Step 4: Copy the config file to ~/Library/Preferences/VMware Fusion/ folder

Step 5: Launch Fusion and see if your problem still persists

0 Kudos
macdamit
Contributor
Contributor

I tried this option and it had no effect (still have the problem).

0 Kudos
JessieZhang
VMware Employee
VMware Employee

macadmin​,

I could not reproduce this issue on my machine, so could you please provide more information so that we can identify what special configuration or steps cause this problem in your environment?

From your description, I see that your machine is a MacBook Pro 13" (Late 2016 version) and you are using an Apple Bluetooth Magic Keyboard when this issue happens, does this issue happen when you use the built-in keyboard on your MacBook Pro? Does this issue happen only on the specific Windows 10 virtual machine or on all of your virtual machine other than the Windows 10 virtual machine?

0 Kudos
ftrujillojr
Contributor
Contributor

I found a work around if you are using Centos 7 as your guest OS.  https://www.cyberciti.biz/faq/linux-deactivate-caps-lock/

https://www.cyberciti.biz/faq/linux-deactivate-caps-lock/

Update your ~/.bashrc

# .bashrc

# Source global definitions

if [ -f /etc/bashrc ]; then

. /etc/bashrc

fi

alias l='/bin/ls -lrt --color=auto'

alias ll='/bin/ls -alrt --color=auto'

disableCapsLock () {

     xmodmap -e "remove lock = Caps_Lock"

     setxkbmap -option ctrl:nocaps

}

enableCapsLock () {

     xmodmap -e "add lock = Caps_Lock"

     setxkbmap -option

}

disableCapsLock

0 Kudos