greinick
Contributor
Contributor

Cant access the VM form the host and vice versa - Added a userdefined Network

Hi,

I added a user defined network to my fusion 7 Pro and connected a fm to it.

In the settings for that network the host is connected as well, NAT is enabled (the VM should be able to connect to the outer world.)

Current state:

  • My Mac (the host) got an IP address from the pool. I can ping that address from the mac.
  • My VM got an IP, and a route. Ping to the VMs IP works, so dose connection to server in my lan and on the internet.

Not working is a connection (ping, ssh, etc) from the host to the vm and from the vm to the host.

Thanks for any feedback and suggestions!

BTW: The default setting with DHCP worked (ping Host <-> VM), but I want to configure the setup to be portable to different hosts....

0 Kudos
1 Reply
nancyz
VMware Employee
VMware Employee

Hi greinick,

Welcome to Fusion community. Smiley Happy

Current state:

  • My Mac (the host) got an IP address from the pool. I can ping that address from the mac.
  • My VM got an IP, and a route. Ping to the VMs IP works, so dose connection to server in my lan and on the internet.

Not working is a connection (ping, ssh, etc) from the host to the vm and from the vm to the host.

       Did you check 'Connect the host Mac to this network' when you add your network. If NOT, please check it and try to ssh,ping... the VM from host and see if it works.

     

BTW: The default setting with DHCP worked (ping Host <-> VM), but I want to configure the setup to be portable to different hosts....

       Do you mean you want a different host to access your VM on the current host? If YES, you need to enable port forwarding in you vmnet.conf file, it resides in /Library/Preferences/VMware    Fusion/vmnetX,

edit nat.conf,  you could find some lines like:

[incomingtcp]

# Use these with care - anyone can enter into your VM through these...

# The format and example are as follows:

#<external port number> = <VM's IP address>:<VM's port number>

#8080 = 172.16.3.128:80

Then add a line following the example, say

801 = 192.168.117.128:22,

From the other host, you could ssh to your VM using:

#ssh -p 801 guestUser@hostIP, then type the password of your VM.

Hope this will help.

0 Kudos