creasman
Contributor
Contributor

Cannot disable "windows key" behavior from Fusion 5

Can someone tell me how to disable the "windows key" function from within a VM running Win 7.  For example, what I *used* to be able to do was hit "command-tab" to switch between my VM and other apps running on OS X.  Now, the "command" key on my MBP defaults to the "windows key" and always opens up the start menu in Win 7.  I've disabled the key mapping in the preferences but that didn't make any difference.

So, the behavior is:

1. I'm in my Win 7 VM

2. Hit "command-tab"

3. The start menu in Win 7 comes up but I can still move to a different OS X

4. Come back to Win 7 VM and the start menu is up

I know this sounds silly but it's driving me crazy.

Thanks

0 Kudos
13 Replies
osturm
Contributor
Contributor

I'm interested in a solution to this problem as well. I can actually use the Mac task switching with Command-Tab (after enabling the "Mac Host Shortcuts" in the new keyboard profile editor), but the Windows Start Screen in Windows 8 pops up every time I do this. I also like to use the Command key as a Control key replacement for some other combinations inside Windows, and I have the mappings set up to do so. However, this also triggers the Windows key behavior sometimes, which is highly inconvenient.

This VMWare KB article suggests it was possible to switch off this mapping in the past: http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&externalId=1001675

I don't remember whether I had this configured somehow in VMWare 4 and earlier, but the option to change the Windows key mapping doesn't seem to be available anymore - of course I can create mappings that trigger the Windows key *in combination* with another key, but there doesn't seem to be a way to map it *on its own* (or rather, remove or reconfigure the mapping that's obviously already there).

I hope there's a solution, or a fix coming up soon!

0 Kudos
osturm
Contributor
Contributor

Huh, found a solution just now after some looking around - "just" remap the Windows key inside Windows itself and the problem goes away. Of course that's not as easy as it probably should be, since MS don't have an option for that sort of thing... anyway, see below. Remains to wonder whether I've always done something similar in the past and I just forgot about it... don't think so. So something must have changed in version 5, because I'm pretty sure I didn't have that problem in the past. Also, in general the keyboard mappings I have configured on the Mac (for instance, Caps Lock set up as Command) seem to work fine inside the VMs... oh well.

So, to fix the problem, I grabbed this tool: http://webpages.charter.net/krumsick/ - doesn't look all too trust inspiring, but as far as I can tell, it does its job and nothing else. I actually used it with Windows 8 without trouble. Just run it, select the left and right Windows keys from the little keyboard image and remap each to something else (I went for left and right Control keys). Apply, restart, and voila - problem gone.

Good luck!

0 Kudos
xtremesniper
Contributor
Contributor

I have the same problem and I shouldn't have to hack around in Windows to get it to work.

If in the preferences there is an "enabled" checkbox next to this hotkey mapping, I should be able to disable it by unchecking it. This is clearly a bug.

Besides, the Windows key behaviour should not activate in Windows until the user either:

1. Releases the CMD key without pressing anything else

2. Presses the second key in the combo with CMD and it is NOT the TAB key

If TAB is pressed with CMD then VMWare should not pass through the key to the mapping.

0 Kudos
creasman
Contributor
Contributor

Agreed.  Messing around in the Window's registry, particularly with a utility that is not "verified" is probably not smart.  I should probably state that in Fusiong 4, I had no problem with this.  I understand that this behavior is perhaps considered correct, but yes, we should be able to disable the windows key behavior all together.  Hopefully they will address this in some way.

We'll see.

Thanks for the feedback, guys.

0 Kudos
JamesA
Contributor
Contributor

Count me as another frustrated Fusion 5 user with this issue.

You can disable the Windows key within Windows itself by applying a registry change.

Create and run (import) a .reg file with the following contents:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,03,00,00,00,00,00,5B,E0,00,00,5C,E0,00,00,00,00

Unfortunately it permanently disables the Windows key until the registry value is deleted and has to be applied to each individual Windows virtual machine but it's better than dealing with the constant start menu popup.

I have also attached the reg file to this message.

0 Kudos
MrSzymon
Contributor
Contributor

The easiest fix for this is to map the CMD key to CTRL.  In fusion preferences, go to Keyboard and Mouse, Key Mappings, and add a new mapping by clicking on the plus sign.  Under "From" click on the CMD button, under "To" click on the "Control" button, but don't specify any actual keys - I've attached a screenshot.  Click on OK and you'll have a new mapping that maps CMD to Control.  CMD+Tab still works on OSX, and you don't get the start menu popping up in the VM 🙂

-simon

0 Kudos
aprabhas
Enthusiast
Enthusiast

Thanks for the post. This was actually a bug filed after the Fusion 5 release and if I remember right, it was also seen in the beta. I am no longer with VMware, but I can assure you that this bug is under the notification of the developers.

0 Kudos
msbc42
Contributor
Contributor

Hasn't been fixed in the 5.0.2 update.

Mark

0 Kudos
xtremesniper
Contributor
Contributor

Thanks for the update... That sucks to hear, though. I haven't upgraded yet.

0 Kudos
johnyo0o
Contributor
Contributor

I have this same problem with Windows 8 and it hasn't been fixed in 5.02. Is there a workaround? Remapping the windows key from VMWare preferences to Ctrl doesn't work, nor does download external software to disable the windows key from the host.

Cmd+Tab is a pretty basic functionality that I hoped would work; if anyone found a way to get around this please let me know! Thanks.

0 Kudos
fszczerba
Contributor
Contributor

MrSzymon wrote:

The easiest fix for this is to map the CMD key to CTRL.  In fusion preferences, go to Keyboard and Mouse, Key Mappings, and add a new mapping by clicking on the plus sign.  Under "From" click on the CMD button, under "To" click on the "Control" button, but don't specify any actual keys - I've attached a screenshot.  Click on OK and you'll have a new mapping that maps CMD to Control.  CMD+Tab still works on OSX, and you don't get the start menu popping up in the VM 🙂

-simon

Thanks for this. This is the best workaround I've seen. I wish they would fix this though.

0 Kudos
welder314
Enthusiast
Enthusiast

I opened a support ticket on this and really pressed them for an answer.  Their response was that it is not a bug; it's just how Fusion 5 works and that it's a great feature. :smileyconfused:

Fusion 4 used to let you unmap the CMD to Start Menu; if you upgrade from v4 > v5, that option still shows in the Key Mappings preferences, but it's a 'ghost' from the old preferences (hence my support call).

Simon's fix is a good workaround, but I just wish VMware would add an option to disable the mapping ... seems rather simple.

0 Kudos
davidb2
Enthusiast
Enthusiast

@welder314,

I am also grateful for Simon's workaround and just wanted to add my vote for VMware to fix this after all these years.

0 Kudos