JBradford
Contributor
Contributor

Cannot attach keyboard to VM

Jump to solution

Hi everyone!

I've been having an odd problem both with the Friends & Family build from VMworld and now with the public beta where regardless of what VM I create/import I can't attach the keyboard. My iMac has an Apple Bluetooth keyboard & mouse. When I start a VM, and click inside it every key I press generates a beep and no input is passed to the VM. I've tried attaching a USB keyboard and have the same problem. It doesn't matter what guest OS I'm running as I have the same problem with trying to enter the VM's BIOS as well. Any ideas?

0 Kudos
65 Replies
jburnett
Contributor
Contributor

Yes. CheckPoint Secureclient with application intelligence - R56 Build number 001

0 Kudos
bgertzfield
Commander
Commander

Excellent. I've just gone through the entire list of OS library functions used by both Quicken Scheduler and CheckPoint SecureClient, and I found the culprit.

Both Quicken Scheduler and CheckPoint SecureClient use a Carbon function, EnableSecureEventInput(), to enable "secure" keyboard input to their program.

Unfortunately, that function seems to have a bug where it disables raw keyboard input to \*all* applications, even when Quicken or CheckPoint isn't the active application. And unfortunately, Quicken and CheckPoint never call DisableSecureEventInput() to turn "secure" keyboard input mode off, until they disconnect/shut down.

That breaks VMware Fusion, and many video games like Enigmo 2, which use raw keyboard input.

I'm researching workarounds now.

Thanks again for helping us track down this issue. Incompatibilities with third party software are some of the hardest bugs to diagnose and reproduce, so we really appreciate your support and tireless testing.

0 Kudos
jburnett
Contributor
Contributor

Nice job! Thanks everyone for all your help.

James

0 Kudos
rcardona2k
Immortal
Immortal

>Both Quicken Scheduler and CheckPoint SecureClient use a Carbon function, EnableSecureEventInput(), to enable "secure" keyboard input to their program.

Excellent find, Ben. This is a very good question for Apple. In fact, as a recovering Carbon developer my inclination is to head-patch EnableSecureEventInput() into a stub while any VM's input is grabbed. This might raise an eyebrow, but it's not like a VM's input is any more secure when someone is running ssh in the Guest. Conversely, you could disclose that the host's input may not be secure while running VMs. I definitely would not say a host is compromised[/i] without EnableSecureEventInput but rather impaired or input-challenged, as you prefer.

Also, interestingly, Googling "Patching EnableSecureEventInput" turns up this intruiging read:

http://rentzsch.com/macosx/terminalSecureKeyboardEntry

0 Kudos
xsee
Contributor
Contributor

So it has been 6 months, any progress? This is a really serious problem, and I don't wish to switch to paralells if its not necessary. however, I must have VPN and I must have VM's... Which is starting to rule out VMWare.

Chet

0 Kudos
cgruber
Contributor
Contributor

I encountered the problem as well today, and resolved it only by disabling bluetooth (I have a mighty-mouse bluetooth version) while starting up the vm, then re-enabling it when the vm was started. In that case I had good keyboard/mouse access. But somehow the VM does crazy things wtih input when external input devices are attached, per people's discoveries above.

christian.

0 Kudos