Highlighted
Contributor
Contributor

Can NOT get keyboard input when move mouse from mac to VM

Hi All,

Symptom:

I am running Mac EI Caption hosted Win7 os using VM fusion 8.5.9 with two screen.

When I move mouse from mac app ( for example : google ) back to VM win7 (say notepad)

I can use mac to select text in notepad but when I input using keyboard it shows in google.

Tried restart VM, reinstall VMtools, does not work!

Can anyone help?

0 Kudos
6 Replies
Highlighted
User Moderator
User Moderator

Hello,

I'm sorry, but I am not understanding what you are seeing:

but when I input using keyboard it shows in google.

Describe in a few more words what is happening here please.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Highlighted
Hot Shot
Hot Shot

You need to select the Fusion window as active for it to receive your keyboard input. Selecting text in your VM should already mark the Fusion window as active. Have you tried clicking anywhere in the VM and then typing? Just moving your mouse to the area of your screen occupied by the VM does not select it as active.

Imagine having a Web Browser and a Text Editor open side by side on your macbook. If you type something in your Text Editor and then move your mouse to the Browser, it won't automatically recognize the Browser window as active and capture your keyboard input.

Try to click anywhere in your VM before trying to type anything and let me know if you notice any difference. 

Cheers, Paul Wilk
0 Kudos
Highlighted
Contributor
Contributor

First thank you for your reply.

sdfSorry maybe it is not very clear for my initial post.

Setting:

I have iMac desktop and extended another monitor via thunderbolt port. 

I am running VM fusion Ver 8.5.9 on Mac EI caption hosted win7 X64 VM.

I always run win7 full screen on my iMac.  I can switch between mac UI & win7 on iMac.

Other monitor only run chrome and other Mac APP.

Symptom:

1. after restart VM In win7 open notepad++ (or any win7 app) , I can input text here.

2. mouse Move and click in chrome (or any other app) on  another monitor, I can input text without any issue.

3. WHEN move the mouse back to win7 notepad++, after click within notepad++ , I am expecting I can input text here,

   but actually all text input APPEARS in chrome on  another monitor!

Hope it is clear. It happened for quite a while but I can not fix it. I can ONLY click win7 notepad++ then swipe to switch to mac

and back, then I can got text input in win7. Sooooo annoying.

Please help.

0 Kudos
Highlighted
User Moderator
User Moderator

Hi,

Understood.

One thing you can try is to type "Ctrl+G" and see if it then allows you to type in NotePad++ instead of in the focused application at the host.

The problem you are seeing is because something is broken with the VMware Tools integration.

These type of issues are almost always due to a broken VMware Tools install at the guest OS.

Do not try a repair install from within the Guest OS as it likely will not fix this, unfortunately the "Reinstall VMware Tools" from the drop down menu also falls in that same category.

You really need the guest OS to reboot inbetween uninstall and install to make sure that all the files from VMware Tools are in the correct locations and of the correct version.

In short follow these steps:

  • Uninstall VMware Tools
  • Reboot guest OS
  • Install VMware Tools
  • Reboot guest OS.

A bit of a longer description is:

  • In the guest Windows operating system, go to Control Panel -> Programs & Features -> Select VMware Tools -> Uninstall
  • Follow the steps from the installer to completely uninstall VMware Tools
  • Reboot the guest OS.
  • Then from the Virtual Machine menu select "Install VMware Tools"

If no installer appears, go to the DVD-rom within windows and click "setup" (for 32 bits windows) or "setup64" (for 64 bits windows)

Once you see an installer, click "Next" until Finish, keep the defaults.

Reboot the guest when done installing (it will ask by itself to reboot)

BTW, Fusion 8.5.10 has been released and I suggest to update to that if you can.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Highlighted
Contributor
Contributor

hi wila,

Thank you for your help.

Once I upgraded to 8.5.10 and restart VM it looks ok for now even before I try you solution.

Will try it if it does not work in future .

0 Kudos
Highlighted
Contributor
Contributor

Hi,

After Easter I came back to office and turn on the iMac.  It does not work again.

This time I exactly follow the Steps that Wila posted but no luck.

I even shutdown & restart VM but it does NOT help. 

Any suggestions?

0 Kudos