Contributor
Contributor

Bridged mode via WIFI cannot connect to domain network

Retina Macbook Pro

Mountain Lion

VMWare Fusion 4.1.3

Windows 7 Professional VM

When I set the network preferences to 'NAT' communication is fine. This is also true if I set the network preference to 'Bridged' and select a physical ethernet adaptor connected to my domain network.

However if I select the WIFI adaptor as my bridged connection preference, I connect (get an IP address assigned) but do not achieve any DNS connectivity and subsequently cannot make outbound connections from the VM.

I have searched for solutions but have found none for my scenario. I have tried removing McAfee Enterprise and Agent - no change. Tried disconnecting the adaptor and forcing a new lease - no change.

Any ideas?

0 Kudos
6 Replies
Champion
Champion

Upgrade to Fusion 5 if you're on 10.8.  It has much better support.

Some networks only allow a single IP per MAC address - is yours configured that way?

0 Kudos
Contributor
Contributor

I'm seeing something that may be similar.

2012 Macbook Pro 15"

Mountain Lion 10.8

VMWare Fusion 4.1.3

Windows XP SP3 guest

We are in a domain, but this guest is not joined to a domain.

I was not getting an IP address assigned while I was connected to the WiFi network. The guest is Bridged, Automatic. As soon as I plugged in to the wired network on my Macbook, my guest had networking.

chris

0 Kudos
Champion
Champion

Definitely try NAT, and Fusion 5 may also be helpful.

Last, I'd ask your network folks if they have it configured to only issue on IP per mac address (my company does that at some locations).

0 Kudos
Contributor
Contributor

Having this problem as well, and I am on Fusion 5. NAT works fine, Bridged never gets an IP address. Running Windows 7 x64 and latest Mountain Lion.

The Retina MBP is only using Wifi, I don't have a Thunderbolt to Ethernet adapter.

What's the fix?

0 Kudos
Contributor
Contributor

I am running an upgraded Windows 8 (Up from XP pack 3) and all works except there is no network connection. I am also on a Macbook Retina with latest Mountain Lion and Fusion 5. I am interested in seeing any solutions. I have tried NAT, Bridged (Autodetect), Bridged (WiFi), and Bridged Thunderbolt Ethernet).

Thanks in advance.

0 Kudos
Contributor
Contributor

I may have solved this myself. Went to VMWARE FUSION-->Preferences->Network and unlocked the pane. Clicked the "+" button to add custom menu. "vmnet5" automatically showed up. First went with default (no check on first button "Allow virtual machines... (using NAT).") and the other two checked but the bottomn one greyed out on Subnet IP & Subnet Mask." Clicked Apply. Nothing happened after restart (on Bridged (Wifi)). Then reopened preference pane (VMWARE FUSION-->Preferences->Network) and click vmnet 5 again. Clicked top button and automatic subnet and mask address appeared. Switched Network Adapter in Fusion 5 toolbar to NAT.  Restarted Win 8 and it opened. Was able to connect to internet via WIFI bridged on my Mac.

Hope that helps.

Patrick

0 Kudos