meaghersclasses
Contributor
Contributor

Boot Camp not prepared to run as virtual machine

Jump to solution

Hi,

I just received my copy of a recently purchased VMware fusion to use as a means to run my existing Windows XP SP2 Boot Camp partition in the Mac environment on my MacBook (2.16GHz Intel Core 2 Duo, 1GB 667MHz DDR2 SDRAM with the startup disk as the Mac partition) running Mac OSX 10.4.10. I have need on occassions to use Windows applications, and from the description of Fusion it appeared that to be able to simply use the existing Windows boot Camp partition would be a simple solution to my needs. On installing Fusion from the disk that I'd purchased, the Boot Camp partition wasn't automatically detected, the version of Fusion that I received was version 1, so I updated to version 1.1.0 62573, and happily it did recognise my Boot Camp partition.

However when I select it and RUN after the message 'VMWare Fusion is preparing your Boot Camp partition to run as a virtual machine.' I received the message 'The Boot Camp partition is not prepared to run as a virtual machine. It appears that Windows did not shut down cleanly the last time it was used. To shut down Windows cleanly, go to System Preferences > Startup Disk and set Windows as the startup operating system. Restart your system. Once in Windows, use the Startup Disk pane in the Control Panel to select Mac OS X as the startup system, then click the Restart button to return to OS X.' I have done this a number of times (along with other methods of shutting down in both Mac and or Windows and booting up in each in a variety of combinations) and still get the same message. This is frustrating as I purchased the software hoping for any easy instal and use. Hopefully there is an easy solution to my difficulty.

Thanks,

Richard.

0 Kudos
1 Solution

Accepted Solutions
sgastevep
Enthusiast
Enthusiast

Thanks to etung for that added bit of info about not needing to constantly re-activate windows. As I say, I'm not affected by it with the volume licensing I have but I sure don't want to be giving out bad information.

Okay, back to the constantly "preparing partition" question.

I still think your base problem is the same as mine... My Disk Utility also identified the drive as NTFS, but in fact it really wasn't. To me, the giveaway in the vmware.log is this:

Dec 07 19:42:29.955: vcpu-0| VIDE: Curr CHS info cyls: 17475 heads: 15 sects: 63 lba_cap: 234441648

Dec 07 19:42:29.979: vcpu-0| Guest: mounting FAT32

Dec 07 19:42:30.024: vcpu-0| Guest: 401 reconfig : unable to mount Windows disk as NTFS or FAT32

Dec 07 19:43:32.101: vcpu-0| PIIX4: PM Soft Off. Good-bye.

VMWare is trying to mount your drive as FAT32 based on the partition table type not the filesystem type. VMWare should really fix this, because both Windows and MacOS themselves are smart enough to suss out the volume type without regard to the partition type flag. If it failed above, it should at least re-try as NTFS (which I don't see any sign of it doing).

I don't understand about why fdisk gave you a scare just to run it, or maybe you were scared by the obligatory first-time sudo warning... In any event, this command will give that information and WILL NOT harm your data, it only prints a bit to the terminal and doesn't change or update ANYTHING.

sudo fdisk /dev/rdisk0

You will get the scary bit of info before you put in your password, but this command in that format is safe. The post I'll mention below shows you how to fix the problem if the type is set wrong, and at that point there is potential for damage, but there is not yet. I say "potential", because it's there, but in reality it should be quite safe. I did it and survived, and in fact that was the only way I got Fusion to work for me here.

I was going to paste in my output from the above, but this editor won't let me preserve it and it messes it all up. See if you can view this:

fdisk example

I really think that the fix is the same as mine, but it will require you to use that scary 'fdisk' terminal command.... There was another post here with instructions already:

http://communities.vmware.com/message/803951

Look for the reply by user "MandarMS".

You need to set the type of your boot camp partition to 07. If it already is, then I apologize for wasting your time and hope the VMWare guys can offer some more insight on this one.

View solution in original post

0 Kudos
14 Replies
BP9906
Expert
Expert

You could try deleting the Bootcamp VM created (wont affect bootcamp install) and restart Fusion to have it re-created.

Check out the last 2 postings here: http://communities.vmware.com/message/803908

0 Kudos
sgastevep
Enthusiast
Enthusiast

My system was working great, but had some damage to the Macintosh partition catalog that couldn't be fixed by Disk Utility. I thought it would be a good opportunity to test the Time Machine full system restore, so I re-formatted the Macintosh partition and let Time Machine restore from the boot cd and backup drive. All went well until I tried to run VMWare...

I get the perpetual cycle you have... Preparing partition and then saying Windows wasn't shut down cleanly. It was. Many Times.

Parallels still works, but I would prefer to use Fusion. Boot Camp works fine if booted directly also.

The Boot Camp partition was not touched, so I don't know why Fusion thinks it needs "preparing", it should already have the required modifications in place from when it was working before.

I'll attach the vmware log files from the "Helper" VM.

I think the trouble spot is this line in the log file:

Guest: 401 reconfig : unable to mount Windows disk as NTFS or FAT32

However, the drive mounts fine in MacOS X as an NTFS drive, Parallels can see it, it will boot straight into windows as an NTFS drive, and I even ran XP's repair procedure and it came up clean.

Steve

0 Kudos
BP9906
Expert
Expert

I dont see the log files.

Also, try removing the Helper VM for Bootcamp and restart Fusion. Fusion should auto rebuild the BC VM.

0 Kudos
sgastevep
Enthusiast
Enthusiast

Strange, they were selected to be attached and I'm almost sure I saw them being uploaded, but oh well....

I had deleted everything in the virtual machines folder, no change.

However, reading through MANY posts, and coupled with that error I saw in the logs about not being able to mount the drive gave me a tip.

Originally the boot camp partition was a DOS/FAT32 partition, and at some point I did a conversion to NTFS. However, the partition table type wasn't ever updated, so I think Fusion was trying to mount a FAT32 volume based on the partition type alone instead of looking at the filsystem data itself to see what type it was.

I changed the partition type and then Fusion rebuilt all the virtual machine stuff properly on the next run and it seems to be great now.

Thanks,

Steve

0 Kudos
meaghersclasses
Contributor
Contributor

Hi thanks for your response and the idea, however I have never had never a Boot Camp VM, working or not, created.

I tried deleting, before trying a restart and 'clean' shut down of the Boot Camp partition, the folder (...Application Support/VMware Fusion/Virtual Machines/Boot Camp) which should, I assume, eventually contain the virtual machine, once prepared, - but continue to get the message about the Boot Camp partition not shutting down cleanly and not being able to be prepared to run as a virtual machine. And therefore have never had a VM created.

I don't really have enough hard drive space to consider creating a new Windows VM on my Mac drive, the reason I bought Fusion initially.

0 Kudos
sgastevep
Enthusiast
Enthusiast

I don't see a log file in your previous posts, could you post one?

If you are in finder, navigate to this path:

(from your home folder)

Library/Application Support/VMWare Fusion/Virtual Machines/Helper

Control-Click on the file: naos-1.0.vmwarevm

Select "Show Packge Contents"

The file (or files) of interest are the ones ending in .log, vmware.log being the most recent.

That was what tipped me off to my problem, so if you post yours I'd be happy to take a look and see if I can help you any further, but even if I can't the folks at VMWare would find that information useful.

Steve

sgastevep
Enthusiast
Enthusiast

One more thing I thought I'd mention to you that came to mind after re-reading your initial post....

You do realize that with XP's activation, you can not take a single XP license and switch back and forth between Boot Camp and VMWare... Each one presents itself as a very different "computer" to the installed Windows XP system and so Windows will want you to re-activate each time you switch. Luckily for me, I work for a large organization that has volume licensing and this doesn't happen, but I also had them set aside two "licenses" for my use just to be completely on the up-n-up. I don't agree with it, but it is the terms of the license.

Also, do you know what filesystem your boot camp installation is using? Is it NTFS or is it FAT-32? You could tell by (at least this is one way I know of finding out, anyway) going into Windows and from the Start menu going to Run... and typing in: compmgmt.msc

Select "Storage" in the right pane, then "Disk Management(local)". In the right pane of your final destiation, you should see a visual breakdown of how your drive is partitioned, and the partition for C: will list the file system type as either FAT32 or NTFS.

Or you can go to a COMMAND box (Start->Programs->Accessories->CommandPrompt, and run:

diskpart

at the prompts, issue these commands:

DISKPART> select disk 0

DISKPART> list volume

That should give you a listing that also indicates the file system on your C: drive.

Then, to see if you had a similar problem to mine, from MacOS X's terminal (sorry, don't know how to do this from inside Windows), issue this command and send back the output in your next post:

sudo fdisk /dev/disk0

This is non-destructive, and will list your partition types for your primary hard drive.

meaghersclasses
Contributor
Contributor

Hi,

And thanks for your offers of assistance.

I have attached the latest log, and verified that the file system type for my boot camp partition as NTFS. When I tried the sudo command in Terminal I gutlessed out when given a warning about potential loss of data, and so used disk utility to look at each partition. There are 3: ‘Macintosh’ – which is identified as a Mac OS Extended (Journaled), as is ‘User_Data’. And the third is ‘Untitled’ and is identified as Windows NT filesystem.

I was unaware of the need to reactivate the XP license each time I switch – a pain, but I’m sure that the license that we have will ensure that I will be operating legally if I obtain the activation code from our network administrator. (The machine belongs to the school I work at. Most staff are using Windows laptops, but many kids (and the media and music depts are using Macs) and our state’s ed dept has an agreement with Microsoft allowing staff machines to use Microsoft products. I have been given the MacBook to enable me to show staff in both environments how to effectively use various software packages to engage students, thus the desire to easily swap between environments. The machine was set up with the three partitions by a network administrator – who has now left, and so I had nothing to do with its configuration.)

I do appreciate your time.

Regards,

Richard Meagher

0403 988 352

http://www.meaghersclasses.podomatic.com

http://www.meaghersphysics.podomatic.com

http://www.meaghersscience.podomatic.com

0 Kudos
admin
Immortal
Immortal

Each one presents itself as a very different "computer" to the installed Windows XP system

Right.

and so Windows will want you to re-activate each time you switch.

Once you install VMware Tools, you should not have to reactivate every time (you may need to reactivate the first time you switch).

0 Kudos
sgastevep
Enthusiast
Enthusiast

Thanks to etung for that added bit of info about not needing to constantly re-activate windows. As I say, I'm not affected by it with the volume licensing I have but I sure don't want to be giving out bad information.

Okay, back to the constantly "preparing partition" question.

I still think your base problem is the same as mine... My Disk Utility also identified the drive as NTFS, but in fact it really wasn't. To me, the giveaway in the vmware.log is this:

Dec 07 19:42:29.955: vcpu-0| VIDE: Curr CHS info cyls: 17475 heads: 15 sects: 63 lba_cap: 234441648

Dec 07 19:42:29.979: vcpu-0| Guest: mounting FAT32

Dec 07 19:42:30.024: vcpu-0| Guest: 401 reconfig : unable to mount Windows disk as NTFS or FAT32

Dec 07 19:43:32.101: vcpu-0| PIIX4: PM Soft Off. Good-bye.

VMWare is trying to mount your drive as FAT32 based on the partition table type not the filesystem type. VMWare should really fix this, because both Windows and MacOS themselves are smart enough to suss out the volume type without regard to the partition type flag. If it failed above, it should at least re-try as NTFS (which I don't see any sign of it doing).

I don't understand about why fdisk gave you a scare just to run it, or maybe you were scared by the obligatory first-time sudo warning... In any event, this command will give that information and WILL NOT harm your data, it only prints a bit to the terminal and doesn't change or update ANYTHING.

sudo fdisk /dev/rdisk0

You will get the scary bit of info before you put in your password, but this command in that format is safe. The post I'll mention below shows you how to fix the problem if the type is set wrong, and at that point there is potential for damage, but there is not yet. I say "potential", because it's there, but in reality it should be quite safe. I did it and survived, and in fact that was the only way I got Fusion to work for me here.

I was going to paste in my output from the above, but this editor won't let me preserve it and it messes it all up. See if you can view this:

fdisk example

I really think that the fix is the same as mine, but it will require you to use that scary 'fdisk' terminal command.... There was another post here with instructions already:

http://communities.vmware.com/message/803951

Look for the reply by user "MandarMS".

You need to set the type of your boot camp partition to 07. If it already is, then I apologize for wasting your time and hope the VMWare guys can offer some more insight on this one.

View solution in original post

0 Kudos
meaghersclasses
Contributor
Contributor

You are a legend Steve!

I now have a working Boot Camp VM. Your apology for potentially wasting my time is definitely not warranted. I very much appreciate the time that you have taken to assist. For interest the following is what I got when using sudo:

Initially:

Disk: /dev/rdisk0 geometry: 14593/255/63

Signature: 0xAA55

Starting Ending

#: id cyl hd sec - cyl hd sec

-


1: EE 1023 254 63 - 1023 254 63

2: AF 1023 254 63 - 1023 254 63 HFS+

3: AF 1023 254 63 - 1023 254 63 HFS+

*4: 0B 1023 254 63 - 1023 254 63 Win95 FAT-32

After altering:

Disk: /dev/rdisk0 geometry: 14593/255/63

Signature: 0xAA55

Starting Ending

#: id cyl hd sec - cyl hd sec

-


1: EE 1023 254 63 - 1023 254 63

2: AF 1023 254 63 - 1023 254 63 HFS+

3: AF 1023 254 63 - 1023 254 63 HFS+

*4: 07 1023 254 63 - 1023 254 63 HPFS/QNX/AUX

Thanks again for all your help,

Regards,

Richard Meagher

0403 988 352

http://www.meaghersclasses.podomatic.com

http://www.meaghersphysics.podomatic.com

http://www.meaghersscience.podomatic.com

0 Kudos
sgastevep
Enthusiast
Enthusiast

I'm glad I was able to help, that's what these community forums are for. Enjoy your newfound flexibility with what Fusion offers. I love it. By the way, I personally no longer use boot camp any more, I always use Fusion. Since I don't have the need to reboot into Windows, I was frustrated that VMWare Fusion will only "suspend" your system if you use a drive image, not with boot camp. It turns out there is a small modification you can make that will allow you to suspend your VMWare Fusion boot camp session as well, and so suspend/resume time is only a few seconds instead of the normal bootup/shutdown time.

The caveat is that if you forget you had suspended VMWare, and then do something that alters your boot camp partition (booting up in boot camp is one thing, but there are others) and then resume your VMWare session, damage will happen because VMWare doesn't know that things have changed and will blissfully go on thinking it has a perfectly valid notion of what your filesystem looks like.

So, I enjoy the suspend/resume times and take extra care to not let anything touch my boot camp partition. If I need to reboot natively into windows, I just fire up VMWare, shut down the virtual machine, and then reboot and do what I need.

Search the forums for info on that little hack... Basically you go to your boot camp configuration (.vmwarevm package file) in the Virtual Machines folder, right click to show package contents, and edit the .vmx file. There is a line in there that should be obvious about allowing suspend, just change it to work as you'd like, save that .vmx file, and on next restart of your virtual machine it should allow you to suspend it... The option is labelled suspend.disabled and is set to TRUE, change it to FALSE and you are all set.

Again, glad I could help, and enjoy.

Steve

0 Kudos
rainierez
Contributor
Contributor

Ok I've reviewed this thread and other but still ha having this problem. When checking the partition in terminal it seems to be set correctly:

Disk: /dev/rdisk0 geometry: -5415437/4/63

Signature: 0xAA55

Starting Ending

#: id cyl hd sec - cyl hd sec

-


1: EE 1023 254 63 - 1023 254 63

2: AF 1023 254 63 - 1023 254 63 HFS+

*3: 07 1023 254 63 - 1023 254 63 HPFS/QNX/AUX

4: 00 0 0 0 - 0 0 0 unused

But when i review the logs it seems to still be the same problem as described below:

Apr 11 09:12:40.817: vcpu-0| SCSI (ide0:0): SCSI-3 16-byte CDB format not supported (LUN 0).

Apr 11 09:12:40.820: vcpu-0| Guest: NTFS mount failed; trying FAT32

Apr 11 09:12:40.843: vcpu-0| SCSI (ide0:0): SCSI-3 16-byte CDB format not supported (LUN 0).

Apr 11 09:12:40.847: vcpu-0| Guest: 401 reconfig : unable to mount Windows disk as NTFS or FAT32

Apr 11 09:13:45.076: vcpu-0| PIIX4: PM Soft Off. Good-bye.

I've attached the whole log. If you have a second to review it, let me know what you guys think.

0 Kudos
jimcarroll
Contributor
Contributor

I've followed this thread, and the thread here:

http://communities.vmware.com/message/803951

and still cannot get things to work.

I upgraded to a 500MB disk on my MacBook Pro. I cloned my Boot Camp drive (Win XP) using WinClone.

I can boot into BootCamp directly, and everything works fine.

I get the dreaded error above when I try to use VMWare; I suspect because my Windows disk isn't appearing as FAT32, but as "HPFS/QNX/AUX"

Disk: /dev/rdisk0 geometry: 60801/255/63

Signature: 0xAA55

Starting Ending

#: id cyl hd sec - cyl hd sec

-


1: EE 0 0 2 - 25 127 14

2: AF 25 127 15 - 1023 110 52 HFS+

*3: 07 1023 223 46 - 1023 80 15 HPFS/QNX/AUX

4: 00 0 0 0 - 0 0 0 unused

jim-carrolls-macbook-pro-3:~ Jim$

Any thoughts? I tried the fix on the post mentioned above, with no luck.

0 Kudos