Back2Mac
Contributor
Contributor

Big Sur has killed my VM

I upgraded to Big Sur on my iMac yesterday.  I have been unable to run my Windowsn 10 VM since.

I open the VM, and am greeted by an error message:

"You are running this machine with side channel mitigations enabled.

Side channel mitigations provide enhanced security but also lower performance.

To disable mitigations, change the side channel mitigations setting in the advanced panel of the virtual machine settings. Refer to VMware KB article 79832 at https://kb.vmware.com/s/article/79832 for more details."

I clock the OK dialog box and then get this message:

"VMWare Fusion does not support virtualized performance counters on this host.

Module 'VPMC' power on failed.

Failed to start the virtual machine"

I first went to settings to disable side channel mitigation, but the box is grayed out.  I can't disable it.  I linked to the knowledge base article, but it is non-existent.

I can't make progress on issue #1, and have no idea what to do about issue #2.

I run Windows for work, and desperately need to be able to get into it.  Please help.  I look forward to all answers.

Thank you.

 

- Brian

5 Replies
wila
Leadership
Leadership

Hello Brian,

For the side channel mitigations warning being shadowed, could it be that your VM is suspended instead of shut down?
As you can't start it anymore after you upgraded, you'll have to force a power off.
You can do that by holding down the option key, then go to the Virtual Machine menu and select "Power Off".
After that the side channel mitigations option in the advanced sheet under settings should be unshadowed.

As for the other topic...

Starting with macOS Big Sur VMware has to use the Hypervisor Framework as is provided by apple. The result of that is that currently some features do not work on a number of processors (even very current processors!) The missing features are Performance counters and nested virtualisation.

In order to start your VM you have to go to the menu "Virtual Machine" -> settings -> Processors & Memory -> open Advanced options and then make sure the following checkboxes are unchecked:

  • Enable Hypervisor applications in this virtual machine
  • Enable code profiling applications in this virtual machine

see also this thread

hope this helps,
--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Back2Mac
Contributor
Contributor

Wil,

I ran into your solution on another thread.  Thank you.

I eventually figured out I could kill the suspended machine using the option key.  Did that, changed the settings, and I'm back in business.

Thank you!

- Brian

0 Kudos
wila
Leadership
Leadership

Hello Brian,

You're welcome!
Seems like I am doing a bit of post Big Sur update help for VMware Fusion users this weekend. 😂🤣

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Tlater
Contributor
Contributor

Thanks for this Wila. I was paranoid, so I read through all of your Big Sur posts before upgrading for use with Windows 8.1, but all went smoothly.

Based on your previous advice, I bought the latest iMac because I wanted to get the last of the non-Apple chips. Hopefully, that will help me avoid chip compatibility problems. Arrived yesterday, so that's next on my list.

I may come begging for help next week! 🙂

At least all works well on my current iMac (late-2014) so I shouldn't have panic-inducing work stoppages!

Appreciate all of your help!